Bug 1153048 - yum update problem between xcb-util qt5-qtbase-gui
Summary: yum update problem between xcb-util qt5-qtbase-gui
Status: CLOSED ERRATA
Alias: None
Product: Fedora EPEL
Classification: Fedora
Component: qt5-qtbase   
(Show other bugs)
Version: el6
Hardware: x86_64
OS: Linux
unspecified
medium
Target Milestone: ---
Assignee: Ngo Than
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
: 1157202 1159633 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-10-15 13:42 UTC by sebastian.luna.valero
Modified: 2014-11-06 03:49 UTC (History)
12 users (show)

Fixed In Version: qt5-qtbase-5.3.2-3.el6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-10-31 01:27:38 UTC
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description sebastian.luna.valero 2014-10-15 13:42:28 UTC
Description of problem:
When I try to update, I get this problem with yum:

Resolving Dependencies
--> Running transaction check
---> Package xcb-util.x86_64 0:0.3.6-1.el6 will be updated
--> Processing Dependency: libxcb-icccm.so.1()(64bit) for package: qt5-qtbase-gui-5.3.2-1.el6.x86_64
--> Processing Dependency: libxcb-image.so.0()(64bit) for package: qt5-qtbase-gui-5.3.2-1.el6.x86_64
--> Processing Dependency: libxcb-keysyms.so.1()(64bit) for package: qt5-qtbase-gui-5.3.2-1.el6.x86_64
---> Package xcb-util.x86_64 0:0.3.6-5.el6 will be an update
---> Package xcb-util-devel.x86_64 0:0.3.6-1.el6 will be updated
---> Package xcb-util-devel.x86_64 0:0.3.6-5.el6 will be an update
--> Running transaction check
---> Package xcb-util.x86_64 0:0.3.6-1.el6 will be updated
--> Processing Dependency: libxcb-icccm.so.1()(64bit) for package: qt5-qtbase-gui-5.3.2-1.el6.x86_64
---> Package xcb-util-image.x86_64 0:0.3.9-4.el6 will be installed
---> Package xcb-util-keysyms.x86_64 0:0.3.9-5.el6 will be installed
--> Finished Dependency Resolution
Error: Package: qt5-qtbase-gui-5.3.2-1.el6.x86_64 (@epel)
           Requires: libxcb-icccm.so.1()(64bit)
           Removing: xcb-util-0.3.6-1.el6.x86_64 (@rhel-x86_64-server-6)
               libxcb-icccm.so.1()(64bit)
           Updated By: xcb-util-0.3.6-5.el6.x86_64 (rhel-x86_64-server-6)
               Not found
 You could try using --skip-broken to work around the problem


How reproducible:
Anytime you want to update.

Steps to Reproduce:
yum update

Expected results:
The update of xcb-util should not affect qt5-qtbase-gui.

Additional info:
It happens when switching from RHEL 6.5 to RHEL 6.6

Comment 1 Anssi Johansson 2014-10-15 14:07:12 UTC
This bug should have been filed against qt5-qtbase, not yum.

Comment 2 Rex Dieter 2014-10-15 14:13:57 UTC
OK, to be clear, seems the newer RHEL xcb-util package lost libxcb-icccm.so.1 ?  (If so, that's not nice :( )

Comment 3 Fedora Update System 2014-10-17 20:39:21 UTC
qt5-qtbase-5.3.2-3.el6 has been submitted as an update for Fedora EPEL 6.
https://admin.fedoraproject.org/updates/qt5-qtbase-5.3.2-3.el6

Comment 4 Fedora Update System 2014-10-19 04:01:29 UTC
Package qt5-qtbase-5.3.2-3.el6:
* should fix your issue,
* was pushed to the Fedora EPEL 6 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=epel-testing qt5-qtbase-5.3.2-3.el6'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-EPEL-2014-3484/qt5-qtbase-5.3.2-3.el6
then log in and leave karma (feedback).

Comment 5 sebastian.luna.valero 2014-10-20 08:42:01 UTC
Many thanks for all your support, it works!

Comment 6 Rex Dieter 2014-10-26 03:36:11 UTC
*** Bug 1157202 has been marked as a duplicate of this bug. ***

Comment 7 Ketan Padegaonkar 2014-10-29 03:24:39 UTC
Thanks for pushing this out so fast. Is there any ETA when this will be generally available?

Comment 8 Rex Dieter 2014-10-29 13:38:54 UTC
It's currently queue'd for stable updates, so whenever the next updates push happens.  That typically happens most every day (or 2).

Comment 9 Fedora Update System 2014-10-31 01:27:38 UTC
qt5-qtbase-5.3.2-3.el6 has been pushed to the Fedora EPEL 6 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 10 Dave Johansen 2014-11-06 03:49:05 UTC
*** Bug 1159633 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.