Bug 1153472 - Free space field in confirmation_page should not display 0MB always.
Summary: Free space field in confirmation_page should not display 0MB always.
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-node
Version: 3.5.0
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: ovirt-3.6.2
: 3.6.0
Assignee: Ryan Barry
QA Contact: Ying Cui
URL:
Whiteboard:
Depends On:
Blocks: rhevh-7.0
TreeView+ depends on / blocked
 
Reported: 2014-10-16 04:53 UTC by Ying Cui
Modified: 2016-03-09 14:15 UTC (History)
6 users (show)

Fixed In Version: ovirt-node-3.6.1-1.0.el7
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-03-09 14:15:18 UTC
oVirt Team: Node


Attachments (Terms of Use)
remaining space (9.40 KB, image/png)
2014-10-16 04:56 UTC, Ying Cui
no flags Details
free space (11.50 KB, image/png)
2014-10-16 04:56 UTC, Ying Cui
no flags Details
new screenshot for free space (16.19 KB, image/png)
2015-12-09 07:19 UTC, Ying Cui
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2016:0378 normal SHIPPED_LIVE ovirt-node bug fix and enhancement update for RHEV 3.6 2016-03-09 19:06:36 UTC
oVirt gerrit 34371 master MERGED Show free space in the confirmation page Never
oVirt gerrit 50198 master MERGED Only set free space to 0 if fill_data is actually set 2015-12-22 11:56:54 UTC
oVirt gerrit 50913 ovirt-3.6 MERGED Only set free space to 0 if fill_data is actually set 2015-12-22 15:00:28 UTC

Description Ying Cui 2014-10-16 04:53:39 UTC
Description of problem:
During RHEVH installing, in confirmation page of the installer, the free space field is always 0MB whatever how much is remaining space.


Version-Release number of selected component (if applicable):
rhev-hypervisor7-7.0-20140918.0.iso
ovirt-node-3.1.0-0.13.20140918gitdda78cb.el7.noarch
Red Hat Enterprise Virtualization Hypervisor release 7.0 (20141006.0.el7ev)
ovirt-node-3.1.0-0.20.20141006gitc421e04.el7.noarch


How reproducible:
100%

Steps to Reproduce:
1. rhevh 7.0 build installation.
2. resize partition size to make remaining space NOT 0MB. example: 500MB

Actual results:
Turn to confirmation page of the installer, free space field is always 0MB

Expected results:
free space should be remaining space size?, but not always 0MB

Comment 1 Ying Cui 2014-10-16 04:56:10 UTC
Created attachment 947409 [details]
remaining space

Comment 2 Ying Cui 2014-10-16 04:56:37 UTC
Created attachment 947410 [details]
free space

Comment 5 Ying Cui 2015-10-10 07:31:06 UTC
Verified this bug on build rhev-hypervisor7-7.2-201509280, ovirt-node-3.3.0-0.10.20150928gite7ee3f1.el7ev.noarch

The free space is not always 0 on this build.
But here still has a new bug 1270448 to trace the new issue.

Comment 6 Ying Cui 2015-12-09 07:18:20 UTC
I have to reopen this bug on build rhev-hypervisor7-7.2-20151201.2(ovirt-node-3.6.0-0.23.20151201git5eed7af.el7ev.noarch)

The free space is always 0 during on build rhev-hypervisor7-7.2-20151201.2 installation.

And the regression happens on build rhev-hypervisor7-7.2-20151201.2(ovirt-node-3.6.0-0.23.20151201git5eed7af.el7ev.noarch)

Comment 7 Ying Cui 2015-12-09 07:19:07 UTC
Created attachment 1103803 [details]
new screenshot for free space

Comment 8 Ryan Barry 2015-12-09 15:27:51 UTC
There were no patches which touched this area inbetween these builds, but I'll grab 1201 and take a look.

Comment 10 Ying Cui 2015-12-30 02:49:35 UTC
Verified this bug on build rhev-hypervisor7-7.2-20151229.0(ovirt-node-3.6.1-1.0.el7ev)
The free space is not always 0 on this build, the free space size is remaining space size.

Comment 12 errata-xmlrpc 2016-03-09 14:15:18 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-0378.html


Note You need to log in before you can comment on or make changes to this bug.