Bug 115369 - /usr/X11R6/lib/xscreensaver/fortune contains wrong fortune location
Summary: /usr/X11R6/lib/xscreensaver/fortune contains wrong fortune location
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: xscreensaver   
(Show other bugs)
Version: 1
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Bill Nottingham
QA Contact:
URL:
Whiteboard:
Keywords:
: 119898 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-02-11 15:37 UTC by Hans de Goede
Modified: 2014-03-17 02:42 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-03-31 15:42:41 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Hans de Goede 2004-02-11 15:37:17 UTC
/usr/X11R6/lib/xscreensaver/fortune

Contains /usr/games/fortune as fortune binary, but when using the
fortune version from the fedora.us repository, fortune is
/usr/bin/fortune.

People not using fedora.us and having an old fortune from when redhat
was still shipping fortune however do have fortune as /usr/games/fortune

To make the problem more fun /usr/games/fortune does exist when using
the fortune package from fedora.us, but it is a directory, so the -x
test succeeds.

My bash isn't all that good, but this should be fixable easily by
testing for both fortunes and testing that /usr/games/fortune is not a
dir.

Comment 1 Karsten Hopp 2004-03-31 15:42:41 UTC
fixed in xscreensaver-4.14-4

Comment 2 Bill Nottingham 2004-04-02 22:55:45 UTC
*** Bug 119898 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.