Bug 119898 - xscreensaver does not properly display fortunes when running an appropriate fortune based screensaver
Summary: xscreensaver does not properly display fortunes when running an appropriate f...
Status: CLOSED DUPLICATE of bug 115369
Alias: None
Product: Fedora
Classification: Fedora
Component: xscreensaver   
(Show other bugs)
Version: 1
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Bill Nottingham
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-04-02 22:54 UTC by Christofer C. Bell
Modified: 2014-03-17 02:43 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 19:02:22 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Christofer C. Bell 2004-04-02 22:54:41 UTC
Description of problem:

/usr/X11R6/lib/xscreensaver/fortune contains an error.  It points 
to /usr/games/fortune to generate fortune text when the correct 
binary location is /usr/bin/fortune.

Version-Release number of selected component (if applicable):

xscreensaver-4.14-2

How reproducible:

Every time.

Steps to Reproduce:
1. Install xscreensaver and fortune packages
2. Use xscreensaver preview mode to preview any screensaver that 
prints fortunes (or set to random and just wait for one)
3. Observe the error that /usr/games/fortune is a directory.
  
Actual results:

User sees /usr/games/fortune is a directory error.

Expected results:

User sees fortunes displayed as screensavers.

Additional info:

The script /usr/X11R6/lib/xscreensaver reads:

#!/bin/sh
if [ -x /usr/games/fortune ]; then
        /usr/games/fortune $*
else
        cat /etc/redhat-release
        uname -sr
        uptime
fi

Should read:

#!/bin/sh
if [ -x /usr/bin/fortune ]; then
        /usr/bin/fortune $*
else
        cat /etc/redhat-release
        uname -sr
        uptime
fi

Note that this file also displays /etc/redhat-release if fortune is 
not installed.  This may need to be updated in future versions to 
display the correct version file.

Comment 1 Bill Nottingham 2004-04-02 22:55:44 UTC

*** This bug has been marked as a duplicate of 115369 ***

Comment 2 Red Hat Bugzilla 2006-02-21 19:02:22 UTC
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.


Note You need to log in before you can comment on or make changes to this bug.