Bug 115413 - Compile: Error including freetype headers
Compile: Error including freetype headers
Status: CLOSED DUPLICATE of bug 114682
Product: Fedora
Classification: Fedora
Component: ttmkfdir (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Yu Shao
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-02-11 20:27 EST by Ivan Gyurdiev
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 14:01:10 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ivan Gyurdiev 2004-02-11 20:27:13 EST
+ make 'OPTFLAGS=-O2 -g -pipe -march=athlon' libtool --mode=compile
g++ -Wall -pedantic -I/usr/include/freetype2 -ggdb -O2 -g -pipe
-march=athlon -o ttmkfdir.o -c ttmkfdir.cpp
mkdir .libs  g++ -Wall -pedantic -I/usr/include/freetype2 -ggdb -O2 -g
-pipe -march=athlon -c ttmkfdir.cpp  -fPIC -DPIC -o .libs/ttmkfdir.o
In file included from ttf.h:6,
                 from ttmkfdir.cpp:8:
/usr/include/freetype2/freetype/freetype.h:20:2: #error "`ft2build.h'
hasn't been included yet!"
/usr/include/freetype2/freetype/freetype.h:21:2: #error "Please always
use macros to include FreeType header files."
/usr/include/freetype2/freetype/freetype.h:22:2: #error "Example:"
/usr/include/freetype2/freetype/freetype.h:23:2: #error "  #include
<ft2build.h>"
/usr/include/freetype2/freetype/freetype.h:24:2: #error "  #include
FT_FREETYPE_H"
In file included from ttmkfdir.cpp:8:
ttf.h:11:31: freetype/ftmodule.h: No such file or directory
make: *** [ttmkfdir.o] Error 1
error: Bad exit status from /var/tmp/rpm-tmp.11319 (%build)
                                                                     
                                                       
                                                                     
                                                       
RPM build errors:
    Bad exit status from /var/tmp/rpm-tmp.11319 (%build)
Comment 1 Yu Shao 2004-02-12 18:07:58 EST

*** This bug has been marked as a duplicate of 114682 ***
Comment 2 Red Hat Bugzilla 2006-02-21 14:01:10 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.