Bug 115443 - daily prelink: Segmentation fault
daily prelink: Segmentation fault
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: prelink (Show other bugs)
1
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Jakub Jelinek
:
: 118387 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-02-12 11:19 EST by Todd Allen
Modified: 2007-11-30 17:10 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-11-24 09:40:22 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
prelink.log (64.00 KB, text/plain)
2004-02-12 11:20 EST, Todd Allen
no flags Details

  None (edit)
Description Todd Allen 2004-02-12 11:19:48 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; Galeon)
Gecko/20031114 Galeon/1.3.10

Description of problem:
The daily /etc/cron.daily/prelink script fails every day with the
following error:

/etc/cron.daily/prelink: line 36: 19629 Segmentation fault     
/usr/sbin/prelink -av $PRELINK_OPTS >>/var/log/prelink.log 2>&1

It leaves a file named /usr/lib/libstdc++.so.2.7.2.8.#prelink#.$blah,
where $blah is a pseudo-random sequence of characters.  A new one of
those appears every night.  Those files are 0-length.  (Also, the
presence of those files freaks out any subsequent runs of ldconfig.) 
The /usr/lib/libstdc++.so.2.7.2.8, which I assume is what's confusing
prelink, is from compat-libstdc++-7.3-2.96.118.

This happens on two different systems, each of which was upgraded from
Red Hat 9 to Fedora Core 1.  The problem started immediately after the
upgrade.

In the hopes that it was simply stale information somewhere, I tried
manually running prelink as "prelink -av -mR".  That succeeded.  But
subsequent night runs of the above script continued to fail.


Version-Release number of selected component (if applicable):
prelink-0.3.0-13

How reproducible:
Always

Steps to Reproduce:
1.  Run /etc/cron.daily/prelink (or just wait until 4am when it
happens automatically).


Actual Results:  /etc/cron.daily/prelink: line 36: 19629 Segmentation
fault      /usr/sbin/prelink -av $PRELINK_OPTS >>/var/log/prelink.log 2>&1


Expected Results:  (silence)

Additional info:
Comment 1 Todd Allen 2004-02-12 11:20:32 EST
Created attachment 97615 [details]
prelink.log
Comment 2 Bart Martens 2004-03-18 15:47:18 EST
*** Bug 118387 has been marked as a duplicate of this bug. ***
Comment 3 Gilles Detillieux 2004-05-11 12:02:52 EDT
I wasn't getting this under FC1, but I was getting the same error
quite consistently under FC2 test3 until installing prelink-0.3.2-1
from the development updates.  This update seems to have made the
problem go away, so I guess this bug is somehow related to bug 118522
or bug 121109, which prelink-0.3.2-1's changelog claims to address.
Comment 4 Jakub Jelinek 2004-10-29 05:30:25 EDT
Yeah, please try to reproduce this with FC3t3 (or FC3rc[1-4]) prelink.
If it works there, this bug can be closed (FC1 is EOL).
Comment 5 Jakub Jelinek 2004-11-24 09:40:22 EST
Expect it is fixed then.

Note You need to log in before you can comment on or make changes to this bug.