Bug 118387 - Evolution will not open.
Evolution will not open.
Status: CLOSED DUPLICATE of bug 115443
Product: Fedora
Classification: Fedora
Component: prelink (Show other bugs)
1
i686 Linux
high Severity high
: ---
: ---
Assigned To: Jeremy Katz
http://www.ximian.com/products/evolut...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-03-16 03:27 EST by Anthony D. Davis
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 14:02:00 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Strace of Evolution Email (9.04 KB, text/plain)
2004-03-16 03:38 EST, Anthony D. Davis
no flags Details

  None (edit)
Description Anthony D. Davis 2004-03-16 03:27:20 EST
Description of problem: Evolution Email will not open. I click on the
Icon and it starts to initialize but does not. 


Version-Release number of selected component (if applicable): 1.4.5-7


How reproducible: It just won't open.


Steps to Reproduce:
1. Boot Up Fedora
2. Click on Evolution Email on Task bar.
3. Main Menu, Internet, Evolution Email.
  
Actual results: Will not open, Initializes but stops. You can see it
appear in the task bar trying to initialize but then it stops and
disappears. 


Expected results: For Email to open so I can see my email and other 
things Evolution offers.

Additional info: An strace was done. 
libgtkhtml-a11y-3.0.so.2: cannot open shared object file: Permission
denied
Comment 1 Anthony D. Davis 2004-03-16 03:38:00 EST
Created attachment 98561 [details]
Strace of Evolution Email

The only things I can think of that I did before this bug happened was send a
new e-mail edited it. I also sent an e-mail using Mozilla 1.4.1 by clicking on
a web page link to bring up Mozilla e-mail (I send email from it I don't
retrieve email from Mozilla I did not add a mail server only smtp server). I
also did edit the email I sent while using Evolution but my strace shows a
different shared object file to report an error.
Comment 2 Bart Martens 2004-03-18 00:49:41 EST
Anthony, could you run these commands, and copy the output here please?

rpm -qf /usr/lib/libgtkhtml-a11y-3.0.so.2
rpm -q evolution gtkhtml3
ls -l /usr/lib/libgtkhtml-a11y-3.0.so.2*

The output that I got, is:

$ rpm -qf /usr/lib/libgtkhtml-a11y-3.0.so.2
gtkhtml3-3.0.9-5
$ rpm -q evolution gtkhtml3
evolution-1.4.5-7
gtkhtml3-3.0.9-5
$ ls -l /usr/lib/libgtkhtml-a11y-3.0.so.2*
lrwxrwxrwx  1 root root    28 Jan 17 12:56
/usr/lib/libgtkhtml-a11y-3.0.so.2 -> libgtkhtml-a11y-3.0.so.2.1.2
-rwxr-xr-x  1 root root 31784 Sep 26 02:36
/usr/lib/libgtkhtml-a11y-3.0.so.2.1.2
$
Comment 3 Anthony D. Davis 2004-03-18 04:06:43 EST
Anthony D. Davis's output or my output is:

[fescue@localhost fescue]$ su
Password:
[root@localhost fescue]# rpm -qf /usr/lib/libgtkhtml-a11y-3.0.so.2
gtkhtml3-3.0.9-5
[root@localhost fescue]# rpm -q evolution gtkhtml3
evolution-1.4.5-7
gtkhtml3-3.0.9-5
[root@localhost fescue]# ls -l /usr/lib/libgtkhtml-a11y-3.0.so.2*
lrwxrwxrwx  1 root   root      45 Mar 15 01:54
/usr/lib/libgtkhtml-a11y-3.0.so.2  ->
libgtkhtml-a11y-3.0.so.2.1.2.#prelink#.O0YsOG
-rwxrwxrwx  1 fescue fescue 31784 Sep 25 20:36
/usr/lib/libgtkhtml-a11y-3.0.so.2 .1.2
-rw-------  1 root   root       0 Mar 10 01:24
/usr/lib/libgtkhtml-a11y-3.0.so.2 .1.2.#prelink#.8uv5xd
-rwx------  1 root   root   31784 Mar 10 01:24
/usr/lib/libgtkhtml-a11y-3.0.so.2 .1.2.#prelink#.O0YsOG
[root@localhost fescue]# exit
exit
[fescue@localhost fescue]$
Comment 4 Bart Martens 2004-03-18 15:20:05 EST
Could you also copy the output of these commands please:

rpm -q prelink
locate "#prelink#"
Comment 5 Bart Martens 2004-03-18 15:47:17 EST

*** This bug has been marked as a duplicate of 115443 ***
Comment 6 Anthony D. Davis 2004-03-19 01:44:00 EST
[fescue@localhost fescue]$ su
Password:
[root@localhost fescue]# rpm -q prelink
prelink-0.3.0-13
[root@localhost fescue]# locate "#prelink#"
/usr/lib/libgtkhtml-a11y-3.0.so.2.1.2.#prelink#.O0YsOG
/usr/lib/libgtkhtml-a11y-3.0.so.2.1.2.#prelink#.8uv5xd
[root@localhost fescue]#
Comment 7 Bart Martens 2004-03-19 14:17:59 EST
OK, this doesn't seem to be an evolution bug, rather a problem with
prelink. I'm not sure whether prelink did something wrong or only got
interrupted. Changing component from evolution to prelink.

You could try to fix the problem you're now having with evolution,
with these commands:

mv /usr/lib/libgtkhtml-a11y-3.0.so.2.1.2.#prelink#.O0YsOG
/usr/lib/libgtkhtml-a11y-3.0.so.2.1.2
chmod 755 /usr/lib/libgtkhtml-a11y-3.0.so.2.1.2
Comment 8 Anthony D. Davis 2004-03-20 03:21:46 EST
The command above did not work but there is also a
/usr/lib/libgtkhtml-a11y-3.0.so.2.1.2.#prelink#.8uv5xd
file that I did not move to /usr/lib/libgtkhtml-a11y-3.0.so.2.1.2
should I do that? I only did this command below:
 
mv /usr/lib/libgtkhtml-a11y-3.0.so.2.1.2.#prelink#.O0YsOG
/usr/lib/libgtkhtml-a11y-3.0.so.2.1.2
chmod 755 /usr/lib/libgtkhtml-a11y-3.0.so.2.1.2

evolution is still not opening. It starts in the task bar then dies.
Comment 9 Bart Martens 2004-03-20 03:55:18 EST
Anthony, let's continue this via e-mail and irc, to keep support
questions separated from bug documentation.
Comment 10 Red Hat Bugzilla 2006-02-21 14:02:00 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.