Bug 1154688 - Upgrading clusters and datacenters to 3.5 does not add the default disk profile [NEEDINFO]
Summary: Upgrading clusters and datacenters to 3.5 does not add the default disk profile
Keywords:
Status: CLOSED DUPLICATE of bug 1145241
Alias: None
Product: oVirt
Classification: Retired
Component: ovirt-engine-webadmin
Version: 3.5
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
: 3.5.1
Assignee: bugs@ovirt.org
QA Contact: Pavel Stehlik
URL:
Whiteboard: infra
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-10-20 14:18 UTC by Daniel Helgenberger
Modified: 2016-02-10 19:35 UTC (History)
10 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-10-28 12:38:17 UTC
oVirt Team: Infra
daniel.helgenberger: needinfo? (bugs)
sbonazzo: ovirt_requires_release_note?


Attachments (Terms of Use)

Description Daniel Helgenberger 2014-10-20 14:18:39 UTC
Description of problem:
When updating oVirt from a prior release and setting the datacenter version to 3.5 there is no default disk profile added effectively preventing the creation of new disks.

Version-Release number of selected component (if applicable):
oVirt 3.5

How reproducible:
always

Steps to Reproduce:
1. Install oVirt engine 3.4.x
2. Upgrade oVirt engine to 3.5
3. Set datacenter version to 3.5
4. Add disk

Actual results:
Adding the disk fails with no error (cannot click OK), because there is no disk profile. Using a template however raises the error pointing to the root cause:
Cannot add disks: ACTION_TYPE_DISK_PROFILE_EMPTY

Expected results:
Disk is added, a default profile (unlimited) is used automatically if not existing.

Additional info:
I do not really know where to file the bug against, at the very least it is documentation or even RFE? Also, manually adding a default profile to every data domain solves the issue.
But there are already to documented cases of this pitfall in 3.5 on the users mailing list.

Comment 1 Sandro Bonazzola 2014-10-20 14:29:15 UTC
The operation of setting datacenter version is done through webadmin interface.
Moving to proper component.

Comment 2 Sven Kieske 2014-10-20 14:48:15 UTC
I guess this is a duplicate bug of bz 1145241 ?

Comment 3 Daniel Helgenberger 2014-10-20 17:37:51 UTC
Indeed Seven, thanks. I realized after filing this BZ. Sandro or anyone - could you flag the dup to bz1145241 ?
At least this one got some more attention now.

Comment 4 Daniel Helgenberger 2014-10-28 12:38:17 UTC

*** This bug has been marked as a duplicate of bug 1145241 ***


Note You need to log in before you can comment on or make changes to this bug.