Bug 1145241 - Upgrading a DC to 3.5 does not create default storage profiles
Summary: Upgrading a DC to 3.5 does not create default storage profiles
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: oVirt
Classification: Retired
Component: ovirt-engine-core
Version: 3.5
Hardware: Unspecified
OS: Unspecified
urgent
high
Target Milestone: ---
: 3.5.1
Assignee: Roy Golan
QA Contact: Jiri Belka
URL:
Whiteboard: sla
: 1154688 1175255 (view as bug list)
Depends On:
Blocks: oVirt_3.5.1_tracker
TreeView+ depends on / blocked
 
Reported: 2014-09-22 15:41 UTC by Allon Mureinik
Modified: 2016-02-10 19:41 UTC (History)
15 users (show)

Fixed In Version: ovirt-3.5.1_rc1
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-01-21 16:04:16 UTC
oVirt Team: SLA


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
oVirt gerrit 34422 master MERGED core: Create default disk profiles for data domains Never
oVirt gerrit 34598 ovirt-engine-3.5 MERGED core: Create default disk profiles for data domains Never

Description Allon Mureinik 2014-09-22 15:41:49 UTC
Description of problem:
Storage profiles are only usable in 3.5 DCs - so upgrading a DC from 3.x to 3.5 should create a deafault, unlimited storage profile for each domain under the DC.

Version-Release number of selected component (if applicable):
engine built from source with commit hash cf7b1700eb77672cc34f7177e83c7250817de74b

How reproducible:
100%

Steps to Reproduce:
1. Create a 3.0 DC
2. Create a cluster
3. Add a host to the cluster with ovirt-3.5's VDSM
4. Add a storage domain
5. Upgrade the cluster to 3.5
6. Upgrade the DC to 3.5

Actual results:
No disk profiles

Expected results:
A default unlimited disk profile per domain

Additional info:

Comment 1 Sven Kieske 2014-10-20 14:46:41 UTC
How could this bug not be found by automatic tests?
I was under the impression a full upgrade plus full lifecycle gets tested
before each release?

imho this is a regression from 3.4 because you can't create new disks
on new DCs.

Comment 2 Sven Kieske 2014-10-22 11:53:27 UTC
This bug got introduced because of incomplete release criteria:

"MUST: Fully operational flow (define DC hierarchy so you can run vm) with GUI/CLI/Python-API/REST-API "

"MUST: Upgrade from previous release

    Features/bug list: "

from:

http://www.ovirt.org/OVirt_3.5_release-management#Release_Criteria_.28WIP.29

So these things get tested independent but not in combination.

imho it makes sense to alter the release criteria for 3.6:

MUST: Upgrade from previous release
    MUST: Fully operational flow (define DC hierarchy so you can run vm) with
    GUI/CLI/Python-API/REST-API

This simple automatic test would have revealed the bug before GA:

1. Spin up latest release
2. Upgrade to RC
3. define DC hierarchy so you can run vm

HTH

Comment 3 Daniel Helgenberger 2014-10-28 12:38:17 UTC
*** Bug 1154688 has been marked as a duplicate of this bug. ***

Comment 4 Tiemen Ruiten 2015-01-07 07:18:49 UTC
*** Bug 1175255 has been marked as a duplicate of this bug. ***

Comment 5 Sandro Bonazzola 2015-01-15 14:15:42 UTC
This is an automated message: 
This bug should be fixed in oVirt 3.5.1 RC1, moving to QA

Comment 6 Sandro Bonazzola 2015-01-21 16:04:16 UTC
oVirt 3.5.1 has been released. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.