Bug 115481 - kickstart network flag being set to DHCP
kickstart network flag being set to DHCP
Status: CLOSED CURRENTRELEASE
Product: Red Hat Satellite 5
Classification: Red Hat
Component: Server (Show other bugs)
unspecified
All Linux
medium Severity medium
: ---
: ---
Assigned To: Robin Norwood
Fanny Augustin
:
: 117481 (view as bug list)
Depends On:
Blocks: rhn310rc
  Show dependency treegraph
 
Reported: 2004-02-12 16:18 EST by Neal Mackanic
Modified: 2007-07-31 10:29 EDT (History)
2 users (show)

See Also:
Fixed In Version: rhn310
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-09-30 11:17:59 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Neal Mackanic 2004-02-12 16:18:50 EST
Description of problem:

In the kickstart profile I select the network option to use static IP
address and yet the kickstart configuration file, and the kickstart
advanced options showing bootproto dhcp. 

The end system completes the kickstart successfully using a static IP
address and not dhcp.  The anaconda-ks.cfg file shows the setting of
network to device eth0 and bootproto static.



Version-Release number of selected component (if applicable):
rhn310rc
Comment 1 Robin Norwood 2004-03-01 11:58:07 EST
The Network Configuration option on the Kickstart->Options page is
used by the bootloader to determine the network configuration for the
kickstart process.  The 'network' command on the advanced options page
is the one used to generate the kickstart configuration file.  The
options passed to the bootloader are different from those needed by
anaconda to configure the system.  It is also possible that these two
settings might be different.  A user might need to kickstart a system
using eth1, but eth0 is the primary network interface for the box.


I've changed the name to 'Kickstart Network Configuration'.  Better
documentation of this difference is also in order.
Comment 2 Robin Norwood 2004-03-04 10:20:07 EST
*** Bug 117481 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.