Bug 115513 - Serial mouse doesn't work during install
Summary: Serial mouse doesn't work during install
Status: CLOSED WONTFIX
Alias: None
Product: Fedora
Classification: Fedora
Component: anaconda   
(Show other bugs)
Version: rawhide
Hardware: i686 Linux
medium
medium
Target Milestone: ---
Assignee: Jeremy Katz
QA Contact:
URL:
Whiteboard:
Keywords:
: 119474 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-02-13 06:08 UTC by Mike Heath
Modified: 2007-11-30 22:10 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-08-24 18:26:43 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Mike Heath 2004-02-13 06:08:23 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6) Gecko/20040115

Description of problem:
During the install of Fedora Core 2 Test 1, my two button serial mouse
did not work.  It is working fine now that FC2 is installed.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.  Boot of FC2 Test 1 CD.
2.  After GUI starts up, mouse does not work.
3.
    

Additional info:

Comment 1 Mike Heath 2004-02-13 06:10:09 UTC
The mouse is attached to ttyS1.

Comment 2 Michael Schwendt 2004-02-14 00:27:05 UTC
My 3-button serial mouse was detected wrongly as "Generic - Wheel
mouse (PS/2)" which didn't work. I installed using keyboard only,
selected the correct mouse during installation, just to find that
"firstboot" doesn't accept any keyboard input and I need to work
around that, too.


Comment 3 Bill Nottingham 2004-02-16 05:48:50 UTC
FC2 Test1 will generally report that a PS/2 wheel mouse is there every
time. This is fixed in current trees.

Comment 4 Jeremy Katz 2004-02-17 04:30:14 UTC
As Bill said, the development tree should have this fixed

Comment 5 Tethys 2004-06-05 10:19:17 UTC
Rather than reporting a PS/2 wheel mouse, FC2 final detects my
mouse as a generic 2 button serial mouse, and doesn't work during
the install (although it's fine once the install is complete).

My mouse is actually a *3* button serial mouse, too, which meant
that I had to manually run mouseconfig after installing to get the
middle button working under X.

Comment 6 Michael Schwendt 2004-08-24 07:19:55 UTC
*** Bug 119474 has been marked as a duplicate of this bug. ***

Comment 7 Leonard den Ottolander 2004-08-24 12:05:29 UTC
Maybe the wheel issue is solved (is it?), but serial mice are still
*not* detected during installation (FC3t1). Reassigning.


Comment 8 Jeremy Katz 2004-08-24 18:26:43 UTC
Serial mice aren't going to be supported during installation (unless
someone provides a patch).  They're just not common enough at this
point and fall into the same category as ISA network cards as far as
support is concerned.

Comment 9 Rahul Sundaram 2004-09-20 14:36:49 UTC
I dont know about other parts of the world but here in India serial
mouse are much more common that ISA cards. In my office almost every
system has a serial mouse but no ISA cards. Please reconsider this


Note You need to log in before you can comment on or make changes to this bug.