Bug 119474 - serial mouse not working during installation
serial mouse not working during installation
Status: CLOSED DUPLICATE of bug 115513
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
athlon Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
:
: 119259 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-03-30 15:02 EST by Michael Schwendt
Modified: 2007-11-30 17:10 EST (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 14:02:16 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michael Schwendt 2004-03-30 15:02:19 EST
Fresh installation of Fedora Core 2 Test 2.

Installer reports mouse as "Generic - 2 Button Mouse (serial)", but
mouse doesn't work during installation. After installation, there's no
/etc/sysconfig/mouse, not valid InputDevice entry in
/etc/X11/XF86Config and no system-config-mouse tool installed.

It should have found and configured the mouse at /dev/ttyS1

Probably kudzu's fault.

How reproducible:
Didn't try
Comment 1 Bill Nottingham 2004-03-30 17:01:34 EST
Comps bug, actually. Will hopefully be fixed in newer builds.
Comment 2 Bill Nottingham 2004-03-30 17:51:56 EST
Reopening, we should probably do something during installation.
Comment 3 adam.huffman 2004-04-03 18:56:01 EST
Possibly related to this, the installer detected my 3-button PS/2
mouse but it is not working in X or in gpm.
Comment 4 Bill Nottingham 2004-04-05 15:18:05 EDT
No, that's a different issue... that should Just Work.
Comment 5 Michael Schwendt 2004-04-05 15:28:56 EDT
At the end of a fresh installation, I find this in install.log.syslog: 

<13>Apr  4 18:08:22 kudzu: linked /dev/mouse to /dev/ttyS1
<13>Apr  4 18:08:22 kudzu: ran mouseconfig for ttyS1

So, at that point, kudzu is correct about my mouse
(system-config-mouse was missing, though, different bug).
Comment 6 Brent Fox 2004-04-16 14:49:16 EDT
*** Bug 119259 has been marked as a duplicate of this bug. ***
Comment 7 Brent Fox 2004-04-16 16:16:59 EDT
I can confirm that serail mice don't work in the installer as of
04/16/2004 rawhide tree.
Comment 8 Leonard den Ottolander 2004-05-04 08:28:34 EDT
Same for FC2t3. Even after manual selection (ms compatible +/- 3 btn
emu or generic 3 button) the mouse is not recognized.
Comment 9 Warren Togami 2004-05-08 15:50:43 EDT
Michael has confirmed that serial mice remain inoperative in the
FC2-e0507.0 release candidate.
Comment 10 Leonard den Ottolander 2004-05-08 15:53:28 EDT
Funny thing is that by starting gpm the serial mouse gets recognized
by X. It's still functional after stopping gpm.
Comment 11 Michael Schwendt 2004-05-08 16:43:51 EDT
Leonard, that was a different bug. [Serial mouse after (!)
installation in X works fine here with the release candidate. In
Test3, one of the side-effects of "service gpm start" is that kernel
module "sermouse" is loaded. But that alone doesn't enable the mouse
in X.]
Comment 12 Bill Nottingham 2004-05-19 17:45:07 EDT
What is the /etc/sysconfig/mouse in the non-functional case?
Comment 13 Michael Schwendt 2004-05-19 19:09:58 EDT
I need to try that (no sooner than tomorrow) with a fresh install. In
Test2, /etc/sysconfig/mouse did not exist. With Fedora Core 2, the
file was most likely created by me after installation (not just to
enable the third button). /root/install.log.syslog contains:

<13>May 15 18:42:30 kudzu: ran mouseconfig for ttyS0
Comment 14 Michael Schwendt 2004-06-03 21:53:06 EDT
FC2, after fresh install with non-working mouse, /etc/sysconfig/mouse
contains:

FULLNAME="Generic - 2 Button Mouse (serial)"
MOUSETYPE="Microsoft"
XEMU3="yes"
XMOUSETYPE="Microsoft"
IMOUSETYPE="bare"
DEVICE=/dev/ttyS0

The device /dev/ttyS0 is correct.

Side-note: In reply to comment 10 (Leonard), _after_ installation
mouse stops working in X as soon as I "chkconfig gpm stop ; reboot".
Comment 15 Bill Nottingham 2004-06-03 21:56:06 EDT
Correct, the gpm init script starts the input layer redirector (for
lack of a better place ATM.)
Comment 16 Janos Lichtenberger 2004-06-09 08:43:55 EDT
The same bug is reported by me in No 124275
Comment 17 Michael Schwendt 2004-07-14 17:25:01 EDT
[just tracking: bug persists in FC3 Test1]
Comment 18 Michael Schwendt 2004-08-24 03:19:36 EDT

*** This bug has been marked as a duplicate of 115513 ***
Comment 19 Rob Porter 2004-08-26 17:04:04 EDT
With a Logitech C7 mouse, bug persists after installation, and does
not work *at all*.

Still there in Core 3 test1.
Comment 20 NHUT THAI LE 2004-09-11 09:28:02 EDT
Logitech Cordless Navigator Duo mouse does not work if I use the ps/2 
adapter to plug both connectors to PS/2 instead of one PS/2, one USB.
However, when the boot process completed, whatever I change the ps/2 
connector(which is used for mouse) to USB or PS/2, the mouse still 
continue to work.
Comment 21 Bob Smith 2005-10-04 18:14:13 EDT
I installed FC4 which did not recognize my mouse. I have a Microsoft Serial
mouse. Tried it as serial and with a PS2 adapter and the install cannot see
either one. Any suggestions on how to get it to work is appreciated.
Comment 22 Chris Peet 2005-10-11 08:39:58 EDT
Here is what I do to fix for FC4 (both x86-32 and x86-64) for serial mice:

1. Log into console or text mode as root.
2. Run mouseconfig - set up for serial mouse, ignore any error messages.
3. Use your favourite editor to open /etc/sysconfig/mouse
4. The last line should contain /dev/mice - change this to /dev/ttyS? where the
question mark refers to the port your mouse is plugged into.
5. Save /etc/sysconfig/mouse
6. Run service gpm start and when you go back to X (Gnome / KDE) the mouse
should work.
Comment 23 Red Hat Bugzilla 2006-02-21 14:02:16 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.