Bug 1155812 - kdepim: improve split packaging
Summary: kdepim: improve split packaging
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: kdepim
Version: rawhide
Hardware: All
OS: Linux
unspecified
medium
Target Milestone: ---
Assignee: Daniel Vrátil
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 1187634 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-10-22 22:03 UTC by Orion Poplawski
Modified: 2015-11-02 01:38 UTC (History)
10 users (show)

Fixed In Version: kdepim-4.14.4-3.fc20
Doc Type: Enhancement
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-02-27 09:24:01 UTC
Type: Bug


Attachments (Terms of Use)

Description Orion Poplawski 2014-10-22 22:03:32 UTC
Description of problem:

The -libs packages in kdepim require their parent component (e.g. kmail-libs requires kmail).  This leads to entanglements so that you cannot have akregator with out kmail:

# yum remove kmail
Resolving Dependencies
--> Running transaction check
---> Package kmail.x86_64 0:4.14.2-1.fc21 will be erased
--> Processing Dependency: kmail = 4.14.2-1.fc21 for package: kmail-libs-4.14.2-1.fc21.x86_64
--> Running transaction check
---> Package kmail-libs.x86_64 0:4.14.2-1.fc21 will be erased
--> Processing Dependency: libmailcommon.so.4()(64bit) for package: kdepim-common-4.14.2-1.fc21.x86_64
...
---> Package kdepim-common.x86_64 0:4.14.2-1.fc21 will be erased
--> Processing Dependency: kdepim-common = 4.14.2-1.fc21 for package: korganizer-4.14.2-1.fc21.x86_64
--> Processing Dependency: kdepim-common = 4.14.2-1.fc21 for package: akregator-4.14.2-1.fc21.x86_64

Comment 1 Rex Dieter 2015-01-30 18:33:19 UTC
*** Bug 1187634 has been marked as a duplicate of this bug. ***

Comment 2 Rex Dieter 2015-01-30 18:34:42 UTC
Yeah, need to examine the interdependencies of these libraries a bit more.

Comment 3 Fedora Update System 2015-02-18 12:14:45 UTC
kdepim-4.14.4-3.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/kdepim-4.14.4-3.fc20

Comment 4 Fedora Update System 2015-02-18 12:14:51 UTC
kdepim-4.14.4-6.fc21 has been submitted as an update for Fedora 21.
https://admin.fedoraproject.org/updates/kdepim-4.14.4-6.fc21

Comment 5 Fedora Update System 2015-02-19 02:59:32 UTC
Package kdepim-4.14.4-3.fc20:
* should fix your issue,
* was pushed to the Fedora 20 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing kdepim-4.14.4-3.fc20'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2015-2274/kdepim-4.14.4-3.fc20
then log in and leave karma (feedback).

Comment 6 Fedora Update System 2015-02-27 09:24:01 UTC
kdepim-4.14.4-6.fc21 has been pushed to the Fedora 21 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 7 Fedora Update System 2015-02-27 09:25:41 UTC
kdepim-4.14.4-3.fc20 has been pushed to the Fedora 20 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.