Bug 1187634 - kdepim: improve split packaging (RFE)
Summary: kdepim: improve split packaging (RFE)
Status: CLOSED DUPLICATE of bug 1155812
Alias: None
Product: Fedora
Classification: Fedora
Component: kdepim
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Ngo Than
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords: FutureFeature
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-01-30 14:19 UTC by Harald Reindl
Modified: 2015-01-31 11:52 UTC (History)
9 users (show)

(edit)
Clone Of:
(edit)
Last Closed: 2015-01-30 18:33:19 UTC


Attachments (Terms of Use)

Description Harald Reindl 2015-01-30 14:19:57 UTC
why is KDEPIM now a dependency?

looks like "kopete" is te trigger because it would be removed with "kdepim-common" and is the only by intention installed package from the list at bottom

Installing for dependencies:
  baloo-akonadi
  boost-thread
  gnupg2-smime
  grantlee
  kaddressbook-libs
  kdepim-common
  kdepim-libs
  kdepim-runtime
  kdepim-runtime-libs
  khotkeys
  khotkeys-libs
  kinfocenter
  kleopatra
  kmail
  kmail-libs
  kmenuedit
  knotes
  knotes-libs
  libkfbapi
  libkgapi
  libkolab
  libkolabxml
  libksba
  pinentry-qt
  python-lockfile
  spambayes
  xerces-c
___________________________________________

 kdepim-common                                           x86_64                                     4.14.4-2.fc20                                       @updates-testing                                     2.1 M
Entfernt für Abhängigkeiten:
 baloo-akonadi                                           x86_64                                     4.14.3-1.fc20                                       @updates                                             205 k
 boost-thread                                            x86_64                                     1.54.0-12.fc20                                      @updates                                              93 k
 gnupg2-smime                                            x86_64                                     2.0.25-1.fc20                                       @updates                                             922 k
 grantlee                                                x86_64                                     0.3.0-3.fc20                                        @fedora                                              1.0 M
 kaddressbook-libs                                       x86_64                                     4.14.4-2.fc20                                       @updates-testing                                     899 k
 kdepim-libs                                             x86_64                                     7:4.14.4-2.fc20                                     @updates-testing                                     8.0 M
 kdepim-runtime                                          x86_64                                     1:4.14.4-1.fc20                                     @updates-testing                                      12 M
 kdepim-runtime-libs                                     x86_64                                     1:4.14.4-1.fc20                                     @updates-testing                                     448 k
 kleopatra                                               x86_64                                     4.14.4-2.fc20                                       @updates-testing                                     3.8 M
 kleopatra-libs                                          x86_64                                     4.14.4-2.fc20                                       @updates-testing                                     1.6 M
 kmail                                                   x86_64                                     4.14.4-2.fc20                                       @updates-testing                                     4.2 M
 kmail-libs                                              x86_64                                     4.14.4-2.fc20                                       @updates-testing                                     9.7 M
 knotes                                                  x86_64                                     4.14.4-2.fc20                                       @updates-testing                                     794 k
 knotes-libs                                             x86_64                                     4.14.4-2.fc20                                       @updates-testing                                     507 k
 kopete                                                  x86_64                                     14.12.1-1.fc20                                      @updates-testing                                      16 M
 kopete-libs                                             x86_64                                     14.12.1-1.fc20                                      @updates-testing                                     4.2 M
 libkfbapi                                               x86_64                                     1.0-1.fc20                                          @fedora                                              522 k
 libkgapi                                                x86_64                                     2.2.0-1.fc20                                        @updates                                             1.7 M
 libkolab                                                x86_64                                     0.5.2-1.fc20                                        @updates                                             886 k
 libkolabxml                                             x86_64                                     1.0.1-2.fc20                                        @updates                                             2.9 M
 libksba                                                 x86_64                                     1.3.2-1.fc20                                        @updates                                             311 k
 pinentry-qt                                             x86_64                                     0.8.1-11.fc20                                       @fedora                                              150 k
 python-lockfile                                         noarch                                     1:0.9.1-5.fc20                                      @fedora                                               74 k
 spambayes                                               noarch                                     1.1-0.8.b1.fc20                                     @updates                                             2.3 M
 xerces-c

Comment 1 Rex Dieter 2015-01-30 14:35:07 UTC
OK, looks like our initial attempt at splitting kdepim may have been sub-optimal.  It's no worse than the single monolithic 'kdepim' before though.

Comment 2 Rex Dieter 2015-01-30 14:35:46 UTC
In short, all subpkgs pull in kdepim-common, which pulls in kdepim-libs and kmail-libs

Comment 3 Harald Reindl 2015-01-30 14:37:49 UTC
*but* before the today updates from updates-testing all that stuff was *not* installed or better said removeable and in fact removed here - something recently changed in the wrong direction

Comment 4 Rex Dieter 2015-01-30 14:40:40 UTC
Which version of kdepim was installed prior to the update?

Comment 5 Harald Reindl 2015-01-30 14:42:25 UTC
*none* and that is the point "Installing for dependencies"!

Installing for dependencies:
  baloo-akonadi
  boost-thread
  gnupg2-smime
  grantlee
  kaddressbook-libs
  kdepim-common
  kdepim-libs
  kdepim-runtime
  kdepim-runtime-libs
  khotkeys
  khotkeys-libs
  kinfocenter
  kleopatra
  kmail
  kmail-libs
  kmenuedit
  knotes
  knotes-libs
  libkfbapi
  libkgapi
  libkolab
  libkolabxml
  libksba
  pinentry-qt
  python-lockfile
  spambayes
  xerces-c

Comment 6 Rex Dieter 2015-01-30 14:48:35 UTC
Ok, I guess I was misled by your initial comment: looks like "kopete" is the trigger

where I assumed you had kopete (and the rest of kdepim) installed prior to the update.

Comment 7 Rex Dieter 2015-01-30 14:50:13 UTC
My bad, kopete wasn't in kdepim, my error

Comment 8 Rex Dieter 2015-01-30 18:33:19 UTC

*** This bug has been marked as a duplicate of bug 1155812 ***

Comment 9 Harald Reindl 2015-01-31 11:52:13 UTC
thank you for the kopete subpackage, just updated from koji and "yum remove kdepim-common" wa able to uninstall the packages pulled yesterday with 58 MB

some may say what are 58 MB, well my full featured workstation needs 6.3 GB for / even with VMware Workstation and ZendStudio, so the pure Fedora would need around 4 GB - the point of slim down the setup is faster upgrades and less cross-dependency problems in case of major upgrades besides the space

Jan 31 12:43:54 Updated: kopete-14.12.1-2.fc20.x86_64
Jan 31 12:43:55 Updated: kopete-libs-14.12.1-2.fc20.x86_64

Jan 31 12:48:51 Erased: kleopatra-4.14.4-2.fc20.x86_64
Jan 31 12:48:51 Erased: kdepim-common-4.14.4-2.fc20.x86_64
Jan 31 12:48:51 Erased: knotes-4.14.4-2.fc20.x86_64
Jan 31 12:48:51 Erased: knotes-libs-4.14.4-2.fc20.x86_64
Jan 31 12:48:51 Erased: kmail-4.14.4-2.fc20.x86_64
Jan 31 12:48:51 Erased: kaddressbook-libs-4.14.4-2.fc20.x86_64
Jan 31 12:48:51 Erased: kmail-libs-4.14.4-2.fc20.x86_64
Jan 31 12:48:51 Erased: 7:kdepim-libs-4.14.4-2.fc20.x86_64
Jan 31 12:48:51 Erased: kleopatra-libs-4.14.4-2.fc20.x86_64
Jan 31 12:48:51 Erased: 1:kdepim-runtime-libs-4.14.4-1.fc20.x86_64
Jan 31 12:48:52 Erased: 1:kdepim-runtime-4.14.4-1.fc20.x86_64
Jan 31 12:48:54 Erased: libkolab-0.5.2-1.fc20.x86_64
Jan 31 12:48:54 Erased: libkolabxml-1.0.1-2.fc20.x86_64
Jan 31 12:48:54 Erased: spambayes-1.1-0.8.b1.fc20.noarch
Jan 31 12:48:54 Erased: gnupg2-smime-2.0.25-1.fc20.x86_64
Jan 31 12:48:54 Erased: 1:python-lockfile-0.9.1-5.fc20.noarch
Jan 31 12:48:54 Erased: libksba-1.3.2-1.fc20.x86_64
Jan 31 12:48:54 Erased: boost-thread-1.54.0-12.fc20.x86_64
Jan 31 12:48:54 Erased: xerces-c-3.1.1-5.fc20.x86_64
Jan 31 12:48:55 Erased: libkfbapi-1.0-1.fc20.x86_64
Jan 31 12:48:55 Erased: libkgapi-2.2.0-1.fc20.x86_64
Jan 31 12:48:55 Erased: grantlee-0.3.0-3.fc20.x86_64
Jan 31 12:48:55 Erased: baloo-akonadi-4.14.3-1.fc20.x86_64
Jan 31 12:48:55 Erased: pinentry-qt-0.8.1-11.fc20.x86_64


Note You need to log in before you can comment on or make changes to this bug.