Bug 115633 - Left handed mouse preferences do not work.
Summary: Left handed mouse preferences do not work.
Status: CLOSED UPSTREAM
Alias: None
Product: Fedora
Classification: Fedora
Component: control-center   
(Show other bugs)
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Jonathan Blandford
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: 121490
TreeView+ depends on / blocked
 
Reported: 2004-02-14 00:37 UTC by Mark Patton
Modified: 2013-04-02 04:19 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-10-22 10:17:07 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Mark Patton 2004-02-14 00:37:24 UTC
Description of problem:

Selecting a left handed mouse does not work as expected. It seems like
both buttons become button 2 instead of switching.

Version-Release number of selected component (if applicable):


How reproducible:

Very.

Steps to Reproduce:
1. Go to mouse preferences.
2. Selected left handed and click ok.
3. Try to use mouse
  
Actual results:

Right mouse button does not change behavior.

Expected results:

Right mouse button behaves like left mouse button.

Additional info:

Comment 1 Hay 2004-02-17 20:17:56 UTC
Have the same problem using FC2 test1 and fully up2date.

Trying to change the mouse button mapping in KDE control center to
left handed gives me a mouse that acts as a mouse with 2 right mouse
buttons.

This feature shows it self om the KDE start menu and the icons on the
desktop. The mouse buttons work fine on a application window.

I have stopped and restarted KDE and X, but no luck there.

This same problem also was in one of the FC1 test releases.

The mouse is a Logitech Cordless MouseMan (PS2) on a Asus P4B-E. It
works fine in FC1 and RH9.

There is a closed messages (20500, 68623) about this issue

Comment 2 Marco Pesenti Gritti 2004-10-22 10:17:07 UTC
UPSTREAM
http://bugzilla.gnome.org/show_bug.cgi?id=114651

The KDE issue is unrelated because this component is about gnome
control center.


Note You need to log in before you can comment on or make changes to this bug.