Bug 121490 - left-handed mouse buttons behave strangely
left-handed mouse buttons behave strangely
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: xorg-x11 (Show other bugs)
rawhide
athlon Linux
medium Severity medium
: ---
: ---
Assigned To: X/OpenGL Maintenance List
David Lawrence
:
: 123800 (view as bug list)
Depends On: 115633
Blocks:
  Show dependency treegraph
 
Reported: 2004-04-21 23:11 EDT by neil v. patel
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-10-12 03:02:18 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description neil v. patel 2004-04-21 23:11:46 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6) Gecko/20040312

Description of problem:
I've been having trouble with using my mouse left-handed. using Gnome
(don't have KDE installed at all), when i use the mouse preferences
applet to switch to "left-handed mouse", the buttons display strange
behaviour. the left mouse button seems to behave as it should (like a
righty right-handed button). the right mouse button, however, does not
work correctly. the most striking issue is that clicking on the
gnome-panel menu causes the menu to flash on screen -- it doesn't stay
open as it usually would. also, hovering over the gnome-panel icons
causes them to appear depressed, but no action is performed.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Set mouse to left handed in "Mouse Preferences"
2. attempt to use mouse to access gnome menu
    

Actual Results:  menu flashes on right-click, instead of being accessible.

Expected Results:  menu should behave as it does when left-clicked
with a right-handed mouse.

Additional info:

this bug has been around since i first installed FC2T1, and persists
through all the updates available on yum/up2date as of today.
Comment 1 Michael Orr 2004-07-28 11:12:25 EDT
This behavior exists under KDE on FC2 as well.
Comment 2 Michael Orr 2004-08-03 09:55:17 EDT
Found workaround on another bug list; comment out following line in
/etc/X11/xorg.conf:

       InputDevice    "DevInputMice" "AlwaysCore"

Restart X.  So far, this allows mouse button reset without side effects.
Comment 3 Mark McLoughlin 2004-08-06 14:38:58 EDT
*** Bug 123800 has been marked as a duplicate of this bug. ***
Comment 4 Mark McLoughlin 2004-08-06 14:40:08 EDT
Moving to xorg at a guess - its nothing to do with the panel and at
least the xorg people might recognise the bug
Comment 5 Mike A. Harris 2004-10-12 03:02:18 EDT
The X server seems to only allow reordering of the first configured
pointing device.  This doesn't appear to be a bug per se. but rather
a design limitation, or at least that's my interpretation upon
investigation.

Upgrade to Fedora Core 3 test2 or later, and if this problem still
exists, file a bug report in the X.Org bugzilla located at:

    http://bugs.freedesktop.org  in the "xorg" component

Once you've filed a bug report to X.Org, if you would like Red Hat
to track the issue, please paste the X.Org bug URL here, and we
will add it to our internal tracking list.

Thanks in advance.

Note You need to log in before you can comment on or make changes to this bug.