Bug 115646 - Error in gstreamer post-install scriptlet
Summary: Error in gstreamer post-install scriptlet
Status: CLOSED DUPLICATE of bug 115647
Alias: None
Product: Fedora
Classification: Fedora
Component: gstreamer   
(Show other bugs)
Version: rawhide
Hardware: i686 Linux
medium
medium
Target Milestone: ---
Assignee: Colin Walters
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-02-14 05:13 UTC by Bob Arendt
Modified: 2007-11-30 22:10 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 19:01:15 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Bob Arendt 2004-02-14 05:13:47 UTC
The gstreamer postinstall scriptlet fails during installation:

   2:gstreamer             
########################################### [ 40%]
error: %post(gstreamer-0.7.3-3) scriptlet failed, exit status 127

Version info:
   % rpm -q gstreamer
   gstreamer-0.7.3-3

The postinstall scriptlet:
  % rpm -q --scripts gstreamer
  postinstall scriptlet (using /bin/sh):
  /sbin/ldconfig
  env DISPLAY= /usr/bin/gst-register --gst-mask=0 > /dev/null 2> /dev/null
  postuninstall program: /sbin/ldconfig

The postinstall scriptlet looks strange.  gst-register is actually
installed as "gst-register-0.7" and the argument has changed.

I believe the following works:
  /usr/bin/gst-register-0.7 --gst-plugin-spew

Comment 1 Bob Arendt 2004-02-14 17:39:31 UTC

*** This bug has been marked as a duplicate of 115647 ***

Comment 2 Red Hat Bugzilla 2006-02-21 19:01:15 UTC
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.


Note You need to log in before you can comment on or make changes to this bug.