Bug 1156488 - [RFE] Re-registered hosts only show up in Content Hosts, not in Host or All Hosts
Summary: [RFE] Re-registered hosts only show up in Content Hosts, not in Host or All H...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Satellite
Classification: Red Hat
Component: Hosts
Version: 6.0.5
Hardware: Unspecified
OS: Unspecified
medium
medium vote
Target Milestone: Unspecified
Assignee: Justin Sherrill
QA Contact: Stephen Benjamin
URL: http://projects.theforeman.org/issues...
Whiteboard:
: 1156691 1168854 (view as bug list)
Depends On:
Blocks: 1154684
TreeView+ depends on / blocked
 
Reported: 2014-10-24 14:51 UTC by Thom Carlin
Modified: 2019-08-12 14:37 UTC (History)
9 users (show)

Fixed In Version:
Doc Type: Enhancement
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-07-27 08:45:52 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Bugzilla 1149145 None None None 2019-11-07 11:55:27 UTC
Red Hat Knowledge Base (Solution) 1228983 None None None Never
Red Hat Product Errata RHBA-2016:1500 normal SHIPPED_LIVE Red Hat Satellite 6.2 Base Libraries 2016-07-27 12:24:38 UTC

Internal Links: 1149145

Description Thom Carlin 2014-10-24 14:51:27 UTC
Description of problem:

When a system is re-registered from RHN Classic to Sat6, the system only displays in "Content Hosts", not in "Host" nor "All Hosts"

Version-Release number of selected component (if applicable):

6.0.5

How reproducible:

Each time

Steps to Reproduce:
1. Re-register system
2. webUI > Content Hosts
3.

Actual results:

System appears but not in "All Hosts"

Expected results:

System appears in all 3 places

Additional info:

Re-registration steps are in GSS case 1271296

Comment 1 RHEL Program Management 2014-10-24 14:53:26 UTC
Since this issue was entered in Red Hat Bugzilla, the release flag has been
set to ? to ensure that it is properly evaluated for this release.

Comment 5 Dominic Cleal 2014-10-29 10:33:14 UTC
*** Bug 1156691 has been marked as a duplicate of this bug. ***

Comment 7 Xixi 2014-10-29 23:05:17 UTC
Adding to RFE review...

There's a doc Bug 1149145 [Documentation] Need clear definition and difference of "All Hosts" and "Content Hosts" under "Hosts" tab in Red Hat Satellite v 6 webui 

Public summary from https://bugzilla.redhat.com/show_bug.cgi?id=1149145#c5:
Per discussion with engineering, there are existing plans to improve the page so that the two lists will be merged into one with all of the hosts, to reduce confusion.

In the meantime, Bug 1149145 is for clarification in the Satellite 6 documentation, with suggested verbiage from https://access.redhat.com/solutions/1228983 which explains which hosts are listed where and how to add a host from Content Hosts to the All Hosts page.

Comment 8 Dominic Cleal 2014-10-30 16:43:32 UTC
Connecting redmine issue http://projects.theforeman.org/issues/3506 from this bug

Comment 9 Dominic Cleal 2014-10-30 16:49:36 UTC
Linking a feature that was started, in which we intended to include Puppet agent configuration as part of subscription registration.  (I get the impression this is less about the UI, more about the lack of client configuration.)

Comment 10 Bryan Kearney 2014-10-30 18:05:37 UTC
Upstream bug assigned to lzap@redhat.com

Comment 13 Dominic Cleal 2014-11-28 10:11:39 UTC
*** Bug 1168854 has been marked as a duplicate of this bug. ***

Comment 14 Bryan Kearney 2015-08-25 18:32:23 UTC
Upstream bug component is Hosts

Comment 16 Justin Sherrill 2016-02-26 13:15:15 UTC
This provided via the host unification feature.  Moving to POST

Comment 18 Stephen Benjamin 2016-03-24 19:16:27 UTC
Verified.

A host registered only through subscription-manager now shows up under 'All Hosts' as well.

Comment 21 errata-xmlrpc 2016-07-27 08:45:52 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:1500


Note You need to log in before you can comment on or make changes to this bug.