Bug 115651 - wrong driver name for ES1371 audio chipset
wrong driver name for ES1371 audio chipset
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: kudzu (Show other bugs)
rawhide
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Bill Nottingham
David Lawrence
:
: 119152 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-02-14 03:49 EST by Michael Schwendt
Modified: 2014-03-16 22:42 EDT (History)
3 users (show)

See Also:
Fixed In Version: 0.107-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-02-15 23:30:21 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michael Schwendt 2004-02-14 03:49:56 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6) Gecko/20040115

Description of problem:
Kudzu returns a wrong driver name for my audio chipset, which causes
system-config-soundcard to fail:

# kudzu -p --class=AUDIO
-
class: AUDIO
bus: PCI
detached: 0
driver: snd-es1371
desc: "Ensoniq|ES1371 [AudioPCI-97]"
vendorId: 1274
deviceId: 1371
subVendorId: 1458
subDeviceId: 2060
pciType: 1
pcidom:    0
pcibus:  0
pcidev:  e
pcifn:  0

The correct driver name is "snd-ens1371" with ALSA.

Note: If the "snd-" prefix has been added compared with the OSS
drivers of the 2.4 kernel, this is likely wrong for other ALSA
drivers, too.


Version-Release number of selected component (if applicable):
kudzu-1.1.41-1

How reproducible:
Always
Comment 1 Michael Schwendt 2004-02-14 04:09:00 EST
Actually, it's snd_ens1371 (with underscore). 

[Hardcoding that driver name in system-config-soundcard's
soundcardBackend.py, the tool works. Though, it seems it doesn't
really support ALSA yet, but just ALSA's OSS compatibility layer. Weird.]
Comment 2 Bill Nottingham 2004-02-15 23:22:49 EST
Fixed, will be in 0.107-1.
Comment 3 Brent Fox 2004-03-25 13:04:33 EST
*** Bug 119152 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.