Bug 115708 - usb subsystem for 2.6.2-1.79 does not recognize usb devices
usb subsystem for 2.6.2-1.79 does not recognize usb devices
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
1
All Linux
medium Severity medium
: ---
: ---
Assigned To: Arjan van de Ven
Brian Brock
:
: 115685 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-02-15 01:16 EST by Alexander Farley
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-05-28 19:09:15 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Alexander Farley 2004-02-15 01:16:04 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6) Gecko/20040115

Description of problem:
USB devices do not seem to be recognized by kernel-2.6.2-1.79. With
the same system using kernel-2.4.22-1.2166 all of the devices are
recognized and work flawlessly. Devices include a scanner, digital
camera, usb flash drive, logitech webcam, and a usb mouse.

Version-Release number of selected component (if applicable):
kernel-2.6.2-1.79

How reproducible:
Always

Steps to Reproduce:
1. Try use any usb device with a 2.6.x kernel
2. Devices are not recognized
3.
    

Actual Results:  USB devices are not recognized and cannot be used.

Expected Results:  USB devices would be usable as they are in 2.4.x
kernels.

Additional info:

Using usbview yields an error messages that /proc/bus/usb/devices
cannot be accessed because it does not exist. However, I do not know
if this directory has changed with the upgrade to 2.6.x kernels.
Comment 1 Bill Nottingham 2004-02-16 01:36:10 EST
Do you have an 'alias usb-controller <something>' in /etc/modprobe.conf?
Comment 2 Alexander Farley 2004-02-16 12:43:29 EST
Yes, I have:
alias usb-controller usb-uhci
alias usb-controller1 ehci-hcd

lsusb produces: 
cannot open /proc/bus/usb, No such file or directory (2)

Only input and pci folders are in the /proc/bus directory.

I tried commenting the two out, but that had no effect. lsusb produces
the same error.
Comment 3 Arjan van de Ven 2004-02-16 12:44:54 EST
that's it then; it's supposed to be
uhci-hcd not usb-uhci ....
Comment 4 Alexander Farley 2004-02-16 13:14:36 EST
Indeed the change solved the problem. However, the module is not being
automatically loaded during boot-up. I had to manually load the
module, which then allowed me to access the usb devices. 

Shouldn't kudzu take care of the uhci-hcd entry if there has been a
naming change between kernels 2.4 and 2.6?
Comment 5 Alexander Farley 2004-02-16 13:16:18 EST
*** Bug 115685 has been marked as a duplicate of this bug. ***
Comment 6 Alexander Farley 2004-05-28 19:09:15 EDT
This appears to have been fixed long ago and should be closed.

Note You need to log in before you can comment on or make changes to this bug.