Bug 1157107 - String to Floating point conversion failure with client packages during mount
Summary: String to Floating point conversion failure with client packages during mount
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: core
Version: 3.6.0
Hardware: x86_64
OS: Linux
high
high
Target Milestone: ---
Assignee: Niels de Vos
QA Contact:
URL:
Whiteboard:
: 1170575 (view as bug list)
Depends On: 1117951 1122902
Blocks: glusterfs-3.6.0
TreeView+ depends on / blocked
 
Reported: 2014-10-25 08:23 UTC by Harshavardhana
Modified: 2016-02-04 15:08 UTC (History)
16 users (show)

Fixed In Version: glusterfs-v3.6.2
Doc Type: Bug Fix
Doc Text:
Clone Of: 1122902
Environment:
Last Closed: 2016-02-04 15:08:20 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)

Comment 1 Dennis Schafroth 2014-10-25 10:09:18 UTC
This has to do with locales. My locale is danish thus using comma for doubles.  

When running with LANG=da_DK.UTF-8, the LC_NUMERIC is set to da_DK.UTF-8

sudo /usr/local/sbin/glusterfs --debug --entry-timeout=1 --volfile-server=bd --volfile-id=dist-rep /mnt/glusterfs/
[2014-10-25 09:45:13.131164] I [MSGID: 100030] [glusterfsd.c:2018:main] 0-/usr/local/sbin/glusterfs: Started running /usr/local/sbin/glusterfs version 3.6.0beta3 (args: /usr/local/sbin/glusterfs --debug --entry-timeout=1 --volfile-server=bd --volfile-id=dist-rep /mnt/glusterfs/)
[2014-10-25 09:45:13.131726] D [MSGID: 0] [glusterfsd.c:409:set_fuse_mount_options] 0-glusterfsd: fopen-keep-cache mode 2
[2014-10-25 09:45:13.131748] D [MSGID: 0] [glusterfsd.c:487:set_fuse_mount_options] 0-glusterfsd: fuse no-root-squash mode 0
[2014-10-25 09:45:13.131833] I [options.c:1163:xlator_option_init_double] 0-fuse: option attribute-timeout convertion failed value 1.0
[2014-10-25 09:45:13.131848] E [xlator.c:425:xlator_init] 0-fuse: Initialization of volume 'fuse' failed, review your volfile again
[2014-10-25 09:45:13.131857] D [MSGID: 0] [glusterfsd.c:572:create_fuse_mount] 0-glusterfsd: failed to initialize fuse translator

fails. Setting LANG=en_DK.UTF-8 works (LC_NUMERIC="C".

I guess the real problem is the hardcoded values (1.0) in xlators/mount/fuse/src/fuse-bridge.c, that is parsed using localised routines.

Comment 2 Anders Blomdell 2014-10-25 14:17:50 UTC
See https://bugzilla.redhat.com/show_bug.cgi?id=1117951

Comment 3 Harshavardhana 2014-10-27 03:41:07 UTC
(In reply to Anders Blomdell from comment #2)
> See https://bugzilla.redhat.com/show_bug.cgi?id=1117951

Ah i remember this, and quickly forgot about it. Thanks for that :-), looks like that needs to go in 'release-3.6' branch.

Comment 4 Niels de Vos 2014-10-28 12:30:39 UTC
Patch from Bug 1117951: http://review.gluster.org/8299

Comment 5 Anand Avati 2014-11-15 22:42:56 UTC
REVIEW: http://review.gluster.org/9132 (Use C-locale for numeric/string conversion routines) posted (#1) for review on release-3.6 by Niels de Vos (ndevos@redhat.com)

Comment 6 Anand Avati 2014-11-17 06:55:54 UTC
COMMIT: http://review.gluster.org/9132 committed in release-3.6 by Vijay Bellur (vbellur@redhat.com) 
------
commit ca5d23c8f62eb38ea98fbb63b06f72c21ce17c87
Author: Niels de Vos <ndevos@redhat.com>
Date:   Sat Nov 15 23:40:14 2014 +0100

    Use C-locale for numeric/string conversion routines
    
    (strtod, ...) or config file parsing might fail.
    
    Cherry picked from commit 5b8de971a4b81bc2bd6de0ffc6386587226295c6:
    > Change-Id: I649f29bbf87222399a0c2d1ed5a3bf136c613b9b
    > BUG: 1117951
    > Signed-off-by: Anders Blomdell <anders.blomdell@control.lth.se>
    > Reviewed-on: http://review.gluster.org/8299
    > Tested-by: Gluster Build System <jenkins@build.gluster.com>
    > Reviewed-by: Prashanth Pai <ppai@redhat.com>
    > Reviewed-by: Vijay Bellur <vbellur@redhat.com>
    
    Change-Id: I649f29bbf87222399a0c2d1ed5a3bf136c613b9b
    BUG: 1157107
    Signed-off-by: Niels de Vos <ndevos@redhat.com>
    Reviewed-on: http://review.gluster.org/9132
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Humble Devassy Chirammal <humble.devassy@gmail.com>
    Reviewed-by: Vijay Bellur <vbellur@redhat.com>

Comment 7 Niels de Vos 2015-02-10 12:47:09 UTC
*** Bug 1170575 has been marked as a duplicate of this bug. ***

Comment 9 Kaushal 2016-02-04 15:08:20 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-v3.6.2, please open a new bug report.

glusterfs-v3.6.2 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://blog.gluster.org/2015/01/glusterfs-3-6-2-ga-released/
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user


Note You need to log in before you can comment on or make changes to this bug.