Bug 115715 - two entries in XF86Config map to same mouse but use different protocol
Summary: two entries in XF86Config map to same mouse but use different protocol
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: system-config-mouse   
(Show other bugs)
Version: rawhide
Hardware: i686
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Brent Fox
QA Contact:
URL:
Whiteboard:
Keywords:
: 117178 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-02-15 11:48 UTC by Adrian Frost
Modified: 2007-11-30 22:10 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-03-01 18:25:05 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Adrian Frost 2004-02-15 11:48:23 UTC
Description of problem:

After boot from new install to setup, mouse is unusable as it cursor
jumps to bottom left as soon as mouse button is pressed

Version-Release number of selected component (if applicable):


How reproducible:

install one mouse of type genius netscroll+


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info: 

Problem fixed by removing Mouse0 from XF86Config

diff XF86Config XF86Config.rel
6c6
<       InputDevice    "DevInputMice" "CorePointer"
---
>       InputDevice    "Mouse0" "CorePointer"
7a8
>       InputDevice    "DevInputMice" "AlwaysCore"
68,75c69,76
< #Section "InputDevice"
< #     Identifier  "Mouse0"
< #     Driver      "mouse"
< #     Option      "Protocol" "NetMousePS/2"
< #     Option      "Device" "/dev/psaux"
< #     Option      "ZAxisMapping" "4 5"
< #     Option      "Emulate3Buttons" "no"
< #EndSection
---
> Section "InputDevice"
>       Identifier  "Mouse0"
>       Driver      "mouse"
>       Option      "Protocol" "NetMousePS/2"
>       Option      "Device" "/dev/psaux"
>       Option      "ZAxisMapping" "4 5"
>       Option      "Emulate3Buttons" "no"
> EndSection

Comment 1 Brent Fox 2004-03-01 18:25:05 UTC
This will be fixed with test2.  All mice will now use /dev/input/mice.

Comment 2 Brent Fox 2004-03-02 15:34:17 UTC
*** Bug 117178 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.