Bug 1157259 - gdm double username prompt after session idle with disable-user-list
Summary: gdm double username prompt after session idle with disable-user-list
Keywords:
Status: CLOSED DUPLICATE of bug 1109530
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: gdm
Version: 7.0
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: Ray Strode [halfline]
QA Contact: Desktop QE
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-10-26 18:42 UTC by Nicholas, Crawford
Modified: 2015-02-02 19:33 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-10-29 17:50:26 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Nicholas, Crawford 2014-10-26 18:42:15 UTC
Description of problem:
While running with disable-user-list, after session idle causes the login screen to blank and lock, upon "unlocking" you are prompted twice for a username.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 2 Nicholas, Crawford 2014-10-26 18:58:19 UTC
My sincere apologies, I mistakenly hit enter while editing the summary and posted this bug incomplete.  I apparently can't edit the initial report now.

Description of problem:
While running with disable-user-list, after session idle causes the login screen to blank and lock, upon "unlocking" you are prompted twice for a username.

Version-Release number of selected component (if applicable):
gdm-3.8.4-28.el7_0.1.x86_64

How reproducible:
100%

Steps to Reproduce:
1.  create dconf rules to disable the user-list, and lower session idle to aide in debugging.

# echo -e "[org/gnome/desktop/session]\nidle-delay=uint32 15\n\n[org/gnome/login-screen]\ndisable-user-list=true" > /etc/dconf/db/site.d/00-test
# echo -e "/org/gnome/desktop/session/idle-delay\n/org/gnome/login-screen/disable-user-list" > /etc/dconf/db/site.d/locks/00-test-locks
# dconf update

2. Reboot and allow login screen to blank
3. Wake login screen and notice Username prompting twice.

Actual results:
User is prompted twice for username. The first prompt appears to be ignored and will accept any text.

Expected results:
User is not prompted twice, but allowed to login normally.

Additional info:
Work-around: setting idle-delay to "uint32 0" for gdm and preventing the screen from blanking allows the user to login normally.  However, the screen appears to never blank nor go to sleep.

Comment 3 Nicholas, Crawford 2014-10-26 19:22:20 UTC
Potentially related https://bugzilla.redhat.com/show_bug.cgi?id=1157266

Comment 4 Ray Strode [halfline] 2014-10-29 17:50:26 UTC
Thank you for your bug report. This issue is already been tracked in our bug tracking system via bug 1109530. A fix for this issue is slated to be released in the next synchronous update (Red Hat Enterprise Linux 7.1).

*** This bug has been marked as a duplicate of bug 1109530 ***


Note You need to log in before you can comment on or make changes to this bug.