Bug 1157266 - gdm loss of banner-text after session idle with disable-user-list
Summary: gdm loss of banner-text after session idle with disable-user-list
Keywords:
Status: CLOSED DUPLICATE of bug 1109530
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: gdm
Version: 7.0
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: Ray Strode [halfline]
QA Contact: Desktop QE
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-10-26 19:20 UTC by Nicholas, Crawford
Modified: 2014-10-29 17:52 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-10-29 17:52:28 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Nicholas, Crawford 2014-10-26 19:20:58 UTC
Description of problem:
With disable-user-list set when a banner is properly set and displayed, once the screen blanks and locks the banner is lost.

Without disable-user-list the banner is displayed normally only once a user is selected or 'Not listed?' is selected.  Contrasted with disable-user-list where the banner is displayed on the initial screen.

Version-Release number of selected component (if applicable):
gdm-3.8.4-28.el7_0.1.x86_64


How reproducible:
100%

Steps to Reproduce:
1. create dconf rules to disable the user-list and display a banner, also lower session idle to aide in debugging

# echo -e "[org/gnome/desktop/session]\nidle-delay=uint32 15\n\n[org/gnome/login-screen]\ndisable-user-list=true\nbanner-message-enable=true\nbanner-message-text=\"This is a banner\"\n" > /etc/dconf/db/site.d/00-test
# echo -e "/org/gnome/desktop/session/idle-delay\n/org/gnome/login-screen/disable-user-list\n/org/gnome/login-screen/banner-message-enable\n/org/gnome/login-screen/banner-message-text" > /etc/dconf/db/site.d/locks/00-test-locks
# dconf update

2.  Reboot, notice the banner displayed on the login screen
3.  Allow the screen to blank
4.  Wake the login screen and notice the banner is now gone

Actual results:
Banner is lost when login screen blanks.

Expected results:
Banner is displayed when login screen returns from lock/blank.


Additional info:
Work-around: setting idle-delay to "uint32 0" for gdm and preventing the screen  from blanking allows the user to login normally.  However, the screen appears to never blank nor go to sleep.

Unfortunately, disabling idle-activation-enabled and lock-enabled appear to have no affect on this bug.

Comment 1 Nicholas, Crawford 2014-10-26 19:22:22 UTC
Potentially related https://bugzilla.redhat.com/show_bug.cgi?id=1157259

Comment 3 Nicholas, Crawford 2014-10-27 04:14:44 UTC
Apologies,

The original report includes an error from a careless cut'n'paste.

in Work-around;

"setting idle-delay to "uint32 0" for gdm and preventing the screen  from blanking allows the user to login normally."

Should read;

"setting idle-delay to "uint32 0" for gdm prevents the screen from blanking and guarantees the banner will continue to display."

Comment 4 Ray Strode [halfline] 2014-10-29 17:52:28 UTC
Thank you for your bug report. This issue is already being tracked in our bug tracking system via bug 1109530. A fix for this issue is slated to be released in the next synchronous update (Red Hat Enterprise Linux 7.1).

*** This bug has been marked as a duplicate of bug 1109530 ***


Note You need to log in before you can comment on or make changes to this bug.