Bug 115748 - EHCI not detected unless acpi=off
EHCI not detected unless acpi=off
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
rawhide
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Linux ACPI Developers
:
: 120306 (view as bug list)
Depends On:
Blocks: FC2Target FC3Target
  Show dependency treegraph
 
Reported: 2004-02-15 12:32 EST by Antti Markus
Modified: 2007-11-30 17:10 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-10-25 12:42:41 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
dmesg output when rebooting while USB stick was plugged in (3.33 KB, text/plain)
2004-02-15 12:47 EST, Antti Markus
no flags Details
dmesg output when rebooting while USB stick was plugged in (kernel-2.6.3-1.91) (2.77 KB, text/plain)
2004-02-20 14:51 EST, Antti Markus
no flags Details
dmesg output when removing USB stick (kernel 2.6.3-1.91) (1.91 KB, text/plain)
2004-02-20 15:53 EST, Antti Markus
no flags Details
lspci output (1.29 KB, text/plain)
2004-03-02 13:28 EST, Antti Markus
no flags Details
lspci -vv output (8.26 KB, text/plain)
2004-03-02 13:47 EST, Antti Markus
no flags Details
lspci -vv output for 2.6.3-1.118 (11.18 KB, text/plain)
2004-03-02 16:23 EST, Antti Markus
no flags Details
/proc/pci for 2.6.3-1.118 (2.95 KB, text/plain)
2004-03-02 16:24 EST, Antti Markus
no flags Details
lspci -vv output for Compaq Deskpro EP running Debian 2.6.3 kernel (4.50 KB, text/plain)
2004-03-03 05:18 EST, Antti Markus
no flags Details
dmesg output when rebooting while USB stick was plugged in (kernel-2.6.3-1.118) (2.75 KB, text/plain)
2004-03-03 14:45 EST, Antti Markus
no flags Details
dmesg output when removing USB stick (kernel 2.6.3-1.118) (740 bytes, text/plain)
2004-03-03 14:50 EST, Antti Markus
no flags Details
dmesg output when inserting USB stick (kernel 2.6.3-2.1.238) (2.67 KB, text/plain)
2004-03-06 05:15 EST, Antti Markus
no flags Details
/var/log/messages when booting 2.6.3-2.1.238 (27.71 KB, text/plain)
2004-03-06 05:26 EST, Antti Markus
no flags Details
dmesg output when removing USB memory stick (kernel 2.6.3-2.1.238) (703 bytes, text/plain)
2004-03-06 05:29 EST, Antti Markus
no flags Details
dmesg output when inserting USB stick (kernel 2.6.3-2.1.240, acpi=off). kobject_register still fails. (1.88 KB, text/plain)
2004-03-07 07:20 EST, Antti Markus
no flags Details
dmesg output for 2.6.5-1.319, acpi=on (14.16 KB, text/plain)
2004-04-13 13:56 EDT, Antti Markus
no flags Details
/var/log/messages when booting 2.6.5-1.319 with acpi=off (35.32 KB, text/plain)
2004-04-13 13:58 EDT, Antti Markus
no flags Details
One of the subsequent kobject_register failures when inserting USB stick (1.41 KB, text/plain)
2004-04-13 14:01 EDT, Antti Markus
no flags Details
acpidmp output (76.55 KB, text/plain)
2004-04-14 15:19 EDT, Antti Markus
no flags Details

  None (edit)
Description Antti Markus 2004-02-15 12:32:28 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (compatible; Konqueror/3.2; Linux) (KHTML, like Gecko)

Description of problem:
USB storage stick (Vmax 256MB model) isn't detected by the kernel. I also tried Trust QZ 501 USB joystick and it also wasn't detected by the kernel. Tried to boot the kernel with acpi=off and acpi=on parameters - no difference.

Version-Release number of selected component (if applicable):
kernel-2.6.1-1.65

How reproducible:
Always

Steps to Reproduce:
1. boot Fedora Core 2 test 1
2. plug in USB flash storage stick or USB joystick

    

Actual Results:  dmesg output doesn't show that USB devices were plugged in

Expected Results:  dmesg output should have shown that USB device was plugged in

Additional info:
Comment 1 Antti Markus 2004-02-15 12:47:17 EST
Created attachment 97692 [details]
dmesg output when rebooting while USB stick was plugged in
Comment 2 Antti Markus 2004-02-15 12:49:02 EST
USB stick was detected when it was left plugged in and the computer 
(Compal CL50 laptop) was rebooted. 
Comment 3 Antti Markus 2004-02-17 14:25:25 EST
Same issue with package kernel-2.6.2-1.85. Only diffrence was when 
computer was rebooted with USB stick plugged in and the 
kobject_register didn't fail for sda1. 
Comment 4 Antti Markus 2004-02-18 12:38:30 EST
The same vith kernel-2.6.2-1.87.
Comment 5 Antti Markus 2004-02-20 14:49:34 EST
Same issue also with kernel-2.6.3-1.91. But this version again gives 
the kobject_register failed for sda1 error. 
Comment 6 Antti Markus 2004-02-20 14:51:43 EST
Created attachment 97880 [details]
dmesg output when rebooting while USB stick was plugged in (kernel-2.6.3-1.91)
Comment 7 Antti Markus 2004-02-20 15:53:55 EST
Created attachment 97886 [details]
dmesg output when removing USB stick (kernel 2.6.3-1.91)

After USB stick was connected after rebooting with it in place, I mounted it,
read some files and unmounted. Then I removed the USB stick and slab corruption
was reported in dmesg output.
Comment 8 Need Real Name 2004-02-22 12:26:13 EST
FC2 test1 can't find my HP1200 printer on USB, ptal-init setup can't
find it after boot up. FC1 had no problem same hardware. Windows boot
on same no prob.
Comment 9 Need Real Name 2004-02-23 21:35:31 EST
Have solved my ptal problem. My feeble attempt to retain user accounts
and other goodies led me to install the new release on top of the old
system without formating the partition. I gave in and installed with
format and the kernel found the USB devices. ptal-connect -scan worked
and I am not off to get the printer going.
Comment 10 Wayne Walker 2004-02-28 20:56:41 EST
I too see nothing in dmesg about USB at all.  Just upgraded from FC1
to FC2 test1.

This is on my IBM Thinkpad 600X.

My desktop machine (also just upgraded from FC1 to FC2 test1)

Kernel 2.6.1-1.65.
Comment 11 Antti Markus 2004-02-29 06:48:15 EST
kernel 2.6.3-1.110. When computer is booted with acpi=off then kudzu 
reports that USB device Intel Corp.|82801DB USB2 is found. When so 
chosen the device is configured and computer is booted OK. But still 
USB devices are not detected.  
 
When booted with acpi=on then kudzu reports that the device Intel 
Corp.|82801DB USB2 has been removed. 
Comment 12 Antti Markus 2004-03-01 14:53:20 EST
kernel-2.6.3-1.116 - the same as 2.6.3-1.110. Also tried booting 
with pci=noacpi but no difference. 
Comment 13 Antti Markus 2004-03-02 13:28:55 EST
Created attachment 98203 [details]
lspci output
Comment 14 Antti Markus 2004-03-02 13:47:16 EST
Created attachment 98204 [details]
lspci -vv output
Comment 15 Antti Markus 2004-03-02 16:21:08 EST
kernel-2.6.3-1.118 - the same as 2.6.3-1.116. 
Comment 16 Antti Markus 2004-03-02 16:23:52 EST
Created attachment 98214 [details]
lspci -vv output for 2.6.3-1.118
Comment 17 Antti Markus 2004-03-02 16:24:37 EST
Created attachment 98215 [details]
/proc/pci for 2.6.3-1.118
Comment 18 Antti Markus 2004-03-03 05:15:22 EST
Tried the same USB storage stick on Compaq Deskpro EP workstation
running Debian with kernel 2.6.3 (2.6.3-1-686). USB stick insertion
was detected and it could be mounted.
Comment 19 Antti Markus 2004-03-03 05:18:13 EST
Created attachment 98233 [details]
lspci -vv output for Compaq Deskpro EP running Debian 2.6.3 kernel
Comment 20 Antti Markus 2004-03-03 14:45:37 EST
Created attachment 98254 [details]
dmesg output when rebooting while USB stick was plugged in (kernel-2.6.3-1.118)

kobject_register failed for sda1 (-17)
Comment 21 Antti Markus 2004-03-03 14:50:44 EST
Created attachment 98256 [details]
dmesg output when removing USB stick (kernel 2.6.3-1.118)

After USB stick was connected after rebooting with it in place, I mounted it,
read some files and unmounted. Then I removed the USB stick and slab corruption
was reported in dmesg output.
Comment 22 Antti Markus 2004-03-06 05:09:44 EST
Partial success with kernel-2.6.3-2.1.238 - when booted with 
acpi=off and pci=noacpi then USB memory stick insertion was detected 
and USB memory stick could be mounted (but /mnt/flash directory was 
not automatically created as with previous kernels when computer was 
booted while USB stick was plugged in). When booting with acpi=on 
the USB stick was not detected. 
Comment 23 Antti Markus 2004-03-06 05:15:21 EST
Created attachment 98338 [details]
dmesg output when inserting USB stick (kernel 2.6.3-2.1.238)

USB stick insertion causes "kobject_register failed for sda1 (-17)" error.
Comment 24 Antti Markus 2004-03-06 05:26:15 EST
Created attachment 98339 [details]
/var/log/messages when booting 2.6.3-2.1.238
Comment 25 Antti Markus 2004-03-06 05:29:42 EST
Created attachment 98340 [details]
dmesg output when removing USB memory stick (kernel 2.6.3-2.1.238)

Slab corruption is still present.
Comment 26 Antti Markus 2004-03-07 07:20:34 EST
Created attachment 98356 [details]
dmesg output when inserting USB stick (kernel 2.6.3-2.1.240, acpi=off). kobject_register still fails.

When booting with acpi=on then USB stick is not detected. Works with acpi=off.
Comment 27 Antti Markus 2004-03-09 14:16:57 EST
kernel-2.6.3-2.1.242: 
- acpi=on - kudzu reports that the device Intel Corp.|82801DB USB2 
has been removed while booting (which is pretty weird considering 
that I'm using a laptop :)) 
- acpi=off - USB stick works (but kobject_register fails on 
insertion) 
Comment 28 Antti Markus 2004-03-17 16:36:24 EST
The same with kernel-2.6.3-2.1.253.2.1 
Comment 29 Len Brown 2004-03-24 04:36:40 EST
I'm a little lost in the comments, perhaps you can summarize...

Exactly what fails with acpi=off vs acpi=on?

You tested two laptops, did they behave differently?

thanks,
-Len
Comment 30 Antti Markus 2004-03-24 08:45:39 EST
acpi=on - kudzu reports that the device Intel Corp.|82801DB USB2 
has been removed
acpi=off - device Intel Corp.|82801DB USB2 is recognized and configured 

And I haven't tested two laptops - I've been using the same Compal
CL-50 laptop.
Comment 31 Antti Markus 2004-04-05 14:06:53 EDT
kernel 2.6.4-1.305 (Fedora Core 2 test 2) 
acpi=on - kudzu reports that the device Intel Corp.|82801DB USB2  
has been removed 
acpi=off - device Intel Corp.|82801DB USB2 seems to be recognized but 
USB stick doesn't work 
Comment 32 Antti Markus 2004-04-09 05:21:44 EDT
kernel 2.6.5-1.308 (Fedora Core 2 test 2) 
acpi=on - kudzu reports that the device Intel Corp.|82801DB USB2   
has been removed 
acpi=off - device Intel Corp.|82801DB USB2 seems to be recognized but  
USB stick doesn't work (USB stick can only be accessed if USB stick 
is plugged in while booting) 
Comment 33 Antti Markus 2004-04-12 15:08:35 EDT
kernel 2.6.5-1.315 (Fedora Core 2 test 2) 
acpi=on - device Intel Corp.|82801DB USB2 is not recognized 
acpi=off - device Intel Corp.|82801DB USB2 is recognized but USB 
storage stick doesn't work 
Comment 34 Antti Markus 2004-04-13 13:55:31 EDT
kernel 2.6.5-1.319 (Fedora Core 2 test 2) 
acpi=on - device Intel Corp.|82801DB USB2 is not recognized 
acpi=off - device Intel Corp.|82801DB USB2 is recognized and USB 
stick works (some USB stick insertions gave "kobject_register failed 
for sda1 (-17)" error, see attachments) 
Comment 35 Antti Markus 2004-04-13 13:56:41 EDT
Created attachment 99370 [details]
dmesg output for 2.6.5-1.319, acpi=on
Comment 36 Antti Markus 2004-04-13 13:58:52 EDT
Created attachment 99371 [details]
/var/log/messages when booting 2.6.5-1.319 with acpi=off

Also contains kobject_register failure when first inserting USB stick.
Comment 37 Antti Markus 2004-04-13 14:01:59 EDT
Created attachment 99373 [details]
One of the subsequent kobject_register failures when inserting USB stick

USB stick could be mounted OK and files accessed normally.
Comment 38 Len Brown 2004-04-13 16:05:12 EDT
both acpi=on and acpi=off discover the uhci_hcd's at: 
 
0000:00:1d.0 
0000:00:1d.1 
0000:00:1d.2 
 
But only acpi=off discovers ehci at 0000:00:1d.7: 
 
PCI: Found IRQ 11 for device 0000:00:1d.7 
ehci_hcd 0000:00:1d.7: EHCI Host Controller 
ehci_hcd 0000:00:1d.7: irq 11, pci mem 22837000 
ehci_hcd 0000:00:1d.7: new USB bus registered, assigned bus number 4 
PCI: cache line size of 32 is not supported by device 0000:00:1d.7 
ehci_hcd 0000:00:1d.7: USB 2.0 enabled, EHCI 1.00, driver 2003-Dec-29 
hub 4-0:1.0: USB hub found 
hub 4-0:1.0: 6 ports detected 
 
From lspci: 
0000:00:1d.7 USB Controller: Intel Corp. 82801DB USB2 (rev 03) (prog-if 20 
[EHCI]) 
        Subsystem: COMPAL Electronics Inc: Unknown device 0012 
        Control: I/O- Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- 
Stepping- SERR- FastB2B- 
        Status: Cap+ 66Mhz- UDF- FastB2B+ ParErr- DEVSEL=medium >TAbort- 
<TAbort- <MAbort- >SERR- <PERR- 
        Latency: 0 
        Interrupt: pin D routed to IRQ 11 
        Region 0: Memory at f4000000 (32-bit, non-prefetchable) 
        Capabilities: [50] Power Management version 2 
                Flags: PMEClk- DSI- D1- D2- AuxCurrent=375mA 
PME(D0+,D1-,D2-,D3hot+,D3cold+) 
                Status: D0 PME-Enable- DSel=0 DScale=0 PME- 
        Capabilities: [58] #0a [2080] 
 
Can you check if the USB stick works on the acpi=on kernel when 
it is plugged into UHCI instead of EHCI? 
 
Not immediately obvious why EHCI isn't probling out. 
Can you attach the output from acpidmp, available in /usr/sbin 
or pmtools: http://ftp.kernel.org/pub/linux/kernel/people/lenb/acpi/utils/ 
 
Does the vanilla 2.6.5 from kernel.org behaves the same as the 
Red Hat 2.6.5* kernel? 
 
thanks, 
-Len 
 
Comment 39 Antti Markus 2004-04-14 15:19:17 EDT
Created attachment 99420 [details]
acpidmp output
Comment 40 Len Brown 2004-04-16 03:40:38 EDT
DSDT:      Package (0x04) { 0x001DFFFF, 0x00, \_SB.PCI0.LPCB.LNKA, 0x00 }, 
                Package (0x04) { 0x001DFFFF, 0x01, \_SB.PCI0.LPCB.LNKD, 0x00 }, 
                Package (0x04) { 0x001DFFFF, 0x02, \_SB.PCI0.LPCB.LNKC, 0x00 }, 
                Package (0x04) { 0x001DFFFF, 0x03, \_SB.PCI0.LPCB.LNKH, 0x00 } } 
 
lspci says device 1D function 7 is on pin D, so that is LNKH 
 
dmesg found this link: 
ACPI: PCI Interrupt Link [LNKH] (IRQs 5 7 9 10 *11) 
However, there is no message that it was enabled, which 
means we didn't probe out any PCI devices that use it, 
which I guess brings us back to where we started;-) 
the PCI probe doesn't find this device. 
 
Comment 41 shaohua li 2004-04-16 04:10:59 EDT
could you try the patch http://bugme.osdl.org/show_bug.cgi?id=1662. 
And test which option help you in 'pci=noacpi', 'acpi=noirq', 
and 'acpi=off'. So we can narrow the problem down. Thanks
Comment 42 Antti Markus 2004-04-17 14:31:42 EDT
Applied the patch to 2.6.5-1.326 
Only option that helped was acpi=off. 
Comment 43 shaohua li 2004-04-19 05:23:44 EDT
I just checked the DSDT, in the PCI0._INI method, I found some 
interesting, 
the code of _INI method is below:
         Method (_INI, 0, NotSerialized)
            {
                Store (SizeOf (_OS), Local1)
                If (LEqual (Local1, 0x14))
                {
                    Store (0x01, MYOS)
                }
                Else
                {
                    If (LEqual (Local1, 0x27))
                    {
                        Store (0x02, MYOS)
                        Or (\_SB.PCI0.LPCB.FDIS, 0x8000, 
B.PCI0.LPCB.FDIS)
                    }
                    Else
                    {
                        Store (0x03, MYOS)
                        Or (\_SB.PCI0.LPCB.FDIS, 0x8000, 
\_SB.PCI0.LPCB.FDIS)
                    }
                }
            }
according to ICH4 manual, 'Or (\_SB.PCI0.LPCB.FDIS, 0x8000, 
\_SB.PCI0.LPCB.FDIS)' will disable EHCI device (that is the device 
you miss). So this code means BIOS of the system will enable EHCI 
default, and disable it according to specific OS. can you try to 
add 'acpi_os_name= ...' option to see if the behave vary in latest 
kernel? Please note the os name whose length should be 20 byte. 
Thanks.

Comment 44 Antti Markus 2004-04-20 12:15:30 EDT
Yes, acpi_os_name=XXXXXYYYYYZZZZZXXXXX did the trick - EHCI 
controller was recognized and configured and USB stick works OK.  
 
Quite embarrassing really - this issue is described in Gentoo Linux 
HOWTO: Fix Common ACPI Problems (DSDT, ECDT, etc.) 
(http://forums.gentoo.org/viewtopic.php?t=122145) which is dated a 
month before by bug report. I guess I should have dug harder before 
clicking submit button... :( 
Comment 45 Pete Zaitcev 2004-04-20 15:11:07 EDT
Reassigning to acpi-bugzilla@lists.sourceforge.net per suggestion
by Arjan.
Comment 46 Fulko Hew 2004-05-21 09:42:08 EDT
*** Bug 120306 has been marked as a duplicate of this bug. ***
Comment 47 Bill Nottingham 2004-08-11 16:07:40 EDT
Does this behave better with the FC3test1 kernel - we have a tweak
there for setting the ACPI name?
Comment 48 Antti Markus 2004-08-13 17:59:24 EDT
Yes, FC3 test1 kernel (2.6.7-1.478) seems to behave correctly - EHCI
controller was recognized and USB stick insertion event was also
processed OK.

Note You need to log in before you can comment on or make changes to this bug.