Bug 120306 - USB does not detect newly plugged in devices
USB does not detect newly plugged in devices
Status: CLOSED DUPLICATE of bug 115748
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
rawhide
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Pete Zaitcev
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-04-07 13:31 EDT by Fulko Hew
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 14:02:28 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Fulko Hew 2004-04-07 13:31:50 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6) Gecko/20040312

Description of problem:
When testing my digital camera with gtkam, I discovered it wouldn't
detect my camera.  Upon further investigation it seems that the USB
sub-system did not auto-detect the newly plugged in device.  Using
lsusb only shows the controllers.  This problem exists regardless of
the USB device type.

When I had the camera (also tested with a web cam, and floppy) plugged
in at boot time, the USB had the devices listed  via lsusb, (and
therefore functioned).  As soon as the device was unplugged, the device
was no longer visible with lsusb, nor operational.


Version-Release number of selected component (if applicable):
kernel-2.6.4-1.305

How reproducible:
Always

Steps to Reproduce:
1. plug in USB device.
2. reboot
3. use 'lsusb' to view the device's presence.
4. unplug the device.
5. use 'lsusb' to see the device gone.
6. plug in USB device.
7. use 'lsusb' to see that the device is still missing.

    

Expected Results:  The device should reappear when hot-plugged in.

Additional info:
Comment 1 Fulko Hew 2004-05-12 10:54:43 EDT
I have tested the same hardware with RH9, and it behaves correctly.
So this is an issue with FC2 (I have not tested FC1).

With the release of Knoppix (supporting kernel 2.6.5) I have tested
with that, and it also works correctly.

As a result I do not know if its a difference between FC2's kernel
and Knoppix's kernel, or an issue with the remainder of the FC2
distribution versus the Knoppix distribution.

I have also fetched and built kernel 2.6.6-rc3 and 2.6.6 and both
exhibit the same failure when run within the FC2 environment.
Comment 2 Fulko Hew 2004-05-21 09:40:23 EDT
Apparently this is a buggy ACPI issue, with the same conclusion as:
http://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=115748
in comment #44.

The workaround is to add a kernel parameter:
acpi_os_name=xxxxxyyyyyzzzzzxxxxx

What is interesting is that the kernel 2.6.6 supplied by Knoppix
(aka. Debian) seems to take this into account and exhibited no 
problems although without the apparent kernel parameter (I couldn't 
find it).
Comment 3 Fulko Hew 2004-05-21 09:42:05 EDT

*** This bug has been marked as a duplicate of 115748 ***
Comment 4 Red Hat Bugzilla 2006-02-21 14:02:28 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.