Bug 115755 - X Window System Crash Firstboot, then everytime
X Window System Crash Firstboot, then everytime
Status: CLOSED DUPLICATE of bug 116937
Product: Fedora
Classification: Fedora
Component: firstboot (Show other bugs)
rawhide
i686 Linux
medium Severity high
: ---
: ---
Assigned To: Brent Fox
:
: 115758 (view as bug list)
Depends On:
Blocks: FC2Blocker
  Show dependency treegraph
 
Reported: 2004-02-15 14:33 EST by Mark Tuttle
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 14:01:18 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
/var/log/messages (44.10 KB, text/plain)
2004-02-17 10:52 EST, Mark Tuttle
no flags Details
new /var/log/messages (21.72 KB, text/plain)
2004-02-22 20:18 EST, Mark Tuttle
no flags Details

  None (edit)
Description Mark Tuttle 2004-02-15 14:33:58 EST
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1)

Description of problem:
Here is the error that occurs:

** (firstboot.py.1998): WARNING **: 'gtktextsearchflag' is not an 
enum type

Window manager warning: Failed to open connection to session manager, 
so window positions will not be saved: SESSION_MANAGER environment 
variable not defined


Version-Release number of selected component (if applicable):
Fedora Core 2 test1's version packaged

How reproducible:
Always

Steps to Reproduce:
1. Install Fedora Core 2 test1 with all packages
2. Run Fedora Core 2
3. Get the bug, and then turn off the computer
    

Actual Results:  The computer freezes afterwords, and you are locked 
out.

Expected Results:  You should have been able to booted into X Window 
System 

Additional info:

This happens everytime, and I cannot determine the source of the 
problem and/or how to fix it.
Comment 1 Mike A. Harris 2004-02-15 16:19:39 EST
*** Bug 115758 has been marked as a duplicate of this bug. ***
Comment 2 Brent Fox 2004-02-16 16:29:34 EST
Can you attach the /var/log/messages file?
Comment 3 Mark Tuttle 2004-02-17 10:52:27 EST
Created attachment 97751 [details]
/var/log/messages

Here is /var/log/messages
Comment 4 Brent Fox 2004-02-19 20:24:18 EST
The /var/log/messages doesn't contain any firstboot messages...that is
surprising to me.  Firstboot will usually write out some error
messages when it runs.  Perhaps this file was from a day or so after
firstboot had been run?  Try grepping for firstboot in
/var/log/messages* and see if the older logs are still around.  
Comment 5 Mark Tuttle 2004-02-22 20:18:57 EST
Created attachment 97936 [details]
new /var/log/messages

I reformatted my hard drive and installed Fedora Core 2 test1 again. I ran
Fedora (firstboot) until it froze to the same spot again. I then popped CD 1 in
my computer and restarted. Using Fedora's rescue program, I copied the messages
file to a floppy and uploaded it here again.
Comment 6 Brent Fox 2004-03-04 13:37:45 EST
I'm trying to figure out if the crash is related to firstboot or XFree86.

A couple of questions:

1) Did the installer work in graphical mode?  Or did you use text mode?

2) After rebooting after the installation is finished, do you see the
graphical bootup screen?  This should happen before the firstboot
program gets run.  All you should see on the screen is a computer icon
and a progress bar as the system is starting up.
Comment 7 Mark Tuttle 2004-03-04 15:45:55 EST
1) Did the installer work in graphical mode?  Or did you use text 
mode?

Answer: No, I can only install Fedora in text mode, not graphical. If 
I was to install it in graphical, I would only get as far as the X 
mouse pointer and patterned backround

2) After rebooting after the installation is finished, do you see the
graphical bootup screen?  This should happen before the firstboot
program gets run.  All you should see on the screen is a computer icon
and a progress bar as the system is starting up.

Answer: Yes, I see the graphical bootup screen working, and it almost 
finishes actaully. When it is about 90 percent done, (while still in 
graphical) the console maximizes on screen and errors out at:

** (firstboot.py.1998): WARNING **: 'gtktextsearchflag' is not an 
enum type

Window manager warning: Failed to open connection to session manager, 
so window positions will not be saved: SESSION_MANAGER environment 
variable not defined

Comment 8 Brent Fox 2004-03-04 16:40:53 EST
Ok, the fact that the graphical installer doesn't work makes this bug
sound like a dupe of bug 116937.

*** This bug has been marked as a duplicate of 116937 ***
Comment 9 Greg Hogan 2004-03-05 21:32:28 EST
I had this exact problem.  It was a problem with the radeon xfree86
driver and my radeon 9800.  The man page for the radeon driver only
claims support up to r350 (9700) cards. Not r360 (9800) cards.  Maybe
not radeon 9600's either.  But adding "ChipID 0x4E46" to my XF86Config
makes the driver think I have a 9700 and x works right again.  From
what I've read, only certain drawing operations trigger the lock up.
Comment 10 Red Hat Bugzilla 2006-02-21 14:01:18 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.