Bug 1158409 - sapconf does not activate "sap-netweaver" tuned profile
Summary: sapconf does not activate "sap-netweaver" tuned profile
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: sapconf
Version: 7.0
Hardware: All
OS: Linux
high
high
Target Milestone: rc
: 7.1
Assignee: Jan Grulich
QA Contact: cluster-qe@redhat.com
URL:
Whiteboard:
Depends On:
Blocks: 1018952 1158894
TreeView+ depends on / blocked
 
Reported: 2014-10-29 10:25 UTC by Frank Danapfel
Modified: 2015-03-05 06:48 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of: 1158407
: 1158894 (view as bug list)
Environment:
Last Closed: 2015-03-05 06:48:22 UTC
Target Upstream Version:


Attachments (Terms of Use)
patch to modify sapconf to activate the "sap-netweaver" profile (1.76 KB, patch)
2014-10-29 10:41 UTC, Frank Danapfel
no flags Details | Diff


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2015:0316 normal SHIPPED_LIVE sapconf bug fix update 2015-03-05 11:46:57 UTC

Description Frank Danapfel 2014-10-29 10:25:47 UTC
Description of problem:
Since the tuned profiles for SAP NetWeaver are going to be shipped via the "tuned-profiles-sap" package (see https://bugzilla.redhat.com/show_bug.cgi?id=1058483) and the "sap" profile has been renamed to "sap-netweaver", sapconf needs to be updated.

Version-Release number of selected component (if applicable):
sapconf-0.97-2.el7.noarch

How reproducible:
always

Steps to Reproduce:
1. install sapconf
2. run sapconf
3. check active tuned profile

Actual results:
- only tuned package is installed as dependency:
# yum install sapconf
...
Installing for dependencies:
 tuned    noarch     2.3.0-11.el7_0.3    rhel-x86_64-server-7

- tuned profile activation fails with "Unable to activate tuned 'sap' profile."

Expected results:
- sapconf rpm should have "tuned-profiles-sap" as dependency
- TUNED_SAP_PROFILE variable needs to be changed from "sap" to "sap-netweaver"

Additional info:

Comment 2 Frank Danapfel 2014-10-29 10:41:36 UTC
Created attachment 951740 [details]
patch to modify sapconf to activate the "sap-netweaver" profile

Comment 5 Jan Grulich 2014-11-03 09:30:42 UTC
Fixed in sapconf-0.98-4.el7.

Comment 6 Jan Grulich 2014-11-06 14:15:03 UTC
Properly fixed in sapconf-0.98-5.el7.

Comment 10 errata-xmlrpc 2015-03-05 06:48:22 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2015-0316.html


Note You need to log in before you can comment on or make changes to this bug.