Bug 11586 - traceroute doesn't determine correct source address
traceroute doesn't determine correct source address
Status: CLOSED DUPLICATE of bug 9351
Product: Red Hat Raw Hide
Classification: Retired
Component: traceroute (Show other bugs)
1.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Crutcher Dunnavant
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-05-22 16:25 EDT by Jonathan Kamens
Modified: 2008-05-01 11:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-05-22 16:25:13 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jonathan Kamens 2000-05-22 16:25:13 EDT
I have two IP addresses bound to eth0, one on device eth0 and one on device
eth0:0.  When I do a traceroute to an address which routes through eth0:0,
traceroute by default uses as its packets' source address the address bound
to eth0, which means that none of the traceroute packets ever make it back
to my machine (since the address on eth0 is a local-network-only address).

Traceroute should be smart enough to determine what interface its packets
will route through and automatically use that interface's address as the
packets' source address.
Comment 1 Preston Brown 2000-07-10 11:02:47 EDT

*** This bug has been marked as a duplicate of 9351 ***

Note You need to log in before you can comment on or make changes to this bug.