Bug 115861 - Python error in diskcheck reported by cron.
Python error in diskcheck reported by cron.
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: diskcheck (Show other bugs)
rawhide
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Harald Hoyer
:
: 117257 (view as bug list)
Depends On:
Blocks: FC2Blocker
  Show dependency treegraph
 
Reported: 2004-02-16 13:22 EST by Michael Dale Long
Modified: 2007-11-30 17:10 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-05-06 09:53:44 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michael Dale Long 2004-02-16 13:22:04 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.5)
Gecko/20031007

Description of problem:
An error in the diskcheck script is reported regularly by cron.
An example of the error is listed below.

Version-Release number of selected component (if applicable):
1.5-1

How reproducible:
Always

Steps to Reproduce:
1.Install Fedora Core 2 test 1
2.Wait until after diskcheck has run at least once.
3.
    

Actual Results:  A Python error is reported

Expected Results:  No message (unless free disk space was below set
warning limits).

Additional info:

Date: Sat, 14 Feb 2004 17:01:00 -0800
From: root@<NAME REMOVED> (Cron Daemon)
To: root@<NAME REMOVED>
Subject: Cron <root@<NAME REMOVED>> run-parts /etc/cron.hourly
X-Cron-Env: <SHELL=/bin/bash>
X-Cron-Env: <PATH=/sbin:/bin:/usr/sbin:/usr/bin>
X-Cron-Env: <MAILTO=root>
X-Cron-Env: <HOME=/>
X-Cron-Env: <LOGNAME=root>

/etc/cron.hourly/diskcheck:

Traceback (most recent call last):
  File "/etc/cron.hourly/diskcheck", line 318, in ?
    high += scan_df(list, "Inodes:")
  File "/etc/cron.hourly/diskcheck", line 245, in scan_df
    nPct = long(pct[:-1])
ValueError: invalid literal for long():
Comment 1 Harald Hoyer 2004-02-17 04:07:25 EST
what does
# df -ihP -x none -x tmpfs -x iso9660 -x udf

output??
Comment 2 Michael Dale Long 2004-02-17 13:13:42 EST
[root@norfair root]# df -ihP -x none -x tmpfs -x iso9660 -x udf
Filesystem            Inodes   IUsed   IFree IUse% Mounted on
/dev/hda6               4.1M    364K    3.8M    9% /
/dev/hda1                21K     110     20K    1% /boot
/dev/hda3               4.9M    568K    4.4M   12% /mnt/gentoo
/dev/hda5               4.9M    235K    4.7M    5% /mnt/uml
/dev/hdd1                  0       0       0    -  /mnt/win2k
Comment 3 Harald Hoyer 2004-02-18 04:03:37 EST
you may add "-x ntfs" to /etc/diskcheck.conf
I will fix the code to not traceback... thx!
Comment 4 Michael Dale Long 2004-02-18 14:00:54 EST
Actually, I don't have an ntfs partition, /mnt/win2k is vfat.  Adding
-x vfat fixed it.  I don't know if the -x ntfs will be needed or not.
Comment 5 Michael Dale Long 2004-02-18 15:18:01 EST
I just tested diskcheck without the -x ntfs with an ntfs partition
mounted and it didn't have any problems. 
Comment 6 Michael Dale Long 2004-02-18 18:25:16 EST
Actually, that's incorrect.  My ntfs partition is always reported as
full even when it's not.  Someone with a real NTFS partition should
probably check it.  But at least it doesn't result in a python exception.
Comment 7 Harald Hoyer 2004-02-19 03:36:25 EST
win2k is vfat??? so why don't you have any information about the usage??
Comment 8 Harald Hoyer 2004-03-02 05:23:42 EST
*** Bug 117257 has been marked as a duplicate of this bug. ***
Comment 9 Warren Togami 2004-03-06 00:03:18 EST
Win2k can optionally use vfat or ntfs filesystems, FYI.

Note You need to log in before you can comment on or make changes to this bug.