Bug 117257 - diskcheck fails to run correctly on default fedora core 2 test 1 install
Summary: diskcheck fails to run correctly on default fedora core 2 test 1 install
Status: CLOSED DUPLICATE of bug 115861
Alias: None
Product: Fedora
Classification: Fedora
Component: diskcheck   
(Show other bugs)
Version: 2
Hardware: i686 Linux
medium
medium
Target Milestone: ---
Assignee: Harald Hoyer
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-03-02 09:48 UTC by David Pollard
Modified: 2007-11-30 22:10 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 19:01:45 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description David Pollard 2004-03-02 09:48:52 UTC
Description of problem:

Every hour root receives an email from diskcheck because there has
been an error in its execution - running diskcheck on its own results
in this :-

[root@dplaptop cron.hourly]# ./diskcheck
Traceback (most recent call last):
  File "./diskcheck", line 318, in ?
    high += scan_df(list, "Inodes:")
  File "./diskcheck", line 245, in scan_df
    nPct = long(pct[:-1])
ValueError: invalid literal for long():

Version-Release number of selected component (if applicable):
1.0

How reproducible:
Default fedora core 2 test1 installation
run /etc/cron.hourly/diskcheck

Steps to Reproduce:
1.cd /etc/cron.hourly
2. ./diskcheck
3.
  
Actual results:
[root@dplaptop cron.hourly]# ./diskcheck
Traceback (most recent call last):
  File "./diskcheck", line 318, in ?
    high += scan_df(list, "Inodes:")
  File "./diskcheck", line 245, in scan_df
    nPct = long(pct[:-1])
ValueError: invalid literal for long():


Expected results:
Report of disk space thats low presumably

Additional info:

Comment 1 Harald Hoyer 2004-03-02 10:23:11 UTC
which version of diskcheck?

Comment 2 Harald Hoyer 2004-03-02 10:23:41 UTC

*** This bug has been marked as a duplicate of 115861 ***

Comment 3 Harald Hoyer 2004-03-02 10:23:59 UTC
should be fixed in diskcheck-1.6-1

Comment 4 David Pollard 2004-03-02 11:34:20 UTC
#!/usr/bin/python
#
# DiskCheck program 1.0

cheers

Comment 5 Harald Hoyer 2004-03-02 11:46:09 UTC
# rpm -q diskcheck 
please :)

Comment 6 David Pollard 2004-03-02 11:49:25 UTC
sorry

:)

diskcheck-1.5-1

cheers

Comment 7 Red Hat Bugzilla 2006-02-21 19:01:45 UTC
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.


Note You need to log in before you can comment on or make changes to this bug.