Bug 1158667 - GeoIP version bump to 1.6.4
Summary: GeoIP version bump to 1.6.4
Keywords:
Status: CLOSED NEXTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: GeoIP
Version: 22
Hardware: All
OS: Linux
unspecified
medium
Target Milestone: ---
Assignee: Philip Prindeville
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks: 1186988
TreeView+ depends on / blocked
 
Reported: 2014-10-29 20:12 UTC by Philip Prindeville
Modified: 2015-10-09 19:18 UTC (History)
3 users (show)

Fixed In Version: GeoIP-1.6.5-1.fc22
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-04-22 08:41:44 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Bugzilla 1201857 None None None Never

Internal Links: 1201857

Description Philip Prindeville 2014-10-29 20:12:54 UTC
Description of problem:

GeoIP 1.6.3 is being released, and it includes a fix for libGeoIP leaking error messages to stderr. This affects the perl-Geo-IP module which uses this libraries via XS stubs.

Version-Release number of selected component (if applicable):

1.6.3

How reproducible:

n/a

Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

from the change log:

1.6.3

* Added a GEOIP_SILENCE flag. Include this flag when calling GeoIP_open to prevent any messages from being written to stderr. ( Philip Prindeville and Boris Zentner )
* Mitigate a possible race condition when running nuder threads in the GeoIP_cleanup function. ( Anthon Pang )
* Added some recommendations to the docs on using this library in a threaded application. ( Boriz Zentner )
* Fixed some bugs discovered by coverity, including failure to check some system call return values and making sure all strings are null-terminated. ( Boris Zentner )

Comment 1 Paul Howarth 2014-11-07 14:54:35 UTC
The geoipupdate tool has been unbundled from the GeoIP distribution and will need to be packaged separately. Can you put together a package for it?

I think it should be called geoipupdate (as per upstream), and I can add a dependency on it in the GeoIP 1.6.3 package.

I think it would make sense to move the cron jobs from GeoIP to the geoipupdate package too, in sub-packages called something like geoipupdate-ipv4-cron and geoipupdate-ipv6-cron. These should obsolete/provide GeoIP-update < 1.6.0 and GeoIP-update6 < 1.6.0 respectively. That will ensure that there is a clean upgrade path for existing users.

Once that's in place I can update GeoIP to 1.6.3 and drop the update sub-packages.

Comment 2 Philip Prindeville 2015-01-20 23:53:47 UTC
(In reply to Paul Howarth from comment #1)
> The geoipupdate tool has been unbundled from the GeoIP distribution and will
> need to be packaged separately. Can you put together a package for it?
> 
> I think it should be called geoipupdate (as per upstream), and I can add a
> dependency on it in the GeoIP 1.6.3 package.

Not obvious that GeoIP and geoipupdate need to have any interdependencies.  I can see a scenario where someone is using the database but accessing it directly themselves (or via some Perl module which doesn't link to the C API via XS stubs), and I can also see a scenario where someone just needs a single static copy of the database and they don't care about ever having it be updated.

BTW: I have a git checkout with the changes staged for 1.6.3.

> I think it would make sense to move the cron jobs from GeoIP to the
> geoipupdate package too, in sub-packages called something like
> geoipupdate-ipv4-cron and geoipupdate-ipv6-cron. These should
> obsolete/provide GeoIP-update < 1.6.0 and GeoIP-update6 < 1.6.0
> respectively. That will ensure that there is a clean upgrade path for
> existing users.

Yes, I'm in favor of reparenting the cron jobs as you suggest.

> Once that's in place I can update GeoIP to 1.6.3 and drop the update
> sub-packages.

Was thinking about temporarily including geoipupdate as a subpackage of GeoIP-1.6.3 so we can get it out the door since it's badly needed, and then doing a respin shortly after as a separate package.

Comment 3 Philip Prindeville 2015-01-22 01:49:43 UTC
Committed (and pushed) changes to build version 1.6.4.

Will build and submit for release.

Will also start separate package (or group of packages and subpackages) for "geoipupdate".

Comment 4 Fedora Update System 2015-01-29 02:27:30 UTC
GeoIP-1.6.4-0.fc21 has been submitted as an update for Fedora 21.
https://admin.fedoraproject.org/updates/GeoIP-1.6.4-0.fc21

Comment 5 Fedora Update System 2015-01-29 02:28:00 UTC
GeoIP-1.6.4-0.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/GeoIP-1.6.4-0.fc20

Comment 6 Fedora Update System 2015-01-30 04:37:37 UTC
Package GeoIP-1.6.4-0.fc21:
* should fix your issue,
* was pushed to the Fedora 21 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing GeoIP-1.6.4-0.fc21'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2015-1369/GeoIP-1.6.4-0.fc21
then log in and leave karma (feedback).

Comment 7 Carl George 2015-02-18 15:15:17 UTC
Would it be possible to update the EPEL packages to version 1.6.4 as well?

EPEL-5: 1.4.8-1.el5
EPEL-6:	1.5.1-5.el6

Comment 8 Paul Howarth 2015-02-18 15:25:56 UTC
Certainly for EPEL-6. I'll have to look at EPEL-5 and see if there are any issues that would prevent an update.

Comment 9 Jaroslav Reznik 2015-03-03 17:19:11 UTC
This bug appears to have been reported against 'rawhide' during the Fedora 22 development cycle.
Changing version to '22'.

More information and reason for this action is here:
https://fedoraproject.org/wiki/Fedora_Program_Management/HouseKeeping/Fedora22

Comment 10 Fedora Update System 2015-04-14 07:57:55 UTC
GeoIP-GeoLite-data-2015.04-1.el5,geoipupdate-2.2.1-2.el5,GeoIP-1.6.5-1.el5 has been submitted as an update for Fedora EPEL 5.
https://admin.fedoraproject.org/updates/GeoIP-GeoLite-data-2015.04-1.el5,geoipupdate-2.2.1-2.el5,GeoIP-1.6.5-1.el5

Comment 11 Fedora Update System 2015-04-14 07:59:17 UTC
GeoIP-GeoLite-data-2015.04-1.el6,geoipupdate-2.2.1-2.el6,GeoIP-1.6.5-1.el6 has been submitted as an update for Fedora EPEL 6.
https://admin.fedoraproject.org/updates/GeoIP-GeoLite-data-2015.04-1.el6,geoipupdate-2.2.1-2.el6,GeoIP-1.6.5-1.el6

Comment 12 Fedora Update System 2015-04-14 08:00:36 UTC
GeoIP-GeoLite-data-2015.04-1.fc21,geoipupdate-2.2.1-2.fc21,GeoIP-1.6.5-1.fc21 has been submitted as an update for Fedora 21.
https://admin.fedoraproject.org/updates/GeoIP-GeoLite-data-2015.04-1.fc21,geoipupdate-2.2.1-2.fc21,GeoIP-1.6.5-1.fc21

Comment 13 Fedora Update System 2015-04-14 08:00:53 UTC
GeoIP-GeoLite-data-2015.04-1.fc22,geoipupdate-2.2.1-2.fc22,GeoIP-1.6.5-1.fc22 has been submitted as an update for Fedora 22.
https://admin.fedoraproject.org/updates/GeoIP-GeoLite-data-2015.04-1.fc22,geoipupdate-2.2.1-2.fc22,GeoIP-1.6.5-1.fc22

Comment 14 Fedora Update System 2015-04-14 08:03:15 UTC
GeoIP-GeoLite-data-2015.04-1.fc20,geoipupdate-2.2.1-2.fc20,GeoIP-1.6.5-1.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/GeoIP-GeoLite-data-2015.04-1.fc20,geoipupdate-2.2.1-2.fc20,GeoIP-1.6.5-1.fc20

Comment 15 Paul Howarth 2015-04-14 14:52:47 UTC
(In reply to Carl George)
> See Also: https://bugzilla.redhat.com/show_bug.cgi?id=1201857

Unfortunately that's a private bug so I can't see it.

Comment 16 Fedora Update System 2015-04-21 19:15:07 UTC
GeoIP-GeoLite-data-2015.04-1.fc22, geoipupdate-2.2.1-2.fc22, GeoIP-1.6.5-1.fc22 has been pushed to the Fedora 22 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 17 Carl George 2015-04-24 19:32:30 UTC
Hey Paul, bug #1201857 was me pointing out that RHEL7 GeoIP doesn't have any IPv6 data.  I believe it was public originally, but then it was then linked to an actual Red Hat support case.  One simple solution would be to rebase the RHEL7 package to these latest Fedora packages, which have all the IPv6 data.

Comment 18 Fedora Update System 2015-04-26 12:48:38 UTC
GeoIP-GeoLite-data-2015.04-1.fc20, geoipupdate-2.2.1-2.fc20, GeoIP-1.6.5-1.fc20 has been pushed to the Fedora 20 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 19 Fedora Update System 2015-04-26 12:58:45 UTC
GeoIP-GeoLite-data-2015.04-1.fc21, geoipupdate-2.2.1-2.fc21, GeoIP-1.6.5-1.fc21 has been pushed to the Fedora 21 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 20 Paul Howarth 2015-04-26 15:43:37 UTC
(In reply to Carl George from comment #17)
> Hey Paul, bug #1201857 was me pointing out that RHEL7 GeoIP doesn't have any
> IPv6 data.  I believe it was public originally, but then it was then linked
> to an actual Red Hat support case.  One simple solution would be to rebase
> the RHEL7 package to these latest Fedora packages, which have all the IPv6
> data.

Hmm, good luck getting Red Hat to do that!

I think the IPv6 data is still considered beta by upstream isn't it?

Comment 21 Fedora Update System 2015-05-14 06:28:01 UTC
geoipupdate-2.2.1-2.el6, GeoIP-1.6.5-1.el6, GeoIP-GeoLite-data-2015.04-2.el6 has been pushed to the Fedora EPEL 6 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 22 Fedora Update System 2015-05-14 06:28:44 UTC
geoipupdate-2.2.1-2.el5, GeoIP-GeoLite-data-2015.04-2.el5, GeoIP-1.6.5-2.el5 has been pushed to the Fedora EPEL 5 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.