Bug 115873 - support for ES1983S Maestro-3i soundcard
support for ES1983S Maestro-3i soundcard
Status: CLOSED DUPLICATE of bug 115932
Product: Fedora
Classification: Fedora
Component: firstboot (Show other bugs)
rawhide
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Brent Fox
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-02-16 14:04 EST by Dimitri Papadopoulos
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 14:01:19 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dimitri Papadopoulos 2004-02-16 14:04:02 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; fr-FR; rv:1.6) Gecko/20040113

Description of problem:
This is probably more related to the kernel than to firstboot. If so,
sorry about that, I wasn't sure which component to choose.

I'm running firstboot manually from the command-line, because of bug
https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=115678

This is the command-line:
$ export LANG=en_US.UTF-8
$ firstboot

The system is a Dell Latitude CPx laptop (model PPX, Latitude C family).

I get past the first pages, "Welcome", "License Agreement", "Date and
Time", "Display", "User Account". There's a problem with "Sound Card"
though.

The "Sound Card" page displays:
	Vendor: ESS Technology
	Model:  ES1983S Maestro-3i PCI Audio Accelerator
	Module: snd-maestro3

Then I click on button "Play test sound". The first time I ran the
test I got no error message, but the test failed: no sound was played.
So I answered "No" to the message box asking "Did you hear the sample
sound?".

After rebooting, I have been consistently seeing this additional
message when performing the same routine:
	The snd-maestro3 driver could not be loaded. This
	soundcard may not be compatible with Red Hat Linux.

This soundcard used to work properly with FC1.


Version-Release number of selected component (if applicable):
firstboot-1.3.3-3

How reproducible:
Always
Comment 1 Bill Nottingham 2004-02-16 15:24:45 EST
What happens if you just load it by hand, run 'aumix' or 'alsamixer'
to turn up the volume,and then play a sound?
Comment 2 Dimitri Papadopoulos 2004-02-17 04:43:09 EST
Actually the module *is* loaded, if that's what you mean:
	# lsmod
	[...]
	snd_maestro3           25636  1
	snd_ac97_codec         52612  1 snd_maestro3
	[...]
	# 

I'm unable to find "alsamixer" on the system:
	# locate alsamixer
	/usr/share/man/fr/man1/alsamixer.1.gz
	# 

I tried "aumix". The volume was indeed set at minimum. I modified the
colume level and was then able to hear the terminal bell or play a
sound for example with:
	# cat /usr/share/man/fr/man1/alsamixer.1.gz > /dev/dsp
	# 

However I'm still unable to hear the sample sound from within
firstboot. So I answer "No" to the dialog that asks "Did you hear thee
sample sound?" and then I get this message "Automatic detection of the
sound card did not work. Audio will not be available on the system.
Please click OK to continue."

After that I can't play sounds. If I run "aumix" again, I see that the
volume level is actually set to 0.

Just a guess: Maybe firstboot is resetting the volume level to 0? This
is what I see on the console...
	# firstboot
	[...]
	* dccprobe retruned bogus values:
	ID:   None
	Name: None
	HorizSync: None
	VertSync:  None
	
	vol set to 0, 0, P
	pcm set to 0, 0
	speaker set to 0, 0
	mic set to 0, 0, R
	cd set to 0, 0, P
	[...]
	# 
Comment 3 Brent Fox 2004-02-20 11:30:33 EST
Firstboot needs to override the default ALSA volume setting, which is 0.

*** This bug has been marked as a duplicate of 115932 ***
Comment 4 Red Hat Bugzilla 2006-02-21 14:01:19 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.