Bug 115932 - no testsound due to insufficient mixer settings
no testsound due to insufficient mixer settings
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: system-config-soundcard (Show other bugs)
rawhide
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Brent Fox
:
: 109304 110201 115873 115914 115976 116013 116083 116085 116450 116549 118741 118970 123976 (view as bug list)
Depends On:
Blocks: FC2Blocker
  Show dependency treegraph
 
Reported: 2004-02-17 02:31 EST by Michael Schwendt
Modified: 2007-11-30 17:10 EST (History)
16 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-03-10 17:09:50 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Michael Schwendt 2004-02-17 02:31:31 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4.1)
Gecko/20031114

Description of problem:
[This is my tracking bug for my problems with ALSA vs. ALSA OSS.]

* After I had corrected the hwdata driver name for my audio chipset to
snd-ens1371 (bug 115651), it inserts the driver successfully, but the
testsound can not be heard. Terminal output is:

FATAL: Module snd_ens1371 is not in kernel.
vol set to 0, 0, P
pcm set to 0, 0
speaker set to 0, 0
line set to 0, 0, P
mic set to 0, 0, P
cd set to 0, 0, P
igain set to 0, 0
line1 set to 0, 0, P
dig1 set to 100, 100
phin set to 0, 0, P
phout set to 0, 0, R
video set to 0, 0, P

* I see that system-config-soundcard points aumix to /etc/.aumixrc,
but I don't know where/when that file is created with defaults which
would unmute "vol" and "pcm", so the testsound could be heard? When
running aumix manually, I end up with another file in /root/.aumixrc,
so at some point I have two such files.

* A comment in the system-config-soundcard code says it attempts at
unmuting the ALSA mixers. How? Where does /etc/.aumixrc come from
after a clean installation?

* system-config-soundcard inserts a native ALSA driver into
/etc/modprobe.conf, but aumix is for OSS, e.g. ALSA's OSS
compatibility layer.

* After reboot, aumix should have restored the OSS mixer settings.
Testsound in system-config-soundcard is still not audible, though.
Sound which uses ALSA somehow, can not be heard.

* When I work around the XMMS arts driver crash and configure it to
use native ALSA output instead of artsd, I need to run alsamixer or
alsactl (from alsa-utils package) to unmute the mixers. Similarly,
when I run a fixed KDE sound server (bug 115507), I also need to set
mixers with alsamixer/alsactl to get output.


Version-Release number of selected component (if applicable):
system-config-soundcard-1.2.2-1


Steps to Reproduce:
Well, that is the question. If I remove all audio related config
files, unload kernel modules, reboot and then restart
system-config-soundcard, what behaviour should I expect?


Additional info:
Fedora.us' ALSA packages use an ALSA "alsasound" initscript which
takes care of saving and restoring mixer settings with alsactl (but
the script also loads/unloads kernel modules). Alsa-utils' "alsaconf"
unmutes the mixers as a final step.
Comment 1 Bill Nottingham 2004-02-17 11:25:29 EST
*** Bug 115914 has been marked as a duplicate of this bug. ***
Comment 2 Christopher Johnson 2004-02-17 21:51:54 EST
I have an effective and persistent solution to this.

First use alsamixer to set levels as you wish.  Then use 'alsactl
store' to save those settings.

Then add two "install" and "remove" lines to your /etc/modprobe.conf,
substituting your snd-* driver for the snd-ali5451 which was correct
for my system:
install snd-ali5451 /sbin/modprobe --ignore-install snd-ali5451 &&
/usr/sbin/alsactl restore
remove snd-ali5451 /usr/sbin/alsactl store && /sbin/modprobe -r
--ignore-remove
snd-ali5451

This causes the current mixer settings to be saved at shutdown and
restored at boot as the snd-* driver module is unloaded and loaded.
Comment 3 Bill Nottingham 2004-02-17 22:44:21 EST
Actually, the modules rarely, if ever, get removed. So you have to
save them at least once. (You can have a script unload the modules,
but if you're doing that, it makes more sense to just save the
settings....)
Comment 4 Bill Nottingham 2004-02-18 00:32:56 EST
*** Bug 116083 has been marked as a duplicate of this bug. ***
Comment 5 Brent Fox 2004-02-20 11:30:35 EST
*** Bug 115873 has been marked as a duplicate of this bug. ***
Comment 6 Bill Nottingham 2004-02-22 00:50:35 EST
*** Bug 116450 has been marked as a duplicate of this bug. ***
Comment 7 Brent Fox 2004-03-10 17:09:50 EST
Should be fixed with system-config-soundcard-1.2.7-3 in Rawhide.
Comment 8 Brent Fox 2004-03-10 17:10:08 EST
*** Bug 116549 has been marked as a duplicate of this bug. ***
Comment 9 Brent Fox 2004-03-10 17:11:57 EST
*** Bug 115976 has been marked as a duplicate of this bug. ***
Comment 10 Brent Fox 2004-03-10 17:12:25 EST
*** Bug 116085 has been marked as a duplicate of this bug. ***
Comment 11 Brent Fox 2004-03-10 17:13:20 EST
*** Bug 116013 has been marked as a duplicate of this bug. ***
Comment 12 Brent Fox 2004-03-11 12:19:53 EST
*** Bug 109304 has been marked as a duplicate of this bug. ***
Comment 13 Brent Fox 2004-03-11 12:21:01 EST
*** Bug 110201 has been marked as a duplicate of this bug. ***
Comment 14 Brent Fox 2004-03-19 15:13:04 EST
*** Bug 118741 has been marked as a duplicate of this bug. ***
Comment 15 Bill Nottingham 2004-03-23 12:28:47 EST
*** Bug 118970 has been marked as a duplicate of this bug. ***
Comment 16 Bill Nottingham 2004-05-25 12:33:43 EDT
*** Bug 123976 has been marked as a duplicate of this bug. ***
Comment 17 Bill Nottingham 2004-06-29 00:38:50 EDT
*** Bug 126212 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.