Bug 1159028 - Installation of second host failed, when try to fetch answer file IOError: [Errno 2] No such file
Summary: Installation of second host failed, when try to fetch answer file IOError: [E...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine-setup
Version: 3.5.0
Hardware: x86_64
OS: Linux
urgent
high
Target Milestone: ---
: 3.5.0
Assignee: Sandro Bonazzola
QA Contact: Artyom
URL:
Whiteboard: integration
: 1158885 (view as bug list)
Depends On:
Blocks: rhev35betablocker rhev35rcblocker rhev35gablocker
TreeView+ depends on / blocked
 
Reported: 2014-10-30 17:44 UTC by Artyom
Modified: 2015-07-16 06:35 UTC (History)
12 users (show)

Fixed In Version: ovirt-hosted-engine-setup-1.2.1-3.el6ev
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-02-12 14:10:02 UTC
oVirt Team: ---


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
oVirt gerrit 34679 master MERGED Get path for answer file from environment Never
oVirt gerrit 34689 ovirt-hosted-engine-setup-1.2 MERGED Get path for answer file from environment Never

Description Artyom 2014-10-30 17:44:42 UTC
Description of problem:
Installation of second host failed, when try to fetch answer file:
Traceback (most recent call last):
  File "/usr/lib/python2.6/site-packages/otopi/context.py", line 142, in _executeMethod
    method['method']()
  File "/usr/share/ovirt-hosted-engine-setup/scripts/../plugins/ovirt-hosted-engine-setup/core/remote_answerfile.py", line 289, in _customization
    self._fetch_answer_file()
  File "/usr/share/ovirt-hosted-engine-setup/scripts/../plugins/ovirt-hosted-engine-setup/core/remote_answerfile.py", line 145, in _fetch_answer_file
    self._tmp_ans
  File "/usr/lib/python2.6/site-packages/paramiko/sftp_client.py", line 673, in get
    file_size = self.stat(remotepath).st_size
  File "/usr/lib/python2.6/site-packages/paramiko/sftp_client.py", line 337, in stat
    t, msg = self._request(CMD_STAT, path)
  File "/usr/lib/python2.6/site-packages/paramiko/sftp_client.py", line 689, in _request
    return self._read_response(num)
  File "/usr/lib/python2.6/site-packages/paramiko/sftp_client.py", line 736, in _read_response
    self._convert_status(msg)
  File "/usr/lib/python2.6/site-packages/paramiko/sftp_client.py", line 762, in _convert_status
    raise IOError(errno.ENOENT, text)
IOError: [Errno 2] No such file

Version-Release number of selected component (if applicable):
ovirt-hosted-engine-setup-1.2.1-2.el6ev.noarch

How reproducible:
Always

Steps to Reproduce:
1. Finish hosted-engine --deploy on one host
2. Try to deploy second host
3.

Actual results:
Deployment failed with exception

Expected results:
Deployment success without any errors

Additional info:

Comment 1 Sandro Bonazzola 2014-10-31 14:11:51 UTC
*** Bug 1158885 has been marked as a duplicate of this bug. ***

Comment 2 Artyom 2014-11-06 14:29:28 UTC
Verified on ovirt-hosted-engine-setup-1.2.1-3.el6ev.noarch

Comment 3 B Carlson 2015-03-06 23:17:37 UTC
Can I get specific information on target file or something to move past this?

This still fails on ovirt-hosted-engine-setup-1.2.1-9.el6ev.noarch, original host/hosted engine installed earlier 2015-03-06 and running:

Traceback (most recent call last):
  File "/usr/lib/python2.6/site-packages/otopi/context.py", line 142, in _executeMethod
    method['method']()
  File "/usr/share/ovirt-hosted-engine-setup/scripts/../plugins/ovirt-hosted-engine-setup/core/remot
e_answerfile.py", line 283, in _customization
    self._fetch_answer_file()
  File "/usr/share/ovirt-hosted-engine-setup/scripts/../plugins/ovirt-hosted-engine-setup/core/remot
e_answerfile.py", line 143, in _fetch_answer_file
    self._tmp_ans
  File "/usr/lib/python2.6/site-packages/paramiko/sftp_client.py", line 595, in get
    fr = self.file(remotepath, 'rb')
  File "/usr/lib/python2.6/site-packages/paramiko/sftp_client.py", line 245, in open
    t, msg = self._request(CMD_OPEN, filename, imode, attrblock)
  File "/usr/lib/python2.6/site-packages/paramiko/sftp_client.py", line 624, in _request
    return self._read_response(num)
  File "/usr/lib/python2.6/site-packages/paramiko/sftp_client.py", line 671, in _read_response
    self._convert_status(msg)
  File "/usr/lib/python2.6/site-packages/paramiko/sftp_client.py", line 697, in _convert_status
    raise IOError(errno.ENOENT, text)
IOError: [Errno 2] No such file

Comment 4 Artyom 2015-03-08 06:36:07 UTC
Can you check version of original hosted-engine? Why you just not update it?
Anyway it some small patch, so you can apply it by yourself, just check link on gerrit(you need to apply this one on first host).

Comment 5 B Carlson 2015-03-09 12:55:17 UTC
This is a for an initial install of RHEVM 3.5 GA, all items (initial host, initial hosted-engine, the second host) all installed on the same day.

That said, this and other issues prompted a clear and reinstall.

Comment 6 aristotle ahito 2015-07-16 06:35:07 UTC
any update on this.. im having the same issue

Traceback (most recent call last):
  File "/usr/lib/python2.6/site-packages/otopi/context.py", line 142, in _executeMethod
    method['method']()
  File "/usr/share/ovirt-hosted-engine-setup/scripts/../plugins/ovirt-hosted-engine-setup/core/remote_answerfile.py", line 283, in _customization
    self._fetch_answer_file()
  File "/usr/share/ovirt-hosted-engine-setup/scripts/../plugins/ovirt-hosted-engine-setup/core/remote_answerfile.py", line 143, in _fetch_answer_file
    self._tmp_ans
  File "/usr/lib/python2.6/site-packages/paramiko/sftp_client.py", line 595, in get
    fr = self.file(remotepath, 'rb')
  File "/usr/lib/python2.6/site-packages/paramiko/sftp_client.py", line 245, in open
    t, msg = self._request(CMD_OPEN, filename, imode, attrblock)
  File "/usr/lib/python2.6/site-packages/paramiko/sftp_client.py", line 624, in _request
    return self._read_response(num)
  File "/usr/lib/python2.6/site-packages/paramiko/sftp_client.py", line 671, in _read_response
    self._convert_status(msg)
  File "/usr/lib/python2.6/site-packages/paramiko/sftp_client.py", line 697, in _convert_status
    raise IOError(errno.ENOENT, text)
IOError: [Errno 2] No such file


Note You need to log in before you can comment on or make changes to this bug.