Bug 115968 - gnumeric - symbolic link not created when using buildroot
Summary: gnumeric - symbolic link not created when using buildroot
Status: CLOSED UPSTREAM
Alias: None
Product: Fedora
Classification: Fedora
Component: gnumeric (Show other bugs)
(Show other bugs)
Version: rawhide
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Havoc Pennington
QA Contact:
URL: http://bugzilla.gnome.org/show_bug.cg...
Whiteboard:
Keywords: Patch
Depends On: 74034
Blocks: FC2Target
TreeView+ depends on / blocked
 
Reported: 2004-02-17 12:27 UTC by Miloslav Trmac
Modified: 2007-11-30 22:10 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-04-16 09:08:35 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Use $(DESTDIR) when creating $(gnumeric_datadir)/gnome (528 bytes, patch)
2004-02-17 12:28 UTC, Miloslav Trmac
no flags Details | Diff

Description Miloslav Trmac 2004-02-17 12:27:35 UTC
Description of problem:
The patch should be self-explanatory.

Version-Release number of selected component (if applicable):
gnumeric-1.2.6-2

Comment 1 Miloslav Trmac 2004-02-17 12:28:06 UTC
Created attachment 97741 [details]
Use $(DESTDIR) when  creating $(gnumeric_datadir)/gnome

Comment 2 Warren Togami 2004-04-14 04:29:11 UTC
Can you please explain what functionality or bug behavior is exhibited
due to this error?

Also please see if this is still an issue with gnumeric-1.2.8
currently in rawhide.

Comment 3 Miloslav Trmac 2004-04-14 07:59:48 UTC
Hello,
I don't know about any bug directly arising from it[1]. I have just
noticed it in my build logs, I don't use gnumeric at all.

And yes, it still looks the same in 1.2.8-1.

[1] The comment directly above (visible in the patch) might help.

Comment 4 Warren Togami 2004-04-14 08:34:56 UTC
For this bug I will apply your patch, however I would ask that you
please make sure upstream knows about this so it can be corrected in
their CVS and the next release.

As a more general request, could you please use mach in order to do
your build testing?  As you probably noticed I began going through all
of the "EasyFix" bugs recently, many of which were marked EasyFix by
you.  I was unhappy to discover however that each package took 10-45
minutes of work rather than 30 seconds, because in 95% of the cases
the reported missing BuildRequires was either incomplete or even wrong
in two cases.

I highly value and appreciate your hard work and reporting, because it
would have taken me far longer to do it alone, however if you use this
methodology you will be able to do much more accurate testing and
reporting.

http://www.fedora.us/wiki/HOWTOFindMissingBuildRequires
Essentially each build starts in the minimal buildroot defined by the
list at the bottom of this page.  If your mach buildroot begins with
fedora-rpmdevtools, then that is exactly the minimum needed.  Please
discuss this on fedora-devel-list if you need further help.

Comment 5 Warren Togami 2004-04-16 09:08:35 UTC
Sorry, decided not to check this in because there appears to be no
functional benefit.  Please report it upstream.


Note You need to log in before you can comment on or make changes to this bug.