Bug 74034 - gnumeric doesn't own all directories that it should
Summary: gnumeric doesn't own all directories that it should
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: gnumeric (Show other bugs)
(Show other bugs)
Version: rawhide
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Caolan McNamara
QA Contact:
URL: http://www.tu-chemnitz.de/~ensc/dirch...
Whiteboard:
Keywords:
: 103127 113046 (view as bug list)
Depends On:
Blocks: 79579 CambridgeTarget 115968
TreeView+ depends on / blocked
 
Reported: 2002-09-13 20:33 UTC by Enrico Scholz
Modified: 2014-01-21 22:48 UTC (History)
3 users (show)

Fixed In Version: FC3
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-06-25 09:35:52 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Patch to fix bug - haven't tested it entirely but, cmon - it's 1 dir (415 bytes, patch)
2003-11-06 07:46 UTC, Seth Vidal
no flags Details | Diff

Description Enrico Scholz 2002-09-13 20:33:21 UTC
Description of Problem:

Because this package contains unowned directories, they will be created
with the current umask. When having restrictive administrator settings
(umask 077) ordinary user will not have access to them and can not use
the package.

Another problem occurs when removing the package because orphaned
directories will remaining.


| $ rpm -qf /usr/lib/gnumeric/1.0.9-bonobo/plugins /usr/lib/gnumeric/1.0.9-bonobo/plugins/applix
| file /usr/lib/gnumeric/1.0.9-bonobo/plugins is not owned by any package
| gnumeric-1.0.9-2

(Please visit the given URL for a complete list of affected directories)


Version-Release number of selected component (if applicable):

gnumeric-1.0.9-2


How Reproducible: 100%


Steps to Reproduce:
0. make a minimal installation
1. umask 077
2. make sure that gnumeric is uninstalled completely
   (rm -rf /usr/lib/gnumeric/1.0.9-bonobo/plugins)
3. rpm -U gnumeric-1.0.9-2.i386.rpm
4. ls -l /usr/lib/gnumeric/1.0.9-bonobo/plugins
5. try to use the programs/scripts/libraries/data of the package as
   non-root user
6. rpm -e gnumeric-1.0.9-2


Actual Results:

* at 4:
  | drwx------    2 root     root         4096 Sep 13 21:49 /usr/lib/gnumeric/1.0.9-bonobo/plugins
* files can not be found/read at 5 and
* /usr/lib/gnumeric/1.0.9-bonobo/plugins still exists after 6.

Comment 1 Owen Taylor 2003-10-07 19:49:02 UTC
*** Bug 103127 has been marked as a duplicate of this bug. ***

Comment 2 Owen Taylor 2003-10-07 19:52:11 UTC
Still present in 1.2.0-1

Comment 3 Seth Vidal 2003-11-06 07:45:48 UTC
attaching 1 line patch.


Comment 4 Seth Vidal 2003-11-06 07:46:35 UTC
Created attachment 95757 [details]
Patch to fix bug - haven't tested it entirely but, cmon - it's 1 dir

Comment 5 Miloslav Trmac 2004-03-01 09:32:08 UTC
*** Bug 113046 has been marked as a duplicate of this bug. ***

Comment 6 Enrico Scholz 2004-03-01 09:41:54 UTC
It's more than one dir (/usr/share/mc + templates); see URL for list
(still valid with gnumeric-1.2.1-1)


Comment 7 W. Michael Petullo 2004-03-30 01:16:08 UTC
/usr/lib/gnumeric/1.2.6-bonobo/plugins is not owned by gnumeric
1.2.6-3.1 so this bug is in Fedora Core 2 Test 2.

Comment 8 Warren Togami 2004-04-14 04:22:42 UTC
I am going to checkin and rebuild this, but before I do can anyone
confirm this?

%files devel
%defattr (-, root, root)
%dir %{_datadir}/gnumeric
%dir %{_datadir}/gnumeric/%{gnumeric_version}
%{_datadir}/gnumeric/%{gnumeric_version}/idl/*.idl
%dir %{_libdir}/gnumeric
%dir %{_libdir}/gnumeric/%{gnumeric_version}

All of those directory ownerships are bogus, and -devel should instead
own %dir .../idl right?

Comment 9 Warren Togami 2004-04-14 05:50:09 UTC
Please see if you can figure out why Bug #115968 is needed too.

Comment 10 W. Michael Petullo 2004-06-25 02:37:42 UTC
This seems to be fixed in 1.2.12:

[root@imp gnumeric]# rpm -qf /usr/lib/gnumeric/1.2.12-bonobo/
gnumeric-1.2.12-1
[root@imp gnumeric]# rpm -qf /usr/lib/gnumeric/1.2.12-bonobo/plugins/
gnumeric-1.2.12-1

Can the original submitter verify this?

Comment 11 Caolan McNamara 2004-06-25 09:35:52 UTC
Yeah, it should be fixed in that version alright, and I see the same
behaviour. In fact I'll close this, and if anyone reports to the
difference I'll reinvestigate


Note You need to log in before you can comment on or make changes to this bug.