This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 115982 - gdm will not work with kernel-2.6.2-1.85
gdm will not work with kernel-2.6.2-1.85
Status: CLOSED DUPLICATE of bug 116118
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
rawhide
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Arjan van de Ven
:
Depends On:
Blocks: FC2Blocker
  Show dependency treegraph
 
Reported: 2004-02-17 08:55 EST by Don Hardaway
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 14:01:21 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
XFree86 config file (3.12 KB, text/plain)
2004-02-17 11:41 EST, Don Hardaway
no flags Details

  None (edit)
Description Don Hardaway 2004-02-17 08:55:17 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6) Gecko/20040115

Description of problem:
X will not lauch with the latest kernel. It complains about the mouse
configuration and gdm.  I tried selecting a different mouse that used
to work on prior versions of rh (i.e. Microsoft Intellimouse) instead
of the generic wheel mouse PS/2 but it does not do any good.

What log files would you like me to attach??

Version-Release number of selected component (if applicable):
kernel-2.6.2-1.85

How reproducible:
Always

Steps to Reproduce:
1.boot with kernel-2.6.2-1.85
2.
3.
    

Actual Results:  X will not launch

Expected Results:  X launches normally

Additional info:

With all of the files X etc. being updated to the latest, I can still
boot normally with the prior kernel release kernel-2.6.2-1.81.
Comment 1 Arjan van de Ven 2004-02-17 08:57:01 EST
make sure your XF config doesn't reference /dev/psaux; it has been
obsoleted/deprecated by /dev/input/mice in 2.6
Comment 2 Don Hardaway 2004-02-17 11:41:45 EST
Created attachment 97756 [details]
XFree86 config file
Comment 3 Don Hardaway 2004-02-17 11:44:01 EST
I changed the config file to comment out the /dev/psaux line but that
does not help. Further, with that line commented out, the prior
version of the kernel will not boot until i uncomment the /dev/psaux
line. I attached an uncommented version of my XFree86 config file for
you to look at. Let me know what to do next.
Comment 4 Alan Schmidt 2004-02-17 14:38:06 EST
The real problem is that the config tools still reference /dev/psaux,
so running them doesn't help when the mouse stops working. Until then,
to fix it by hand, you'll need to change /etc/X11/XF86Config by hand.
Rather than comment out the line with /dev/psaux in it, you need to
replace /dev/psaux with the new mouse device file--e.g.:
/dev/input/mice or /dev/input/mouse0.

You'll need to do the same thing with /etc/sysconfig/gpm too.
Comment 5 Don Hardaway 2004-02-17 17:51:00 EST
OK, I changed the line in the XF86Config file to /dev/input/mice and
in the gpm file to /dev/mice then tried mouse0 in both config files
but no of them work. Any other ideas?  Also did something change
between kernel versions kernel-2.6.2-1.85 and kernel-2.6.2-1.81
because if the config for XFree86 worked in 81 why wouldn't it work in
85 unless something changed.
Comment 6 Alin Osan 2004-02-18 03:27:22 EST
This solved tha same problem:

Comment out the "Input Device" section with Identifier "Mouse0", make
sure you have a similar "Input Device":

        Identifier  "DevInputMice"
        Driver      "mouse"
        Option      "Protocol" "IMPS/2"
        Option      "Device" "/dev/input/mice"
        Option      "ZAxisMapping" "4 5"
        Option      "Emulate3Buttons" "no"

Next, in section "ServerLayout" replace Mouse0 with "DevInputDevice"
to have:

InputDevice    "DevInputMice" "CorePointer" 

This worked for me ;-)

Otherwise, Fedora is a great job.
Comment 7 Don Hardaway 2004-02-18 08:17:41 EST
Thank You. That worked great.  I still have a problem when I boot
though in that I have to have my wireless pcmcia card removed while
booting or the boot will hang until I remove it. Once fully booted I
can then insert it and everything is fine.
Comment 8 Dave Jones 2004-02-23 18:19:53 EST

*** This bug has been marked as a duplicate of 116118 ***
Comment 9 Red Hat Bugzilla 2006-02-21 14:01:21 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.