Bug 116118 (mouse-psaux) - Change things from /dev/psaux to /dev/input/mice
Summary: Change things from /dev/psaux to /dev/input/mice
Status: CLOSED RAWHIDE
Alias: mouse-psaux
Product: Fedora
Classification: Fedora
Component: rhpl   
(Show other bugs)
Version: rawhide
Hardware: All
OS: Linux
high
high
Target Milestone: ---
Assignee: Brent Fox
QA Contact:
URL:
Whiteboard:
Keywords:
: 115967 115982 116092 116180 116235 116247 116306 116420 116550 116608 116714 116800 116803 116974 117256 117479 117493 118370 118489 118578 118845 119277 122034 (view as bug list)
Depends On:
Blocks: FC2Blocker
TreeView+ depends on / blocked
 
Reported: 2004-02-18 13:24 UTC by Gene Czarcinski
Modified: 2007-11-30 22:10 UTC (History)
24 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-02-24 20:59:08 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Gene Czarcinski 2004-02-18 13:24:55 UTC
Description of problem:

With the 2.6 kernel, the pointing device (mouse, trackball, etc.)
needs to change from using /dev/psaux to /dev/input/mice.

Update system-config-mouse to do the necessary updating.

Comment 1 Bill Nottingham 2004-02-18 17:22:22 UTC
system-config-mouse isn't run automatically, so I'm pretty sure that's
not the right place for it.

Comment 2 Gene Czarcinski 2004-02-18 17:36:39 UTC
When I first booted up the new kernel that did not have psaux,
"something" invoked mouse configuration.  Whether this was
system-config-mouse or something else, I do not know.

The "hard part" is that apparently system-config-xfree86 put
/dev/psaux into /etc/X11/XF86Config.  If this had been "/dev/mouse",
then it would be a simple matter of changing the symbolic link for
->psaux to ->input/mice

Fixing things up so they work in a future test and final distribution
for an upgrade is not going to be easy.

Comment 3 Gene Czarcinski 2004-02-18 18:25:29 UTC
I just checked today's round of updates and it includes an updated
system-config-display.  This may fix the mouse reconfiguration that
was the objective of this bug report ... that does not mean that
changes are not necessary to system-config-mouse but that my specific
problem may have benn for another package is is already fixed.

Once I get the new round downloaded and installed, I will set stuff
package the way it originally was and try again to see if this will
handle things.

Comment 4 Gene Czarcinski 2004-02-18 19:31:24 UTC
Nope.  Whatever system-config-display changed, it does not fix the
mouse problem.  When the error occurs, you are lead through a bunch of
panels which dows invoke mouseconfig.  However, that does not fix things.





Comment 5 Bill Nottingham 2004-02-19 05:21:52 UTC
*** Bug 116180 has been marked as a duplicate of this bug. ***

Comment 6 Bill Nottingham 2004-02-19 15:56:26 UTC
*** Bug 116235 has been marked as a duplicate of this bug. ***

Comment 7 Gene Czarcinski 2004-02-19 17:27:02 UTC
You close 116180 (against system-config-display) as a dup of this
report (against system-config-mouse).  I am not sure that is the case.

This package should be changed to set mouse->input/mice instead of
mouse->psaux.  Even if that setting is made manually,
system-config-display still sets /dev/psaux.

system-config-display should be chaged to use /dev/mouse

Comment 8 Brent Fox 2004-02-19 17:43:44 UTC
Both system-config-mouse and system-config-display use the list of
mice that comes from rhpl so they are dupes of each other.  Actually,
this bug should be filed against rhpl.  Changing components.

Comment 9 Bill Nottingham 2004-02-20 03:55:49 UTC
*** Bug 116247 has been marked as a duplicate of this bug. ***

Comment 10 Brent Fox 2004-02-20 15:59:16 UTC
Also, I'm taking this out of RFE status.  It's more of a critical bug
rather than an RFE.

I will try to fix this today.

Comment 11 Brent Fox 2004-02-20 16:47:35 UTC
*** Bug 115967 has been marked as a duplicate of this bug. ***

Comment 12 Gene Czarcinski 2004-02-20 17:33:53 UTC
Thank you.

Comment 13 Bill Nottingham 2004-02-23 05:08:36 UTC
*** Bug 116420 has been marked as a duplicate of this bug. ***

Comment 14 Dave Jones 2004-02-23 23:13:24 UTC
*** Bug 116608 has been marked as a duplicate of this bug. ***

Comment 15 Dave Jones 2004-02-23 23:19:55 UTC
*** Bug 115982 has been marked as a duplicate of this bug. ***

Comment 16 Brent Fox 2004-02-24 20:59:08 UTC
Should be fixed in Rawhide as of today.  This touches libxf86config,
rhpl, anaconda, and system-config-display.

Comment 17 Bill Nottingham 2004-02-25 04:16:14 UTC
*** Bug 116714 has been marked as a duplicate of this bug. ***

Comment 18 Dave Jones 2004-02-25 17:21:20 UTC
*** Bug 116803 has been marked as a duplicate of this bug. ***

Comment 19 Bill Nottingham 2004-02-26 04:15:25 UTC
*** Bug 116800 has been marked as a duplicate of this bug. ***

Comment 20 Bill Nottingham 2004-02-27 00:12:38 UTC
*** Bug 116974 has been marked as a duplicate of this bug. ***

Comment 21 Bill Nottingham 2004-03-02 16:52:04 UTC
*** Bug 117256 has been marked as a duplicate of this bug. ***

Comment 22 Bill Nottingham 2004-03-04 19:58:45 UTC
*** Bug 117493 has been marked as a duplicate of this bug. ***

Comment 23 Dave Jones 2004-03-17 00:02:38 UTC
*** Bug 118489 has been marked as a duplicate of this bug. ***

Comment 24 Brent Fox 2004-03-17 18:45:59 UTC
*** Bug 118370 has been marked as a duplicate of this bug. ***

Comment 25 Dave Jones 2004-03-18 13:41:53 UTC
*** Bug 118578 has been marked as a duplicate of this bug. ***

Comment 26 Neal Becker 2004-03-18 14:22:21 UTC
I'm confused.  Changing from /dev/psaux -> /dev/input/mouse didn't 
work.  Changing to /dev/input/mouse0 did work.  How is this thing 
supposed to be setup?  What is /dev/input/mouse?  What is /dev/input 
mouse0? 
 
Here are mine, are the correct? 
ls -l /dev/input/mouse 
crw-------  1 root root 10, 149 Feb 23 16:02 /dev/input/mouse 
[nbecker@rpppc1 ~]$ ls -l /dev/input/mouse0 
crw-------  1 root root 13, 32 Feb 23 16:02 /dev/input/mouse0 
 

Comment 27 Bill Nottingham 2004-03-18 15:41:18 UTC
You want /dev/input/mice - it's the multiplexor for
/dev/input/mouse0,1,2...

There is no /dev/input/mouse.

Comment 28 Dave Jones 2004-03-21 16:55:40 UTC
*** Bug 118845 has been marked as a duplicate of this bug. ***

Comment 29 Mike A. Harris 2004-03-29 21:28:25 UTC
*** Bug 117479 has been marked as a duplicate of this bug. ***

Comment 30 Mike A. Harris 2004-03-29 21:35:59 UTC
*** Bug 116092 has been marked as a duplicate of this bug. ***

Comment 31 Mike A. Harris 2004-03-29 21:37:24 UTC
*** Bug 116306 has been marked as a duplicate of this bug. ***

Comment 32 Mike A. Harris 2004-03-29 21:37:51 UTC
*** Bug 116550 has been marked as a duplicate of this bug. ***

Comment 33 Adam Huffman 2004-04-11 12:40:34 UTC
I have changed XF86Config to use /dev/input/mice and still X does not
see the mouse.  While it shows up in the log file, it doesn't do anything.

Comment 34 Dave Jones 2004-06-15 00:08:13 UTC
*** Bug 119277 has been marked as a duplicate of this bug. ***

Comment 35 Dave Jones 2004-06-15 01:03:01 UTC
*** Bug 122034 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.