Bug 1160499 - Missing high contrast icon
Summary: Missing high contrast icon
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: gnome-themes-standard
Version: 21
Hardware: x86_64
OS: Linux
unspecified
high
Target Milestone: ---
Assignee: Cosimo Cecchi
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: AcceptedBlocker
Depends On: 1162856
Blocks: F21FinalBlocker
TreeView+ depends on / blocked
 
Reported: 2014-11-05 02:38 UTC by Michael Catanzaro
Modified: 2014-11-25 22:37 UTC (History)
12 users (show)

Fixed In Version: gnome-themes-standard-3.14.2-2.fc21
Doc Type: Bug Fix
Doc Text:
Clone Of:
: 1162856 (view as bug list)
Environment:
Last Closed: 2014-11-25 22:37:16 UTC


Attachments (Terms of Use)
welcome screen - no high contrast icon (307.46 KB, image/png)
2014-11-24 11:53 UTC, Kamil Páral
no flags Details
overview - missing high contrast icon (355.32 KB, image/png)
2014-11-24 11:54 UTC, Kamil Páral
no flags Details

Description Michael Catanzaro 2014-11-05 02:38:57 UTC
Description of problem: The Install to Hard Drive app on the Workstation live image does not have a high contrast variant.


Version-Release number of selected component (if applicable): anaconda-21.48.13-1.fc21


How reproducible: Always


Steps to Reproduce:
1. Launch Fedora 21 Workstation Beta live image
2. Turn on high contrast in System Settings

Actual results: Anaconda's icon does not change.


Expected results: Anaconda's icon changes to a high contrast icon in approximately the same style as the other high contrast icons.


Additional info: Proposing as F21 final blocker under the criterion "All applications installed by default in Fedora Workstation must comply with each MUST and MUST NOT guideline in the Applications and Launchers policy." [1]

In particular:

"App launchers MUST have a unique 128×128 launcher icon with an alpha channel and a matching High Contrast icon." [2]

A strong case could be made that anaconda does not technically trigger this criterion since it is not actually installed on the system... but that's really a technicality, and I'd simply suggest rewording the criterion from "installed by default" to "on the live image."

[1] https://fedoraproject.org/wiki/Fedora_21_Final_Release_Criteria#Default_application_functionality

[2] https://fedoraproject.org/wiki/Workstation/Guidelines/Applications_and_Launchers#For_launchers:

Comment 1 David Shea 2014-11-05 15:19:20 UTC
I mean that's not even the worst-looking part of fedora-welcome if you try to switch it to high contrast mode but if you want to complain about the icon I guess we can start with the icon.

Comment 2 Kamil Páral 2014-11-05 17:28:01 UTC
Discussed at 2014-11-05 blocker review meeting [1]. Accepted as a blocker. This bug is a clear violation of the Final criterion: All applications installed by default in Fedora Workstation must comply with each MUST and MUST NOT guideline in the Applications and Launchers policy.

[1] http://meetbot.fedoraproject.org/fedora-blocker-review/2014-11-05/

Comment 3 Tom "spot" Callaway 2014-11-05 18:43:37 UTC
The anaconda icon lives in gnome-theme-standard. Also, it appears to have a 256x256 HighContrast variant:

/usr/share/icons/HighContrast/256x256/apps/anaconda.png

Reassigning to gnome-theme-standard.

Comment 4 Jaroslav Reznik 2014-11-10 14:29:38 UTC
I expect this needs new design for Anaconda icon to be high contrast and I don't think it's something Gnome devs can do. I'm going to ask Fedora design team.

Comment 5 Jaroslav Reznik 2014-11-10 14:33:07 UTC
(In reply to Jaroslav Reznik from comment #4)
> I expect this needs new design for Anaconda icon to be high contrast and I
> don't think it's something Gnome devs can do. I'm going to ask Fedora design
> team.

Ops, sorry. I misread Spot's comment...

Comment 6 Matthias Clasen 2014-11-11 19:08:20 UTC
fedora-welcome is using the anaconda.svg icon by its full path, so it doesn't benefit from the highcontrast variant of the anaconda icon that is provided by gnome-themes-standard. Changing fedora-welcome to use the icon by name is trivial enough, but doesn't actually work. Or rather, it solves the problem in HighContrast, but breaks it in non-HighContrast, because the full-color anaconda icon is installed into a no-longer-existing icon theme called Fedora. So, to fix the icon in fedora-welcome, two things are needed:

1) install the anaconda icon into hicolor instead of Fedora

2) replace 

      let pix = GdkPixbuf.Pixbuf.new_from_file_at_size(
          '/usr/share/icons/Fedora/scalable/apps/anaconda.svg',
          256, 256);
      installContent.add(new Gtk.Image({ pixbuf: pix }));


by

      installContent.add(new Gtk.Image({ icon_name: 'anaconda',
                                         pixel_size: 256 });


To make fedora-welcome show visible text in HighContrast, you additionally need to remove the unnecessarily hard-coded white text color in two places:

--- /usr/share/anaconda/gnome/fedora-welcome	2014-10-28 14:01:35.000000000 -0400
+++ fedora-welcome	2014-11-11 14:05:46.265025084 -0500
@@ -40,14 +40,14 @@
     let widget = new Gtk.Label();
 
     if (button)
-        widget.set_markup('<b><span size="x-large" color="white">' + label + '</span></b>');
+        widget.set_markup('<b><span size="x-large">' + label + '</span></b>');
     else {
         widget.set_line_wrap(true);
         widget.set_justify(Gtk.Justification.CENTER);
         widget.set_margin_top(32);
         widget.set_margin_bottom(32);
 
-        widget.set_markup('<span size="large" color="white">' + label + '</span>');
+        widget.set_markup('<span size="large">' + label + '</span>');
     }
 
     return widget;

Comment 7 Matthias Clasen 2014-11-11 19:18:56 UTC
moving this back to anaconda, since fedora-welcome is in that package

Comment 8 David Shea 2014-11-11 21:33:22 UTC
Thanks for figuring this out. Forwarded the patch to the list and cloned this bug for the fedora-logos part.

Comment 9 Kamil Páral 2014-11-20 10:33:20 UTC
Hello David, what's the status of this? Is the fixed version going to be available soon?

Comment 10 David Shea 2014-11-20 14:36:55 UTC
Well, first I have to decode what spot even did, because the first I found out about the new fedora-logos package was you telling reporting that the fedora-logos package broke fedora-welcome.

Comment 11 Fedora Update System 2014-11-20 20:44:41 UTC
anaconda-21.48.16-1.fc21 has been submitted as an update for Fedora 21.
https://admin.fedoraproject.org/updates/anaconda-21.48.16-1.fc21

Comment 12 Fedora Update System 2014-11-20 20:59:03 UTC
python-blivet-0.61.10-1.fc21, anaconda-21.48.16-1.fc21 has been submitted as an update for Fedora 21.
https://admin.fedoraproject.org/updates/FEDORA-2014-15420/anaconda-21.48.16-1.fc21,python-blivet-0.61.10-1.fc21

Comment 13 Fedora Update System 2014-11-22 20:20:03 UTC
Package python-blivet-0.61.10-1.fc21, anaconda-21.48.16-1.fc21:
* should fix your issue,
* was pushed to the Fedora 21 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing python-blivet-0.61.10-1.fc21 anaconda-21.48.16-1.fc21'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2014-15420/anaconda-21.48.16-1.fc21,python-blivet-0.61.10-1.fc21
then log in and leave karma (feedback).

Comment 14 Kamil Páral 2014-11-24 11:53:42 UTC
Created attachment 960689 [details]
welcome screen - no high contrast icon

Something didn't work. There's still no high contrast icon for Anaconda, neither on welcome screen nor in the overview. I have read this bug and bug 1162856 and it is not clear to me which package should have included this icon, but it seems to be missing from both of them. Either anaconda or fedora-logos need to include it.

Btw, the anaconda icon on the welcome screen is now actually different from the overview icon. That makes it inconsistent. I believe the problem lies in fedora-logos package, because it contains a different looking icon for 256x256 size than for all other sizes.

Comment 15 Kamil Páral 2014-11-24 11:54:34 UTC
Created attachment 960691 [details]
overview - missing high contrast icon

I forgot to add, I was testing with the TC3 image.

Comment 16 David Shea 2014-11-24 15:08:02 UTC
Well, this is fun. gnome-themes-standard updated from gnome-themes-standard-3.14.0-1.fc21.x86_64.rpm in TC2 to gnome-themes-standard-3.14.2-1.fc21.x86_64.rpm in TC3, and one of the changes is that the "anaconda" HighContast icon moved to "liveinst." Now, I don't disagree with this change on a philosophical level, since anaconda is specific to Fedora and it's better to keep thing like that in the Fedora-specific packages and leave upstream clean, but that's not the kind of thing to change between final test composes without telling the downstream consumers.

I mean, seriously, it's not hard to guess who might have been using the icon. We were in the freaking file name.

Comment 17 Matthias Clasen 2014-11-24 15:33:16 UTC
That change was made because the hc icon that is included in gnome-themes-standard is the hc version of the liveinst icon. Not the hc version of the anaconda icon.

Comment 18 Matthias Clasen 2014-11-24 15:34:04 UTC
this entire mess could easily be avoided if anaconda just shipped full-color and hc versions of all the icons it cares about.

Comment 19 David Shea 2014-11-24 15:42:20 UTC
(In reply to Matthias Clasen from comment #17)
> That change was made because the hc icon that is included in
> gnome-themes-standard is the hc version of the liveinst icon. Not the hc
> version of the anaconda icon.

That's great and all, but again, this change was a surprise, we're in a change freeze, and if this change hadn't happened then everything would be fixed. The only differences between the two gnome-themes-standard packages are to 1) move the icon that anaconda was using to something anaconda is not using, and 2) add a couple of Kazakh transliterations. That seems kinda spiteful.

At this point fixing it the "right" way would mean more changes to anaconda and more changes to fedora-logos, and the easy way would be to just revert a change to a filename that never should have gone in in the first place. (In reply to 

> this entire mess could easily be avoided if anaconda just shipped full-color
> and hc versions of all the icons it cares about.

It could also be avoided by acknowledging that the "gnome" themes are part of the look of gtk and effectively part of downstream API.

Comment 20 Matthias Clasen 2014-11-24 15:53:51 UTC
(In reply to David Shea from comment #19)
> (In reply to Matthias Clasen from comment #17)
> > That change was made because the hc icon that is included in
> > gnome-themes-standard is the hc version of the liveinst icon. Not the hc
> > version of the anaconda icon.
> 
> That's great and all, but again, this change was a surprise, we're in a
> change freeze, and if this change hadn't happened then everything would be
> fixed. The only differences between the two gnome-themes-standard packages
> are to 1) move the icon that anaconda was using to something anaconda is not
> using, and 2) add a couple of Kazakh transliterations. That seems kinda
> spiteful.

spiteful ?! This change was made to _fix_ the lack of hc icon for the liveinst icon. Iirc, there was a blocker bug for this somewhere...

Lets just make the icon available under both names for now.

Comment 21 Fedora Update System 2014-11-24 16:54:35 UTC
gnome-themes-standard-3.14.2-2.fc21 has been submitted as an update for Fedora 21.
https://admin.fedoraproject.org/updates/gnome-themes-standard-3.14.2-2.fc21

Comment 22 Fedora Update System 2014-11-24 20:57:42 UTC
Package gnome-themes-standard-3.14.2-2.fc21:
* should fix your issue,
* was pushed to the Fedora 21 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing gnome-themes-standard-3.14.2-2.fc21'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2014-15639/gnome-themes-standard-3.14.2-2.fc21
then log in and leave karma (feedback).

Comment 23 Fedora Update System 2014-11-25 03:06:26 UTC
python-blivet-0.61.10-1.fc21, anaconda-21.48.16-1.fc21 has been pushed to the Fedora 21 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 24 Petr Schindler 2014-11-25 14:19:21 UTC
Beautiful high contrast icon is on TC4.

Comment 25 Fedora Update System 2014-11-25 22:37:16 UTC
gnome-themes-standard-3.14.2-2.fc21 has been pushed to the Fedora 21 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.