Bug 1162856 - Missing high contrast icon
Summary: Missing high contrast icon
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: fedora-logos
Version: 21
Hardware: x86_64
OS: Linux
unspecified
high
Target Milestone: ---
Assignee: Tom "spot" Callaway
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: AcceptedBlocker
Depends On:
Blocks: F21FinalBlocker 1160499
TreeView+ depends on / blocked
 
Reported: 2014-11-11 21:24 UTC by David Shea
Modified: 2014-11-22 00:46 UTC (History)
16 users (show)

Fixed In Version: fedora-logos-21.0.5-1.fc21
Doc Type: Bug Fix
Doc Text:
Clone Of: 1160499
Environment:
Last Closed: 2014-11-22 00:46:14 UTC
Type: Bug


Attachments (Terms of Use)
high contrast desktop (287.97 KB, image/png)
2014-11-11 21:24 UTC, David Shea
no flags Details

Description David Shea 2014-11-11 21:24:47 UTC
Created attachment 956424 [details]
high contrast desktop

This bug is for the fedora-logos changes needed to high-contrast support with fedora-welcome in the Workstation live image. Thanks to Matthias for figuring this all out.

The easy part:
- please move /usr/share/icons/Fedora/scalable/apps/anaconda.svg to /usr/share/icons/hicolor/scalable/apps/anaconda.svg

that along with a change in anaconda to refer to the icon by icon-name fixes the fedora-welcome app itself.

Extra credit:
There's still a couple of launcher icons that don't have high contrast versions, though. In the attached image, the Fedora logo referenced by fedora-welcome.desktop as Icon=/usr/share/icons/Fedora/256x256/places/start-here.png. "start-here" is also provided by gnome-themes-standard, though, as the gnome foot, so that'll need a new name if it's to be iconized.

The hard drive with a green check mark is installed by anaconda to /usr/share/icons/hicolor/*/apps/liveinst.png and comes from bug 588737. For a high contrast version we would need a new file and can take care of the rest re: paths and such, or if fedora-logos wants to take ownership of that file instead that would be pretty great.

+++ This bug was initially created as a clone of Bug #1160499 +++

Description of problem: The Install to Hard Drive app on the Workstation live image does not have a high contrast variant.


Version-Release number of selected component (if applicable): anaconda-21.48.13-1.fc21


How reproducible: Always


Steps to Reproduce:
1. Launch Fedora 21 Workstation Beta live image
2. Turn on high contrast in System Settings

Actual results: Anaconda's icon does not change.


Expected results: Anaconda's icon changes to a high contrast icon in approximately the same style as the other high contrast icons.


Additional info: Proposing as F21 final blocker under the criterion "All applications installed by default in Fedora Workstation must comply with each MUST and MUST NOT guideline in the Applications and Launchers policy." [1]

In particular:

"App launchers MUST have a unique 128×128 launcher icon with an alpha channel and a matching High Contrast icon." [2]

A strong case could be made that anaconda does not technically trigger this criterion since it is not actually installed on the system... but that's really a technicality, and I'd simply suggest rewording the criterion from "installed by default" to "on the live image."

[1] https://fedoraproject.org/wiki/Fedora_21_Final_Release_Criteria#Default_application_functionality

[2] https://fedoraproject.org/wiki/Workstation/Guidelines/Applications_and_Launchers#For_launchers:


--- Additional comment from Matthias Clasen on 2014-11-11 14:08:20 EST ---

fedora-welcome is using the anaconda.svg icon by its full path, so it doesn't benefit from the highcontrast variant of the anaconda icon that is provided by gnome-themes-standard. Changing fedora-welcome to use the icon by name is trivial enough, but doesn't actually work. Or rather, it solves the problem in HighContrast, but breaks it in non-HighContrast, because the full-color anaconda icon is installed into a no-longer-existing icon theme called Fedora. So, to fix the icon in fedora-welcome, two things are needed:

1) install the anaconda icon into hicolor instead of Fedora

2) replace 

      let pix = GdkPixbuf.Pixbuf.new_from_file_at_size(
          '/usr/share/icons/Fedora/scalable/apps/anaconda.svg',
          256, 256);
      installContent.add(new Gtk.Image({ pixbuf: pix }));


by

      installContent.add(new Gtk.Image({ icon_name: 'anaconda',
                                         pixel_size: 256 });


To make fedora-welcome show visible text in HighContrast, you additionally need to remove the unnecessarily hard-coded white text color in two places:

--- /usr/share/anaconda/gnome/fedora-welcome	2014-10-28 14:01:35.000000000 -0400
+++ fedora-welcome	2014-11-11 14:05:46.265025084 -0500
@@ -40,14 +40,14 @@
     let widget = new Gtk.Label();
 
     if (button)
-        widget.set_markup('<b><span size="x-large" color="white">' + label + '</span></b>');
+        widget.set_markup('<b><span size="x-large">' + label + '</span></b>');
     else {
         widget.set_line_wrap(true);
         widget.set_justify(Gtk.Justification.CENTER);
         widget.set_margin_top(32);
         widget.set_margin_bottom(32);
 
-        widget.set_markup('<span size="large" color="white">' + label + '</span>');
+        widget.set_markup('<span size="large">' + label + '</span>');
     }
 
     return widget;

Comment 1 Fedora Blocker Bugs Application 2014-11-17 18:44:14 UTC
Proposed as a Blocker for 21-final by Fedora user dshea using the blocker tracking app because:

 This change is required for bug 1160499, which was accepted as a 21-final blocker.

Comment 2 Kamil Páral 2014-11-18 10:55:16 UTC
(In reply to Fedora Blocker Bugs Application from comment #1)
>  This change is required for bug 1160499, which was accepted as a 21-final
> blocker.

If I am not mistaken, proposing this is not strictly necessary, because this bug already blocks bug 1160499, which makes it a blocker transitively. But no harm done even this way.

Comment 3 Ryan Lerch 2014-11-18 15:49:17 UTC
Do the two new hi-contrast icons (fedora logo, and install to HDD icon) need the full set of icon sizes? or does the criteria just state the launcher?

Is the 256x256 icon always shown on the launcher?

Comment 4 David Shea 2014-11-18 16:03:55 UTC
I'm not sure how to answer your questions so here's some more technical details.

/usr/share/icons/Fedora/256x256/places/start-here.png (the fedora logo) is used by (and as far as I know, only by) fedora-welcome. fedora-welcome is started via autostart upon logging in as the live user, but the desktop file sets NoDisplay and thus fedora-welcome does not appear in the activities menu.

The install to hdd icon currently has, in the anaconda repo, sizes for 16x16, 22x22, 24x24, 32x32, 48x48, and 256x256. If any of these are unneeded, let us know. This icon is referenced by icon name by liveinst.desktop. liveinst does appear in the activities menu.

Comment 5 Michael Catanzaro 2014-11-18 18:22:38 UTC
The upstream GNOME requirement for application icons is for 256x256px, 48x48px, 32x32px, 24x24px and 16x16px variants of the icon, with 512x512px recommended but optional, and all other sizes (notably 22x22px and 128x128px) are unnecessary (but harmless). [1] That would be the ideal resolution to this bug. But in contrast, the Fedora Workstation requirement [2] -- which applies to this bug -- is specifically that a 128x128px icon must be present. It mentions no other icon size, but the intent behind the requirement was that 256x256px is a high bar for applications to meet, and that a 128x128px icon would be sufficient if a 256x256px icon is not provided (the wording can be uncontroversially changed if there's concern about not actually including a 128x128px icon). It's not even clear from the wording that the icon size requirement applies to the high contrast icon at all.

So... take that as you will. The Fedora criteria is not really very specific. I suspect whatever high contrast icons you provide will be gratefully accepted. In particular, if the non-high contrast start here logo only exists as a 256x256px icon, then there's not much sense in expecting more sizes from the high contrast variant.

(In reply to Ryan Lerch from comment #3)
> Do the two new hi-contrast icons (fedora logo, and install to HDD icon) need
> the full set of icon sizes? or does the criteria just state the launcher?

The Fedora criteria specifically applies to the launcher. [1]

> Is the 256x256 icon always shown on the launcher?

On normal displays, I think so, for both the app grid and the dock (so it will be used even if NoDisplay=false), with a fallback to smaller icon sizes if not present. (I think a 512x512px icon will be used instead on high-DPI displays.) The icon used for the app menu (next to Activities when the app is focused) is 48x48px (on normal displays, again with fallback to other sizes if not present).

[1] https://people.gnome.org/~tobiasmue/hig3/icons-and-artwork.html
[2] https://fedoraproject.org/wiki/Workstation/Guidelines/Applications_and_Launchers

Comment 6 David Shea 2014-11-18 18:33:01 UTC
On IRC it was decided that the best way to handle start-here.png (the Fedora logo in the taskbar) is to get rid of it. fedora-welcome is automatically started and not available in the activities menu, so there's not much point in having it in the taskbar. anaconda will set skip-taskbar-hint on the GtkWindow and drop the Icon= from the desktop file.

Comment 7 Mike Ruckman 2014-11-19 16:25:35 UTC
Discussed in 2014-11-19 blocker review meeting. This bug is a clear violation of the Final criterion: All applications installed by default in Fedora Workstation must comply with each MUST and MUST NOT guideline in the Applications and Launchers policy.

Comment 8 Michael Catanzaro 2014-11-19 17:21:42 UTC
(In reply to David Shea from comment #6)
> On IRC it was decided that the best way to handle start-here.png (the Fedora
> logo in the taskbar) is to get rid of it. fedora-welcome is automatically
> started and not available in the activities menu, so there's not much point
> in having it in the taskbar. anaconda will set skip-taskbar-hint on the
> GtkWindow and drop the Icon= from the desktop file.

A bit confused on the technical details here: what icon will be displayed for the app menu when fedora-welcome is running? What icon will be displayed for fedora-welcome in the dock, should the user open the overview before closing fedora-welcome? We don't want to wind up with the empty window placeholder icon.

Comment 9 David Shea 2014-11-19 17:56:32 UTC
(In reply to Michael Catanzaro from comment #8)
> (In reply to David Shea from comment #6)
> > On IRC it was decided that the best way to handle start-here.png (the Fedora
> > logo in the taskbar) is to get rid of it. fedora-welcome is automatically
> > started and not available in the activities menu, so there's not much point
> > in having it in the taskbar. anaconda will set skip-taskbar-hint on the
> > GtkWindow and drop the Icon= from the desktop file.
> 
> A bit confused on the technical details here: what icon will be displayed
> for the app menu when fedora-welcome is running? 

None. It won't have an app menu it is a ghost.

https://dshea.fedorapeople.org/fedora-welcome/normal.png

> What icon will be displayed
> for fedora-welcome in the dock, should the user open the overview before
> closing fedora-welcome?

oooOOOOOoOoooooooo

https://dshea.fedorapeople.org/fedora-welcome/overview.png

It's kind of weird (spooky?) that it disappears entirely when you switch to the overview but we live in an imperfect world with an imperfect gnome-shell.

Comment 10 Fedora Update System 2014-11-20 03:02:15 UTC
fedora-logos-21.0.5-1.fc21 has been submitted as an update for Fedora 21.
https://admin.fedoraproject.org/updates/fedora-logos-21.0.5-1.fc21

Comment 11 Fedora Update System 2014-11-20 09:06:51 UTC
Package fedora-logos-21.0.5-1.fc21:
* should fix your issue,
* was pushed to the Fedora 21 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing fedora-logos-21.0.5-1.fc21'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2014-15444/fedora-logos-21.0.5-1.fc21
then log in and leave karma (feedback).

Comment 12 Kamil Páral 2014-11-20 10:31:46 UTC
After upgrading fedora-logos on TC2 Live, fedora-welcome no longer starts. I assume anaconda changes are necessary first.

Comment 13 Fedora Update System 2014-11-22 00:46:14 UTC
fedora-logos-21.0.5-1.fc21 has been pushed to the Fedora 21 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.