Bug 1160616 - builddep plugin does not print missing deps
Summary: builddep plugin does not print missing deps
Keywords:
Status: CLOSED DUPLICATE of bug 1155211
Alias: None
Product: Fedora
Classification: Fedora
Component: dnf-plugins-core
Version: 21
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Packaging Maintenance Team
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-11-05 09:11 UTC by Miroslav Suchý
Modified: 2014-11-11 12:45 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-11-11 12:45:46 UTC


Attachments (Terms of Use)
Proposed patch to resolve this issue (1.85 KB, patch)
2014-11-05 09:30 UTC, Miroslav Suchý
no flags Details | Diff

Description Miroslav Suchý 2014-11-05 09:11:32 UTC
Description of problem:
When you run:
  dnf builddep some.src.rpm
and there is missing dependency, it will just print:
  Error: no package matched
While previously
  yum-builddep some.src.rpm
print nicely:
  Error: No Package found for bar
  Error: No Package found for foo

It would be nice to preserve this functionality, so mock can parse the output and do something about it.

Version-Release number of selected component (if applicable):
dnf-plugins-core-0.1.3-1.fc21.noarch

How reproducible:
always

Steps to Reproduce:
1. create src.rpm with 
   BuildRequires: foo bar
2. compare output of:
  dnf builddep some.src.rpm
  yum-builddep some.src.rpm

Actual results:
  Error: no package matched

Expected results:
  Error: No Package found for bar
  Error: No Package found for foo

Comment 1 Radek Holy 2014-11-05 09:19:57 UTC
Thank you for the report.

I'd just add that it would be even necessary to document the expected output. Otherwise Miroslav would be depending on an undocumented (ie. unsupported) feature. I would introduce a switch or a new command that would have a documented output (not only) for this purpose like Git's plumbing and porcelain functions (http://git-scm.com/book/en/Git-Internals-Plumbing-and-Porcelain).

Comment 2 Miroslav Suchý 2014-11-05 09:30:50 UTC
Created attachment 953972 [details]
Proposed patch to resolve this issue

Comment 3 Honza Silhan 2014-11-11 12:45:46 UTC

*** This bug has been marked as a duplicate of bug 1155211 ***


Note You need to log in before you can comment on or make changes to this bug.