Bug 1155211 - dnf builddep: print what's missing when package not found
dnf builddep: print what's missing when package not found
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: dnf-plugins-core (Show other bugs)
20
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Honza Silhan
Fedora Extras Quality Assurance
:
: 1160616 1174336 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2014-10-21 11:01 EDT by Michael Simacek
Modified: 2015-02-20 03:32 EST (History)
9 users (show)

See Also:
Fixed In Version: hawkey-0.5.3-2.fc21
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-02-20 03:32:17 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michael Simacek 2014-10-21 11:01:08 EDT
Description of problem:
Current error output of dnf builddep command is not very useful. When it cannot find some of the dependencies, it prints only "No package matched", but doesn't say what's missing.

Example:
sudo dnf builddep sonarqube-5.0-M7.1.fc22.src.rpm
Error: no package matched

Yum lists all the things that are missing, in this case:
Error: No Package found for animal-sniffer
Error: No Package found for backport-util-concurrent
Error: No Package found for fest-assert
Error: No Package found for jruby-rack
Error: No Package found for maven-surefire-provider-junit4
Error: No Package found for picocontainer >= 2.14.1
Error: No Package found for reflections
Error: No Package found for sonar-packaging-maven-plugin
Error: No Package found for sonar-update-center-common
Error: No Package found for staxmate

Could this be improved?
Comment 1 Honza Silhan 2014-11-05 09:30:12 EST
it can, PR created.
Comment 2 Honza Silhan 2014-11-11 07:45:46 EST
*** Bug 1160616 has been marked as a duplicate of this bug. ***
Comment 3 Craig Ringer 2014-12-27 04:25:41 EST
Still seeing this in dnf 0.6.3 in Fedora 21, and it's a major issue when debugging builds, especially via mock for multiple arches.

What's the PR URL? A search on https://github.com/rpm-software-management/dnf/pulls for 1155211 doesn't find anything.  Nor a search for 'builddep'.
Comment 4 Miroslav Suchý 2015-01-05 06:27:00 EST
*** Bug 1174336 has been marked as a duplicate of this bug. ***
Comment 5 Honza Silhan 2015-01-05 12:18:10 EST
Craig, here: https://github.com/rpm-software-management/dnf-plugins-core/pull/44. You can test it if you built it. I will need to fix minor issues within this PR.
Comment 6 Fedora Update System 2015-02-15 19:03:06 EST
dnf-plugins-core-0.1.5-1.fc21,hawkey-0.5.3-2.fc21,dnf-0.6.4-1.fc21 has been submitted as an update for Fedora 21.
https://admin.fedoraproject.org/updates/dnf-plugins-core-0.1.5-1.fc21,hawkey-0.5.3-2.fc21,dnf-0.6.4-1.fc21
Comment 7 Fedora Update System 2015-02-17 03:04:00 EST
Package hawkey-0.5.3-2.fc21, dnf-plugins-core-0.1.5-1.fc21, dnf-0.6.4-1.fc21:
* should fix your issue,
* was pushed to the Fedora 21 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing hawkey-0.5.3-2.fc21 dnf-plugins-core-0.1.5-1.fc21 dnf-0.6.4-1.fc21'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2015-2139/dnf-plugins-core-0.1.5-1.fc21,hawkey-0.5.3-2.fc21,dnf-0.6.4-1.fc21
then log in and leave karma (feedback).
Comment 8 Fedora Update System 2015-02-20 03:32:17 EST
hawkey-0.5.3-2.fc21, dnf-plugins-core-0.1.5-1.fc21, dnf-0.6.4-1.fc21 has been pushed to the Fedora 21 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.