Bug 116083 - Impossible to determine if soundcard is correctly detected because volume is set to 0
Impossible to determine if soundcard is correctly detected because volume is ...
Status: CLOSED DUPLICATE of bug 115932
Product: Fedora
Classification: Fedora
Component: firstboot (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Brent Fox
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-02-17 22:05 EST by Aaron VanDevender
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 14:01:23 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Aaron VanDevender 2004-02-17 22:05:34 EST
Description of problem:

Once the soundcard detection determines what hardware is available and
installs the appropriate ALSA module, it attempts to play a sound clip
to allow the user to verify that the sound is working properly. The
problem is that when the ALSA drivers are loaded for the first time,
the volume is set to 0 across the board, so even if the correct
drivers are installed, no sound will be produced.

Version-Release number of selected component (if applicable):

firstboot 1.3.3-3
system-config-soundcard 1.2.2-1

How reproducible:
Always when loading ALSA drivers.

Steps to Reproduce:
1. Try to configure a soundcard using the ALSA drivers.
2. Play the test sound.
3. Listen to the sounds of silence.

Actual results:
No test sound is heard.

Expected results:
After loading the alsa drivers it should set the volume to a
reasonable level before playing the test sound. There are a couple of
ways to do this, but probably using alsactl is the simplest.
Comment 1 Bill Nottingham 2004-02-18 00:32:54 EST

*** This bug has been marked as a duplicate of 115932 ***
Comment 2 Red Hat Bugzilla 2006-02-21 14:01:23 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.