Bug 1160931 - fedup to F21 fails due to missing 'fedora-install-21' repo in mirrormanager
Summary: fedup to F21 fails due to missing 'fedora-install-21' repo in mirrormanager
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: distribution
Version: 21
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: ---
Assignee: Václav Pavlín
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: https://fedoraproject.org/wiki/Common...
: 1161464 (view as bug list)
Depends On:
Blocks: F21FinalBlocker
TreeView+ depends on / blocked
 
Reported: 2014-11-06 02:29 UTC by Adam Williamson
Modified: 2014-11-12 15:36 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-11-12 15:36:00 UTC


Attachments (Terms of Use)

Description Adam Williamson 2014-11-06 02:29:08 UTC
Currently, fedup to 21 fails unless --instrepo is explicitly specified, because the 'fedora-install-21' repo does not exist in mirrormanager. fedup looks for:

https://mirrors.fedoraproject.org/metalink?repo=fedora-install-21&arch=(arch)

and fails.

If I understood him correctly, Dennis told me we actually can't fix this as easily as you'd think, because for some reason we can't have two mirrormanager 'repos' pointing to the same place, but to fix this we'd want to have both fedora-server-21 and fedora-install-21 pointing to:

https://dl.fedoraproject.org/pub/alt/stage/21_TC1/Server

so in a weird way, this actually depends on https://bugzilla.redhat.com/show_bug.cgi?id=1128474 .

Dennis, might it be possible to do something a bit hacky like point fedora-server-21 at Beta and fedora-install-21 at Final TC1? it's not entirely 'correct' but it shouldn't really break too badly. Once we have a TC2 we could fiddle it around a bit more. Once we fix #1128474 we could leave fedora-server-21 pointing at whatever the last compose was that needed a Product-specific repo, and keep fedora-install-21 pointing at the latest compose (or at TC1 if we want to be sure it's pointed at something 'safe', and use --instrepo for testing the latest compose).

Proposing as a Final blocker:

"For each one of the release-blocking package sets, it must be possible to successfully complete an upgrade from a fully updated installation of the previous stable Fedora release with that package set installed. The user must be made to specify which Product (or none) they wish to have running when upgrade is complete."

https://fedoraproject.org/wiki/Fedora_21_Beta_Release_Criteria#Upgrade_requirements

Comment 1 Will Woods 2014-11-10 17:42:27 UTC
*** Bug 1161464 has been marked as a duplicate of this bug. ***

Comment 2 Adam Williamson 2014-11-11 03:46:42 UTC
releng fixed this up a couple of days ago, I think we're currently using something like my suggestion in the description.

Comment 3 Kamil Páral 2014-11-12 15:36:00 UTC
http://mirrors.fedoraproject.org/mirrorlist?repo=fedora-install-21&arch=x86_64 works correctly and I just tried `fedup --network 21 --product workstation` from F20 and it works well. Closing as fixed.


Note You need to log in before you can comment on or make changes to this bug.