Bug 1161015 - [USS]: snapd process is not killed once the glusterd comes back
Summary: [USS]: snapd process is not killed once the glusterd comes back
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: glusterd
Version: mainline
Hardware: x86_64
OS: Linux
unspecified
high
Target Milestone: ---
Assignee: Sachin Pandit
QA Contact:
URL:
Whiteboard: USS
Depends On: 1158883 1240338 1240952 1240955
Blocks: 1175735
TreeView+ depends on / blocked
 
Reported: 2014-11-06 07:28 UTC by Sachin Pandit
Modified: 2015-07-26 22:06 UTC (History)
6 users (show)

Fixed In Version: glusterfs-3.7.0
Doc Type: Bug Fix
Doc Text:
Clone Of: 1158883
: 1175735 (view as bug list)
Environment:
Last Closed: 2015-05-14 17:28:20 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)

Comment 1 Anand Avati 2014-11-06 13:37:13 UTC
REVIEW: http://review.gluster.org/9062 (USS : Kill snapd during glusterd restart if USS is disabled.) posted (#1) for review on master by Sachin Pandit (spandit@redhat.com)

Comment 2 Anand Avati 2014-11-10 12:26:36 UTC
REVIEW: http://review.gluster.org/9062 (USS : Kill snapd during glusterd restart if USS is disabled.) posted (#2) for review on master by Sachin Pandit (spandit@redhat.com)

Comment 3 Anand Avati 2014-11-10 12:35:09 UTC
REVIEW: http://review.gluster.org/9062 (USS : Kill snapd during glusterd restart if USS is disabled) posted (#3) for review on master by Sachin Pandit (spandit@redhat.com)

Comment 4 Anand Avati 2014-11-11 07:53:49 UTC
REVIEW: http://review.gluster.org/9062 (USS : Kill snapd during glusterd restart if USS is disabled) posted (#4) for review on master by Sachin Pandit (spandit@redhat.com)

Comment 5 Anand Avati 2014-11-13 07:03:18 UTC
REVIEW: http://review.gluster.org/9062 (USS : Kill snapd during glusterd restart if USS is disabled) posted (#5) for review on master by Sachin Pandit (spandit@redhat.com)

Comment 6 Anand Avati 2014-11-17 04:55:20 UTC
REVIEW: http://review.gluster.org/9062 (USS : Kill snapd during glusterd restart if USS is disabled) posted (#6) for review on master by Sachin Pandit (spandit@redhat.com)

Comment 7 Anand Avati 2014-11-17 06:23:30 UTC
REVIEW: http://review.gluster.org/9062 (USS : Kill snapd during glusterd restart if USS is disabled) posted (#7) for review on master by Sachin Pandit (spandit@redhat.com)

Comment 8 Anand Avati 2014-11-17 07:35:48 UTC
REVIEW: http://review.gluster.org/9062 (USS : Kill snapd during glusterd restart if USS is disabled) posted (#8) for review on master by Sachin Pandit (spandit@redhat.com)

Comment 9 Anand Avati 2014-11-17 11:38:20 UTC
COMMIT: http://review.gluster.org/9062 committed in master by Krishnan Parthasarathi (kparthas@redhat.com) 
------
commit a7ec009499f2c8f0c96aa03110ff4755eef8f1b8
Author: Sachin Pandit <spandit@redhat.com>
Date:   Wed Nov 5 11:09:59 2014 +0530

    USS : Kill snapd during glusterd restart if USS is disabled
    
    Problem : When glusterd is down on one of the nodes and during that
    time if USS is disabled then snapd will still be running
    in the node where glusterd was down.
    
    Solution : during restart of glusterd check if USS is disabled,
    if so then issue a kill for snapd.
    
    NOTE : The test case which I wrote in my previous patchset
    is facing some spurious failures, hence I thought of removing
    that test case. I'll add the test case once the issue is resolved.
    
    Change-Id: I2870ebb4b257d863cdfc319e8485b19e932576e9
    BUG: 1161015
    Signed-off-by: Sachin Pandit <spandit@redhat.com>
    Reviewed-on: http://review.gluster.org/9062
    Reviewed-by: Rajesh Joseph <rjoseph@redhat.com>
    Reviewed-by: Avra Sengupta <asengupt@redhat.com>
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Krishnan Parthasarathi <kparthas@redhat.com>
    Tested-by: Krishnan Parthasarathi <kparthas@redhat.com>

Comment 10 Niels de Vos 2015-05-14 17:28:20 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.7.0, please open a new bug report.

glusterfs-3.7.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://thread.gmane.org/gmane.comp.file-systems.gluster.devel/10939
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user

Comment 11 Niels de Vos 2015-05-14 17:35:41 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.7.0, please open a new bug report.

glusterfs-3.7.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://thread.gmane.org/gmane.comp.file-systems.gluster.devel/10939
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user

Comment 12 Niels de Vos 2015-05-14 17:38:03 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.7.0, please open a new bug report.

glusterfs-3.7.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://thread.gmane.org/gmane.comp.file-systems.gluster.devel/10939
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user

Comment 13 Niels de Vos 2015-05-14 17:44:36 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.7.0, please open a new bug report.

glusterfs-3.7.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://thread.gmane.org/gmane.comp.file-systems.gluster.devel/10939
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user


Note You need to log in before you can comment on or make changes to this bug.