This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 116108 - Cannot add Member to Role
Cannot add Member to Role
Status: CLOSED WONTFIX
Product: Red Hat Enterprise CMS
Classification: Retired
Component: ui (Show other bugs)
nightly
All Linux
medium Severity medium
: ---
: ---
Assigned To: Scott Seago
Daniel Berrange
http://youth.aplaws.org.uk/ccm/conten...
:
: 116115 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-02-18 06:19 EST by James Kearns
Modified: 2008-10-06 09:39 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-10-06 09:39:04 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description James Kearns 2004-02-18 06:19:48 EST
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.0)

Description of problem:


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Log in with Site Wide Administrator group permissions.
2. Go to Roles tab. Select "First Time Author" role.  
3. Click "Add member". Use Search. Tick "content Administration First 
Time Author" from results. 
4. Click "Add Members" button.
    

Actual Results:  An unexpected error has occurred.

Expected Results:  Automatically returned to Role details screen.
"content Administration First Time Author" now appears in Members 
list.

Additional info:

Can achieve expected results with other members, for 
example, "Heather Fishlock"
Comment 1 Daniel Berrange 2004-02-18 06:26:10 EST
'content Administration First Time Author' is in fact the internal
name for the 'First Time Author' role. So what you are attempting to
do here is to add the role to itself - which causes CMS to throw an
error. That said, CMS should not have listed this role for you when
doing the search in the first place. Thus the fix we'll apply is to
filter out these roles when doing the search

Comment 2 Daniel Berrange 2004-02-18 06:53:06 EST
*** Bug 116115 has been marked as a duplicate of this bug. ***
Comment 3 James Kearns 2004-02-18 06:55:59 EST
'content Administration First Time Author' is a Group I set up.
Comment 4 Scott Seago 2004-02-18 09:35:39 EST
Actually, we should only filter out the current role. It should be
possible to add "content administration Author" to the editor role, as
a  shortcut for making sure the same users are assigned to both roles,
in cases where that is desirable.

But yes, in this case, you were attempting to add a group to itself,
which would definitely fail. The UI should, at a minimum, filter out
the current group and all supergroups. i.e. if the content section is
"content", the role is "Author", then the system creates the "content
Administration" group which is the supergroup for all roles in the
content section, and for the "Author" role the group "content
Administration Author" is created to contain the assigned users/groups
for the role. Both of these groups should be filtered out, but
"content Administration Editor" should probably remain in the list.
Comment 5 Scott Seago 2004-02-18 11:49:27 EST
Fixed @40513:
Add member/group to role form now filters out the current role and any
of its supergroups.

Comment 6 David Lawrence 2006-07-17 22:39:59 EDT
QA_READY has been deprecated in favor of ON_QA. Please use ON_QA in the future.
Moving to ON_QA.

Note You need to log in before you can comment on or make changes to this bug.