Bug 1161616 - jabberd and init script issue
Summary: jabberd and init script issue
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora EPEL
Classification: Fedora
Component: jabberd
Version: el6
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Adrian Reber
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-11-07 13:42 UTC by Tomas Lestach
Modified: 2014-12-02 22:09 UTC (History)
3 users (show)

Fixed In Version: jabberd-2.2.14-6.el6
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-12-01 21:44:02 UTC
Type: Bug


Attachments (Terms of Use)
patch used to fix Bug 1153677 (967 bytes, text/plain)
2014-11-07 14:19 UTC, Tomas Lestach
no flags Details

Description Tomas Lestach 2014-11-07 13:42:54 UTC
Description of problem:
RHEL 6.6 initscripts cause jabberd start/restart to write the following messages:

Starting router: /usr/bin/dirname: extra operand `2>&1'
Try `/usr/bin/dirname --help' for more information.

Version-Release number of selected component (if applicable):
jabberd-2.2.14-5.el6.x86_64
initscripts-9.03.46-1.el6_6.1.x86_64

How reproducible:
Always

Steps to Reproduce:
1. Just restart jabberd servise with:
$ service jabberd restart

Actual results:
$ service jabberd restart
Terminating jabberd processes ...
Stopping s2s:                                              [  OK  ]
Stopping c2s:                                              [  OK  ]
Stopping sm:                                               [  OK  ]
Stopping router:                                           [  OK  ]
Initializing jabberd processes ...
Starting router: /usr/bin/dirname: extra operand `2>&1'
Try `/usr/bin/dirname --help' for more information.
                                                           [  OK  ]
Starting sm: /usr/bin/dirname: extra operand `2>&1'
Try `/usr/bin/dirname --help' for more information.
                                                           [  OK  ]
Starting c2s: /usr/bin/dirname: extra operand `2>&1'
Try `/usr/bin/dirname --help' for more information.
                                                           [  OK  ]
Starting s2s: /usr/bin/dirname: extra operand `2>&1'
Try `/usr/bin/dirname --help' for more information.
                                                           [  OK  ]
Expected results:
No erros/warnings

Additional info:
This messages affect Spacewalk as it uses the EPEL6 jabberd.
See related Bug 1153677 for more information.

Comment 1 Tomas Lestach 2014-11-07 14:19:23 UTC
Created attachment 954953 [details]
patch used to fix Bug 1153677

Comment 2 Adrian Reber 2014-11-14 19:51:08 UTC
Thanks for the patch. The patch was not applying (wrong filename and reversed). I hope the new build is the intended result. A diff against the jabberd el6 branch git would have been easier.

Comment 3 Fedora Update System 2014-11-14 20:01:33 UTC
jabberd-2.2.14-6.el6 has been submitted as an update for Fedora EPEL 6.
https://admin.fedoraproject.org/updates/jabberd-2.2.14-6.el6

Comment 4 Fedora Update System 2014-11-16 04:18:09 UTC
Package jabberd-2.2.14-6.el6:
* should fix your issue,
* was pushed to the Fedora EPEL 6 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=epel-testing jabberd-2.2.14-6.el6'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-EPEL-2014-4094/jabberd-2.2.14-6.el6
then log in and leave karma (feedback).

Comment 5 Fedora Update System 2014-12-01 21:44:02 UTC
jabberd-2.2.14-6.el6 has been pushed to the Fedora EPEL 6 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.