Bug 1161883 - Headphones not detected by pulseaudio
Summary: Headphones not detected by pulseaudio
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: pulseaudio
Version: 21
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Lennart Poettering
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: AcceptedBlocker
: 1161919 1162835 (view as bug list)
Depends On:
Blocks: F21FinalBlocker
TreeView+ depends on / blocked
 
Reported: 2014-11-08 19:24 UTC by Anthony Crognale
Modified: 2014-11-22 00:46 UTC (History)
24 users (show)

Fixed In Version: pulseaudio-5.0-25.fc21
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-11-22 00:46:01 UTC
Type: Bug


Attachments (Terms of Use)
Various output logs (122.53 KB, text/plain)
2014-11-08 19:24 UTC, Anthony Crognale
no flags Details
Output from alsa-info.sh (39.37 KB, text/plain)
2014-11-08 19:39 UTC, Anthony Crognale
no flags Details


Links
System ID Priority Status Summary Last Updated
FreeDesktop.org 86032 None None None Never

Description Anthony Crognale 2014-11-08 19:24:15 UTC
Created attachment 955371 [details]
Various output logs

Description of problem: My headphones are not detected by Pulseaudio. When I unplug them and replug them in, the following error message is provided in journalctl:

Nov 08 14:13:10 apollo pulseaudio[1967]: [pulseaudio] module-alsa-card.c: Availability of port 'analog-output-headphones' is inconsistent!

As a result, headphones are not listed under the available output devices in the sound settings. 

Version-Release number of selected component (if applicable):

Fedora 21
Pulseaudio - 24.20141103gitaec81.fc21


How reproducible: Reproduces every time across different sets of headphones


Steps to Reproduce:
1. Unplug headphones
2. Plug headphones in
3. Open up sound settings and see if headphones are an available output source

Actual results: Headphones are listed under available output devices


Expected results: Headphones are not listed under available output devices


Additional info:

Comment 1 Anthony Crognale 2014-11-08 19:26:41 UTC
Forgot to add kernel version: Linux apollo 3.17.2-300.fc21.x86_64 #1 SMP Thu Oct 30 19:23:48 UTC 2014 x86_64 x86_64 x86_64 GNU/Linux

Comment 2 Rex Dieter 2014-11-08 19:34:53 UTC
Please attach/post the output from 'alsa-info.sh'

Comment 3 Anthony Crognale 2014-11-08 19:39:06 UTC
Created attachment 955372 [details]
Output from alsa-info.sh

Comment 4 Joachim Frieben 2014-11-09 07:08:21 UTC
After upgrading to pulseaudio-5.0-24.20141103gitaec81.fc21, no sound is available on my desktop system any longer. This affects the normal speakers, too. Thus, this is no headphone issue. Downgrading to pulseaudio-5.0-10.fc21 restores the audio capabilities.

Comment 5 Rex Dieter 2014-11-09 14:00:00 UTC
did you restart your session after installing -24?  If not, can you test that?

I found that it's new autospawn behavior didn't seem to work until I did that too.

Comment 6 Anthony Crognale 2014-11-09 17:56:55 UTC
Joachim, I think you and I are experiencing different issues then, I have sound through my internal speakers on 24.20141103gitaec81.fc21.

Comment 7 Anthony Crognale 2014-11-09 23:02:16 UTC
Had some time to tinker. I downgraded pulseaudio and friends:

  pulseaudio.x86_64 5.0-10.fc21               pulseaudio-gdm-hooks.x86_64 5.0-10.fc21           pulseaudio-libs.x86_64 5.0-10.fc21         
  pulseaudio-libs-glib2.x86_64 5.0-10.fc21    pulseaudio-module-bluetooth.x86_64 5.0-10.fc21    pulseaudio-module-x11.x86_64 5.0-10.fc21   
  pulseaudio-utils.x86_64 5.0-10.fc21        


I can confirm that headphones now work again after running `pulseaudio -k`.

Comment 8 Nils Philippsen 2014-11-10 10:18:07 UTC
Same here with -24.20141103gitaec81.fc21 (broken) vs. -10.fc21 (working).

(In reply to Rex Dieter from comment #5)
> did you restart your session after installing -24?  If not, can you test
> that?

After installing -24 (and finding sound not working), I rebooted the machine and saw the same behavior:

- with headphones unplugged, the internal speakers were displayed as available and working
- with headphones plugged, neither headphones nor speakers were displayed as available, nor did sound work

This is on a Lenovo Thinkpad T520, FWIW.

Bug #1161919 seems to be a duplicate.

Comment 9 Shawn Starr 2014-11-10 15:41:19 UTC
I confirm this on my Lenovo Thinkpad W500.

( 101.882|   0.000) D: [pulseaudio] device-port.c: Setting port analog-output-speaker to status no
( 101.882|   0.000) W: [pulseaudio] module-alsa-card.c: Availability of port 'analog-output-headphones' is inconsistent!

running pulseaudio in debug

Comment 10 Rex Dieter 2014-11-10 16:04:24 UTC
Upstream pointed me to this thread:
http://lists.freedesktop.org/archives/pulseaudio-discuss/2014-October/022205.html

with some proposed, but not yet committed patches.

Comment 11 Satish Balay 2014-11-10 23:28:17 UTC
Same issue on a Thinkpad T430 [i.e headphones not functional]. downgrading pulseaudio gets it working.

Comment 12 Rob Adornato 2014-11-11 03:21:01 UTC
*** Bug 1161919 has been marked as a duplicate of this bug. ***

Comment 13 Rob Adornato 2014-11-11 03:29:23 UTC
Perhaps bug should be reassigned to  wtaymans@redhat.com, as my basically identical bug on the Thinkpad T410 was redirected to him.

Comment 14 Rex Dieter 2014-11-11 04:59:08 UTC
He's CC'd already, no worries.

Comment 15 Fedora Blocker Bugs Application 2014-11-11 10:05:24 UTC
Proposed as a Freeze Exception for 21-final by Fedora user pbrobinson using the blocker tracking app because:

 I believe non working headphones is part of the Working_sound beta criteria.

Comment 16 Wim Taymans 2014-11-11 14:43:59 UTC
Can't we put -10.fc21 back? switching to a git version at this stage seems to be too much risk.

Comment 17 Satish Balay 2014-11-11 16:10:30 UTC
currently 24.20141103gitaec81.fc21 is in updates testing. With the -ve karma - hopefully it won't get into release or updates. And pulseaudio-5.0-10.fc21.x86_64
would be the version in F21

https://admin.fedoraproject.org/updates/FEDORA-2014-14476/pulseaudio-5.0-24.20141103gitaec81.fc21?_csrf_token=61b9e5fd1ff32f9f72c8f0cb25708283acb21355

Comment 18 Parag Nemade 2014-11-12 08:18:23 UTC
I too find this issue on Lenovo T430s. Internal speakers without headphone plugged works fine. When plugged headphone no sound.

Comment 19 Rex Dieter 2014-11-12 12:43:14 UTC
The update that prompted this bug has been revoked,
https://admin.fedoraproject.org/updates/FEDORA-2014-14476/pulseaudio-5.0-24.20141103gitaec81.fc21

You can run,
yum distro-sync
to downgrade to the last known-good release (pulseaudio-5.0-10)

Comment 20 Rui Matos 2014-11-12 18:43:18 UTC
*** Bug 1162835 has been marked as a duplicate of this bug. ***

Comment 21 Fabiano Franz 2014-11-13 16:52:49 UTC
Same issue on a Thinkpad T440s with Fedora 21 Beta and the latest "yum update". The version right from the ISO (without the latest updates) works fine.

On "Settings" / "Sound":

- Without headphone plugged in, "Speakers - Built-In Audio" is shown as device for sound output.
- Plugs in headphone: nothing shown as device for sound output.
- Removes headphone: "Speakers - Built-In Audio" is shown again. 

On journalctl plugging in the headphone makes:

Nov 13 14:48:43 localhost.localdomain pulseaudio[1970]: [pulseaudio] module-alsa-card.c: Availability of port 'analog-output-headphones' is inconsistent!

Comment 22 Fabiano Franz 2014-11-13 16:55:15 UTC
And confirmed that a "yum distro-sync" puts PulseAudio back to 5.0-10.fc21, after a "pulseaudio -k" it's working again.

Comment 23 Fedora Update System 2014-11-14 16:10:50 UTC
pulseaudio-5.0-25.fc21 has been submitted as an update for Fedora 21.
https://admin.fedoraproject.org/updates/pulseaudio-5.0-25.fc21

Comment 24 Todd Warner 2014-11-15 00:53:34 UTC
Version: pulseaudio-5.0-24

Ditto, same issue on the Lenovo x230. I can get things working by installing the extra PulseAudio Volume Control and then forcing the laptop to use the undetected Headphones: listed as "Port: Headphones (unplugged)" -- and of course, they are plugged in. :)

So, there is a work around for my hardware, but nothing is automatic. We'll see what comes with the 5.0.25 update. Thanks

-todd

Comment 25 Fedora Update System 2014-11-15 09:21:39 UTC
Package pulseaudio-5.0-25.fc21:
* should fix your issue,
* was pushed to the Fedora 21 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing pulseaudio-5.0-25.fc21'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2014-15132/pulseaudio-5.0-25.fc21
then log in and leave karma (feedback).

Comment 26 Rob Adornato 2014-11-16 11:22:01 UTC
From my perspective, it looks like this bug is resolved.  Who gets to close it?

Comment 27 Joachim Frieben 2014-11-16 11:47:54 UTC
Package pulseaudio-5.0-25.fc21 also resolves the external speaker issue with a Lenovo ThinkPad T400 reported in comment #4.

Comment 28 Mike Ruckman 2014-11-19 18:57:37 UTC
Discussed in the 2014-11-19 blocker review meeting. This violates Beta criterion "The installed system must be able to play back sound with gstreamer-based applications." We elevated this to a blocker because it's a clear violation of the Beta Criterion.

Comment 29 Wim Taymans 2014-11-21 15:57:16 UTC
The regression should be fixed in 6.0 RC1.

Comment 30 Fedora Update System 2014-11-22 00:46:01 UTC
pulseaudio-5.0-25.fc21 has been pushed to the Fedora 21 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.