Bug 1161904 - lose Japanese environment in Spins of Fedora 21
Summary: lose Japanese environment in Spins of Fedora 21
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: spin-kickstarts
Version: 21
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Jeroen van Meeuwen
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-11-09 06:44 UTC by Keiichi SHIGA
Modified: 2014-12-06 08:29 UTC (History)
10 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-12-06 08:29:45 UTC


Attachments (Terms of Use)
In Japanese environment at installer start (84.48 KB, image/jpeg)
2014-11-09 06:44 UTC, Keiichi SHIGA
no flags Details

Description Keiichi SHIGA 2014-11-09 06:44:00 UTC
Created attachment 955411 [details]
In Japanese environment at installer start

Description of problem:
Japanese environment disappears in Xfce and MATE-Compiz version shown in Fedora 21 Beta:
 - Japanese fonts disappear (Therefore Japanese users cannot work by installation)
 - "kana kanji" (かな漢字・ibus-kkc) is not included, and Japanese input is not possible.
There is not this problem in Fedora 20, and the Japanese user can treat it normally.

Version-Release number of selected component:
Fedora 21 (Beta)

Additional info:
This problem does not produce the LXDE version.
Because Japanese environment is not always included in the KDE version, I am inapplicable in this report.

Comment 1 Wolfgang Ulbrich 2014-11-09 18:31:04 UTC
sorry, my thought was that a livecd will always use in english.
I removed those packages for size reasons in mate-compiz spin.
-vlgothic-fonts
-ibus-kkc

Can you install those packages in a livecd on an usb-stick, for testing that adding those packages fix the issue, please?

Comment 2 Wolfgang Ulbrich 2014-11-16 00:01:07 UTC

*** This bug has been marked as a duplicate of bug 1162537 ***

Comment 3 Keiichi SHIGA 2014-11-17 11:26:43 UTC
I confirmed 21-TC2.
The MATE-Compiz version confirmed improvement.
(refer to bug 1162537)
but as for the Xfce version, this improvement is not provided.
Therefore, I change status.

Comment 4 Wolfgang Ulbrich 2014-11-17 11:40:41 UTC
You should better file out a report against xfce-livecd for livecd in general, otherwise nobody will get notice of the issue.

Comment 5 Noriko Mizumoto 2014-11-26 08:46:33 UTC
The bug sounds serious to Japanese speaking user. 

I hear tell that this problem has been fixed recently, and change the component to 'spin-kickstarts' to get the attention from the maintainer.

Comment 6 Kevin Fenzi 2014-11-26 14:30:12 UTC
Please try the TC4 Xfce live and let us know if this still persists. 

It should be fixed there as well.

Comment 7 Keiichi SHIGA 2014-11-27 01:03:58 UTC
I confirmed 21_TC4.
This problem continues in Xfce version.
I do not confirm the reply of the Xfce version person in charge.

Comment 8 Kevin Fenzi 2014-11-27 01:49:09 UTC
Strange. Looking at the install logs I definitely see ibus-kkc and vlgothic-fonts both included. 

Can you identify any other missing font or ibus packages that should be included?

Comment 9 Keiichi SHIGA 2014-11-27 02:11:32 UTC
Is it really "TC4 Xfce" version that Kevin confirms?
(which is not LXDE and MATE-Compiz)
I was not able to confirm installation of ibus-kkc and vlgothic-fonts from Fedora-Live-Xfce-x86_64-21-TC4.iso which live booted.

Comment 10 Kevin Fenzi 2014-11-27 02:25:23 UTC
I've tracked down the problem. I made changes on 2014-11-21 that should have fixed this. 

TC4 was made on 2014-11-24, so I assumed my changes would be in there (and they were in the nightly composes), but they were not pulled yet. I've asked that they get pulled before the next TC/RC. 

We can retest then and hopefully it's done.

Comment 11 Keiichi SHIGA 2014-11-27 02:33:05 UTC
Thank you for Kevin, the correspondence of this problem and the current advisory.
We get next TC/RC and confirm this.

Comment 12 Kevin Fenzi 2014-11-28 18:21:52 UTC
Can you please retest with RC1?

Comment 13 Keiichi SHIGA 2014-11-29 00:51:20 UTC
I confirmed RC1, but a new bug seemed to occur and cannot install it in an installer.
I can confirm Japanese being displayed with an installer and that ibus-kkc is included from live boot.
We may wait for next RC to confirm that this problem completely solved us.

Comment 14 Kevin Fenzi 2014-11-29 00:58:16 UTC
Please do report that installer bug if you can duplicate it... there may not be another RC unless there's blocker bugs.

Comment 15 Keiichi SHIGA 2014-11-29 01:01:10 UTC
We may wait for next RC to confirm that this problem completely solved us.
but I leave a report to other people because probably other people think that it is a bug to reappear immediately.

Comment 16 Keiichi SHIGA 2014-11-29 01:02:35 UTC
Because I transmitted by mistake, please ignore Comment 15.

This bug occurs regardless of Xfce bug. Therefore a report is necessary separately.
but I leave a report to other people because probably other people think that it is a bug to reappear immediately.

Comment 17 Adam Williamson 2014-11-29 01:24:34 UTC
I ran a test of Final RC1 Workstation live with the installer in Japanese and ran into a crash at the start of installation, filed as https://bugzilla.redhat.com/show_bug.cgi?id=1169019 . Indeed it does not look related to this bug, but definitely something we should try and fix!

Comment 18 Keiichi SHIGA 2014-12-06 08:29:45 UTC
I tried RC5 and was able to confirm Fix of the problem. I can treat Japanese normally.
I thank all of you who coped with a problem and close this.


Note You need to log in before you can comment on or make changes to this bug.